The online racing simulator
VHPA v3.1.4 [updated 26/03/10]
(613 posts, started )
flyby3d - It always will be slower the more programs are using your CPU. As the program has gotten more complicated, everything begins to effect everything, so by this stage, moving almost any slider causes all the calculations to be re-done. This takes time; if I'd written this program 10 years ago, aside from making me the worlds smartest 11 year old, you'd really notice it working.

All I can suggest is keep LFS in the garage, that should limit what LFS is using, and disable on-the-fly deceleration calculations. I think I'll make that the default setting for the next release.

Quote from seinfeld :thanks bob, the only issue with doing the equally spaced gearing, I always use a 1.00 final gear no matter what car, and say the BF1 for example, when I do the equally spaced gear, I only get a 10.3% difference between gears, and your wasting 800 ish rpm ,12 % is perfect hence why im asking

So why not just alter first gear to be a little shorter then press "re-apply". Works foolproof for me.

If you want a constant 12% drop with a 1:1 ratio for 7th gear, then 1st gear needs to be 2.154:1.
thanks bob,
also for flyby 3d, this program is quite cpu intensive its simulating ,and working out a lot of calculations, so yea, have lfs in garage

now bob, can do live telemetry and integrate it with this program, that will be awesome then bob
That is on my to-do list but right at the bottom, atm. Want to get all the final little things sorted first.
Thanks Bob... just noticed the new update Keep up the great work.

About time you started calling it by wotever name you chose lol...

VEn
The last update was on the 4th, your previous post was on the 9th, commenting on the new features included in the latest release???

Perhaps you're psychic and knew I would finish the next update tonight. I'll go over it tomorrow morning and double check things, plus one extra feature I've just remembered I wanted to add, then post it here. Stay tuned.
And here it is: Download RC Final - link removed, please see first post

This should be the big v3.0 official release, only it isn't yet as I haven't updated the manual nor created the webpage yet (which is my next task). The program itself is ready, excluding any bugs you might find.

Give her a whirl!

Edit: Updates since RCX
Options:
* Adjustable scales for every graph
* New options for some graphs (notably gearing torque graph)
* New rpm selection method for top gear
* Replaced "Hide useless controls" and "Enable reverse gear adjustment" with a new "LFS Compatibility mode" that does both of those plus a lot more, and is more intelligent
Physics:
* Wheel:spring motion ratio support
Misc:
* Low-res controls updated, should be more practical to use and configurable
* Some internal improvements and optimisations
* Name chosen and logo created (see about box)
Cheers Bob,
Bet it is great to say you have reached this point of development.
Although I know there are many more things you want to add.
Thanks again for sharing this great tool and best of luck with the future development of it, I wait in anticipation
Great work. Gonna try it out right away.

Thanks for making such a great tool
Great news! I will test it during next weekend. Again big thanks for your effort.
looks good (hopefully dp1 will be back soon - is there a way to model the center sprag? if not a 30/70 torque split works ok)

one minor thing - how come the picture of the bmw f1 car says 'renault' on it?

another small item - units preference does not propagate to vehicle tools when creating a vehicle. if i set units to imperial and save preferences, vehicle data is still in metric. yes i know i can use the units converter but would be more convenient if the same units applied throughout. not a big deal of course.

also, in gearing setup the text boxes don't seem to accept overdrive (0.xx) selection - the whole thing goes haywire. using sliders works fine though. when switching vehicles gearing setup seems to remain from the previous vehicle and does not appear to switch to vehicle defaults. overall the gearing setup functionality seems a bit unstable (i'm running on vista btw, if that has any bearing on it - a horrible OS that came with my machine and i'm thiiiis close to actually buying a copy of XP and reloading the whole thing).

haven't played around too much with other functions but what i did try seems to work well.
if i say "open" settings file, isn't the programm supposed to read the data from the *.set file?
because if i set r2 slicks in lfs and open the same settings file in that setup analyser of yours, it says "road/normal" tyres in "Display: Vehicle Settings / Tyres" for my XRR...

regards
Dennis - DP1 is back in this release, you just have to add it manually. Centre sprag not modelled atm. I will re-do the car photos soon too (I want them all pointing to the right), I should probably use the BMW skin for the BF1 too.

All information is stored in SI units, and then converted to your preffered units for display. When creating a vehicle, you are inputting straight into memory, so you have to use SI units. The seperate unit converter was much easier solution, perhaps I'll have a look at doing things 'properly' later.

As for gearing, there are no defaults for each vehicle. Hence no settings change when you select another vehicle. That's what the setup files are for.
Regarding the gearing going haywire, the gearing analysis is updated everytime you change a number. Typing zero is below the minimum value of 0.5, so it is chaged to 0.5 automatically. The trouble is this positions the cursor back at the start. You now type an 8 (trying to make 0.8) and have ended up typing 80.5, which is above the upper limit of 7.5, so it is reduced to this number. The logic does not permit a higher gear to be shorter, so the gears above are set to this number, if they are not already higher. Since 7.5 is the maximum, they can't be, so all ratios end up as 7.5. Agreed this is not an ideal situation. Luckily if you know to reposition the cursor manually, this isn't a problem. I'll look at moving the cursor automatically. [done]

Micha - Ah, good point. a) Enable LFS compatability mode b) I think when I added (support for) that mode, it is doing things in the wrong order (picking the tyre compound from the setup, then regenerating the list and losing your choice). I'll have a look at fixing that now. [done]

Thanks for the problem reports guys.
OK, those two issues are fixed, program updated (download again from the same link).
I haven`t got time to test this program before now, but holy shit it`s great!
Absolutely stunning work, thank you a lot!
Quote from Bob Smith :As for gearing, there are no defaults for each vehicle. Hence no settings change when you select another vehicle. That's what the setup files are for.

perhaps a default setup file per vehicle that is automatically loaded when vehicle is loaded might be handy? not a big deal, would just make it easier and more intuitive. right now if you go from a 4-speed car to a 7-speed car and just try to run the sim without redoing setup or reloading a setup file the results are a bit odd

Quote :
Regarding the gearing going haywire, the gearing analysis is updated everytime you change a number. Typing zero is below the minimum value of 0.5, so it is chaged to 0.5 automatically. The trouble is this positions the cursor back at the start. You now type an 8 (trying to make 0.8) and have ended up typing 80.5, which is above the upper limit of 7.5, so it is reduced to this number. The logic does not permit a higher gear to be shorter, so the gears above are set to this number, if they are not already higher. Since 7.5 is the maximum, they can't be, so all ratios end up as 7.5. Agreed this is not an ideal situation. Luckily if you know to reposition the cursor manually, this isn't a problem. I'll look at moving the cursor automatically.

would there be any harm in setting the minimum at 0 instead of 0.5? if someone actually leaves a gear as 0 it can be skipped when the sim is run. just an idea for another way to solve the problem.

overall, great work! let me know when i can put a link to it on my site.
COMDLG32.OCX not regitered correctly error in Vista
Hi,

Hope you can help me. I am unable to run Project3 due to the above error. I read the posts earlier that seemed to indicate that this has been fixed for Vista. I must be missing something since I cannot work out what the actual fix was. Seems like I need to install VB or .NET runtimes on Vista for this to work.

I tried copying the included files into my System32 but they already existed except for one file that I did copy. I would have thought that Project3 would pick up the controls and dlls from the same directory it was in though?

thanks for any advice.

Andrew
Currawong - You must run this application "as administrator" the first time you run it, for the files to be registered. After that, it can be run normally.

Quote from dpcars :would there be any harm in setting the minimum at 0 instead of 0.5? if someone actually leaves a gear as 0 it can be skipped when the sim is run. just an idea for another way to solve the problem.

I like the idea of being able to skip a gear, however the gear ranges are fixed to maintain compatability with the LFS setup format.

Quote from dpcars :overall, great work! let me know when i can put a link to it on my site.

Thanks. Soon, I hope.
Thanks Bob.

I am running as Administrator. The actual error message says "a file is missing or invalid". That is why I think I must have missed something basic in your instructions.

Andrew
No idea then, I only tested it once on Vista when I was playing with it one time, I don't have it on my PC to have a further play. All I can tell you is what I had to do to get it to run, which I've done.

Any loading errors like that are not specific to my program, but are VB6 errors. A bit of googling could well prove informative.
for what it's worth i'm running vista (unfortunately) and project3 runs fine. i didn't do anything special, just unzipped everything into one directory.
Well, moving on...

The manual is now updated, plus I've fixed a few bugs and made a couple of usability improvements, all minor stuff though. I would point you all to the new spangly website... but it's not there yet. I start that tomorrow, since that's gonna take some time and you might like the update now... here it is.
Download RC Complete - link removed, please see first post
Note: enable LFS compatibility mode after unzipping if you want it to work with LFS properly
HiHI
Would like to say first of all what a nice bit of kit this is Bob great work and thanks alot

i've had no problems with any release in the past now i've just download the RC Complete Version 3.00
and i get this Error when trying to load my setup

"" This setup is for a vehicle not currently loaded in the program.
Load the relevant vehicle before attempting to open this setup again.

i'm running on windows XP April 2007
if i load the Project3-RCFinal all works fine no problems.

hope this helps

cheers n thanks again
You need to enable LFS compatability mode in the options.

Unnecessary, more detailed explanation:
The vehicle a setup is for is stored in the filename. This program checks for a vehicle with that name and selects it if it exists, else doesn't load the setup. For most of the LFS cars, the setup filename prefix does not match the car name. One of the functions of LFS compatability mode is to check against the alternate prefix instead of the vehicle name, so that the setup can be loaded and the correct vehicle automatically chosen.

In the future there will be a standard release and an LFS release, for each version. The LFS release will contain the LFS cars and have this option on by default, while the stadard release will not. Until then you just need to remember to enable it manually.
im not sure if i've done the right thing when setting up the compatibility option, so i just deleted them both and started again

reinstalled the RCComplete version then this popped up.

VHPA3
Component 'COMDLG32.OCX'or one of its dependencies not correctly registered: a file is missing or invalid. - closed window -

click Proj3.exe again, program loads but i get the same error, and will not load any setup
i've changed the compatibility option in LFS i think..

i might ask where do i change the compatibility option ?
LFS.exe /compatibility/select option

thanks again
You can find the option for 'LFS compatibility mode' in the attached screenshot.

As for the file error, the file 'COMDLG32.OCX' is included in the zip. I'm not sure what has made this want to happen now, but move that file into your windows\system32 folder. Then click Start, Run, and type in: 'REGSVR32 COMDLG32.OCX'. Click OK. Once that has executed, try loading the program again.
Attached images
here.png

VHPA v3.1.4 [updated 26/03/10]
(613 posts, started )
FGED GREDG RDFGDR GSFDG