The online racing simulator
VHPA v3.1.4 [updated 26/03/10]
(611 posts, started )
Quote from N I K I :Hi, after install I try to run program and this thing shows up, any help pls

Download and install the VB6 runtimes and extra components as linked to from here: http://www.vehicle-analyser.com/download.html

Quote from Byku :Something is wrong, at least I think so. I've made a car, in "acceleration times & distances" from 0-227.7(max speed) takes 120 sec, but in "search data for statistics" from 0-227 takes just 95 sec O.o. Ok, I understand, there is 0,7 km/h difference, but still, from 0-150 in "at&d" takes 11,829, but in "sdfs" it takes just 11,748. Why there is a difference? (there are differences in any other car also)

Two things to consider here.

1. The custom searches will always return a time that is slower by the timestep due to the subtraction of the two times that is necessary to set a minimum speed. This shouldn't be an issue. There is something wrong that is throwing those figures off; I'll have a look.

2. For top speed, the last few tenths take forever to reach (especially for low powered, heavy cars), so there will be large time differences for small changes in speed. Also the top speed used in the automated search is to a higher level of precision than you can enter (it is rounded for display in the GUI but will really be to 10 decimal places or so - whatever 8 byte floats allow). Also worth noting that there is a 120 second cut off point in the simulation, so times can never go above that.

Quote from Byku :Bob, if you want more people to test 3.1.2, announce it in the title of this thread .

I'll do that only once it is done, still fixing the odd bug and adding the licencing system.
OK, third test version.

Hopefully all the times* should always match up now, and another couple of crash bugs cured.
*with the exception of top speeds, as explained before
v3.1.2 is finally ready. Felt like it was really dragging on this time.

A little more exciting than the last update, tons of small changes:


* Double click any graph to display it in the resizable graph window
* Added engine torque/power data table for comparisons when creating engine torque curves
* Added recently used file-list (up to 8 items)
* Added custom searches to acceleration analysis
* Added multiple instances of the resizable graph window
* Added seven new graph types for acceleration analysis
* Added customisable units for volume and frequency
* Added conversion of vehicle data to user selected units when creating/editing a vehicle
* Added licence code entry for commercial users; current licence is displayed in the about box
* Added seperate small and large distance units, added units of Nm/deg for roll stiffnesses
* Will now attempt to load a photo using parts of the vehicle name, allowing shared photos
* Changed rotating mass being entered for the pair of wheels, to the mass of an individual wheel
* Changed lower shape of torque curve to be set relative, rather than absolute (e.g. 10 is always a straight line now), will give a sensible range for any engine now but will likely require presets to be updated to reflect this change
* Re-ordered the front and rear columns for vehicle wheel and tyre data
* Changed how brake bias alters wheel brake torque; now uses the same method as LFS
* Swapped gasohol (90% petrol / 10% ethanol) for E85 (15% petrol / 85% ethanol) in the vehicle fuel list
* Minor revision to clutch logic when pulling away
* Improved accuracy of acceleration and deceleration statistics
* Refined some vehicle data field and setup slider bounds
* Fixed crash due to resizing the resizeable graph window too small
* Fixed inverted setup links
* Fixed reversed forces bug
* Fixed inverse tyre diagram scaling in resizable graph window
* Fixed setup being reloaded when editing a vehicle (and thus losing any unsaved changes)
* Fixed crash upon starting when first vehicle in list did not have a default setup
* Fixed crash upon creating a vehicle with front or rear wings inside the wheelbase
* Prevented crazy damper overflow crash (doesn't fix underlying problem)
* Fixed unrounded fuel percentages being displayed
* Fixed body pitch lines in the real time acceleration viewer (they now move again)
* Fixed many possible crashes when starting VHPA with no vehicles
* Fixed setup filtering showing vehicles starting with the name of the current vehicle
* Fixed diff analysis calling bug
* Fixed springs not compressing with negative loads when anti-roll bars are used
* Fixed live info not updating when tyre compound changed
* Fixed slider position not updating in realtime acceleration viewer when changing playback speed while paused
* Fixed File->Save overwriting a file that you had asked it not to, when previously using File->Save As
* Fixed graphs units labels in options panel not updating when units are changed
* Fixed bug where the optimum shift point could end up slightly over the rev limiter


Download in the usual place, thanks to those who tested.
nice i'll check it out tomorrow
Hi guys

I'm having some trouble sorting out the .OCX files on an XP64 machine. I've put all the files in system32 but when I run reg_system_xp.bat it says it can't find COMCTL32.OCX and COMDLG32.OCX

When I try and run the VHPA program I get "Component 'COMDLG32.OCX' or one of its dependencies not correctly registered:a file is missing or invalid"

Is there a different way of registering these files for XP64 than in XP?

Thanks for your help


EDIT
Problem solved. Put the files into syswow64 instead and it did the trick
Yay
waj_uk - thanks for the info, never had anybody test it on xp64 Will add that info to the website
No Problem. Thank you very much for the program. It looks like it'll be really useful. I just need to find the best way of using all that information I now have on tap.
Great work once again Bob, thanks
Thanks (again)!
Time to (re)work my sets it seems
Ok Bob... well... got a problem. I was trying to recreate Dodge Challenger R/T from sites you added to links. I clicked to save vehicle data and this what happened. Btw.: I started creating the car from one of the cars from LFS(maybe it is something with that?)... i mean I created new vehicle using deafult data from LFS car.
Attached images
error.JPG
Ah, that's a Windows filename limitation - you can't have a "/" in a filename. I should probably run some validation checks before trying to save a file with an invalid name. I'll add that to my todo list. I thought something like that would have been built into the Microsoft Dialog Control though.

Thanks for raising the issue.
Cheers Bob, first time I actually had a look at this, seeing that I am making some error in my setup =)

Curious, when dampening goes above 100%, is the dampening capped or will it continue to dampen over 100%?
Over 100% just means over critical, so the damping is lengthening the time it takes to recover from a bump (critical damping is the point where the suspension recovers fastest), as well as making the suspension harder during transients - both negative. Hence the red highlight on the text, as you most likely don't want this.
Cheers for the clarify =) Figured it was red because it was bad, but didn't know exactly what was going on =)
I think i found a bug. Whenever you attempt to overwrite an existing setup via the save-as dialog, you have to double-click the file you want to overwrite or select it and hit ok. Sounds simple enough but if you are playing with the same file, the GUI remembers the setup that you have loaded and it will present its filename already in the "filename" dropdown in the explorer window. Simply clicking OK will not save the file. This was causing me some grief until I figured out what was happening.
This sounds like another "bug" with the Microsoft control I am using. You get a similar issue if you type a new filename, but rename a file using that window at the same time (e.g. clicking on "test", and then renaming "test" to "test_backup" will actually overwrite "test_backup", and not re-create "test"). I'll try for a work around but may just have to remove the default filename. There is always the File, Save option for this reason, though.

I was planning to add the filename in question to the overwrite confirmation dialog box anyway, which should help reduce confusion on these matters.

Thanks for the report.
I'm trying to fix this bug atm but I can't seem to reproduce it (although I can using the method I described). Could you (or someone else who can reproduce this) explain the exact steps on how to do it?

For now I've added the filename about to be overwritten in the message box that pops up. Perhaps that on its own will be enough to people over-writing the wrong setup?
Quote from Bob Smith :I'm trying to fix this bug atm but I can't seem to reproduce it (although I can using the method I described). Could you (or someone else who can reproduce this) explain the exact steps on how to do it?

For now I've added the filename about to be overwritten in the message box that pops up. Perhaps that on its own will be enough to people over-writing the wrong setup?

Actually, I never use the "save" option, always save-as. Anyway, these are the steps:

Load up a vehicle - in my case UF1. Open an existing setup from LFS setup dir. Make some changes to setup. Click on save-as and when the explorer window pops up, the filename will already be there. If you just click ok, the file will not be over-written nor will it prompt you to ok the over-write. If I follow these steps and load that setup in LFS the setup would be the same as it was before and no new setup changes would have been applied.
Aha, sussed what it is now. A prievous change had effectively broken my 'cancel detection' code, so the saving was skipped. A brief google has revealed a non ambiguous way to handle cancels, so this should all be fixed in the next version.

I should add this bug will only happen if you (try to) use Save As like Save, so for now I suggest you just use the Save feature.

Thanks for the report.
Curious that you say "for those with little mechanical knowledge", as I don't really consider myself to know all that much on the subject (although more than I did when I was 19, that's for sure). I just like cars.

I started updating the guide on my lunch breaks but I really need more than half an hour at a time to concentrate on it. It's a large task as it will be rewritten to a much higher standard than before, and will be much more thorough.

I'm trying to focus on only one thing at a time at the moment, so I can actually make visible progress. Currently, VHPA has my focus. I do want to update the guide, that will probably be next, before I get around to finishing my mod, and then I'd imagine things will go full circle. All my jobs are finite though, so it's just a matter of time.

I'm currently polishing VHPA to a standard where it can be left for a while, before I start to work on the core physics some more. If I force myself to read the guide at this point, releasing how bad it is will likely inspire me to sort it out then.
Bob, got a problem . Ok, seriously :P. My VHPA freezes when I try to calculate acceleraction(1/100th sec) in this setup/car i attached. Is it only mine problem or rather not? ^^
Attached files
LFS.ZIP - 538 B - 54 views
Just tested it in my dev version, works fine. I'll try it in the 3.1.2 release next, just in case.

That's one weird ass car, btw.

Edit: doesn't do it for me in v3.1.2 either.
strange... well that means it is with mine pc/VHPA, thx Bob . Btw. I was just playing
The way the acceleration loop is run, it should be impossible for it to run indefinitely. There is a hard limit which, when reached, will force the loop to exit (after 120 seconds of virtual time). Crashing in that loop is a different matter. Although there have been various infinite loops throughout VHPA development, to my knowledge they all got fixed quick and none ever made it into a public version.

VHPA v3.1.4 [updated 26/03/10]
(611 posts, started )
FGED GREDG RDFGDR GSFDG