The online racing simulator
Guide: Running an LFS Server
(666 posts, started )
Thanks, doing that now
Quote from the_angry_angel :Yes... Just make sure they use different ports obviously.

That's not working for us. Just one of the servers is tunning although they're using different ports and the are configured that way in the setup.cfg
Firewall issue perhaps?
Worked for me. I changed the two port lines. Not sure if they both needed doing but changed them both anyway.
Quote from the_angry_angel :Firewall issue perhaps?

Doesn't look like a firewall problem. I had open a thread this morning with details about our "problem":

EDIT: I was wrong, it is a firewall issue but we haven't been able to solve it yet, working on it and trying to guess what's wrong right now.
As a temporary fix, change your firewall so that all outgoing traffic is allowed out - does that help?
We already figured it out, it was a stupid mistake opnening the ports. The usual thing that happens when you do it quickly. When we checked the individual setup.cfg files we fixed it easily.

Now we have 6 team servers 5 of them tigh 32 slots yay! And they work just fine Thanks fot your support.
Glad to hear its working well
lfs lapper...

Just when I thought all of the sever issues were taken care of, Patch X came out! I tried downloading the new LFS lapper (for patch x.) Here is the link for the download: .When I click the download, here is what appears: lapper 1.bmp
After I click "ok", a blank firefox screen comes on with no address and no website. Why is this? Should I be opening it through another program?


NOTE: Microsoft framework 2.0 is installed.
Attached images
lapper 1.bmp
A rar file is a compressed file format. You need either WinRar, powerarchiver or something similar to open it. Firefox cannot.
I tried running it off powerarchiver. I can't start the serverl, and it is only a 30 day trial. What other programs are there I could use to run the server?

7zip -
ok well i got it working i can join it only if i go to join specific game and click on local network, i dont seen the server name anywhere in the server list, and when i go to join specific game and choose internet and put my server name in i get this error when i try joining

You may not necessarily beable to connection from within the same network as the server is running because some home routers can't cope with what they're supposed to do.

Get a friend to check for you. If they can connect then you have one such router. When the server is on the same LAN you should ideally connect via the LAN address anyway.
lfs lapper problems...

I tried downloading 7 zip, and it was successfully installed to my desktop. The only problem is that I can't figure out how to open lfs lapper through 7zip. It is trying to open up through firefox again (like it was before). Again, I tried clicking the list (shown in two posts again), and 7 zip was not on that list. Any other suggestions?

Save the file to your hard drive - some where you'll remember
Goto Start > [All] Programs and file 7-Zip, and open 7-Zip File Manager
Browse to the location of the file
Select the file and click Extract
Extract it somewhere you'll remember

Configure Lapper and the server accordingly.
Thank you so much for responding so quick,

I am almost there! Lapper is opened up through 7-zip. I have thoroughly went through the lfs lapper setup and made important changes. The only problem is I can't start lfs lapper!. When I clicked "WinMSBuildBat", the black screen came up, but it wouldn't start. Instead, it sais "error CS2001: Source File '. /src/*.cs' could not be found fatal error CS2008: No inputs specified" In the "WindowsMonoBuild" icon, it says "mcs is not recognized as an internal or external command, operable command or batch file". I am a computer noob and have no idea on what any of this means, do you have any idea?

You can find the actual bit you need to run in the "bin" directory within the rar file. Just edit the cfg file in there as appropriate
Every time we talk, I get one step closer to getting it!

Now, I filled in all of the information in the "cfg" in the "bin" folder. There is only one problem. Whenever I add new information to the "cfg", it doesn't save. What happens, is a box pops up and says, "File Lfs Lapper cfg was modified. Do you want to update it to the archive? The options are "ok" and "cancel." When I push ok, a new box comes up (red x on the left) and says "cannot update file." That means basically anything I add to the server setup wouldn't be saved.

Any Ideas?

You're editing the files in the rar itself. Edit them outside of the rar (i.e. where you extracted it). Delete the rar once you've extracted the files. It's just designed to be a single container for "shipping".
I got it! Thank you so much for your speedy support. Please come visit [MB] Racing sometime!
Glad to hear it's working [MB] Racing didnt appear to be on the master when I checked though
Hey Angel,

You've helped so many so far! Thanks a heap Now i wonder i you can help me....

I am trying to host a dedicated server on gentoo, 2.6 kernel, wine 0.9.29 (well thats what the recent portage shot says...)

i am running everything default and when i try and run LFS.exe it just dumps and exits. I run netstat to see if the port is open but there is nothing but LFS.exe and wineconsole is in the process list....

I'm just trying to run on the local network so there is no port forwarding problems yet....

This is getting on my nerves

Quote from malinkie :i am running everything default and when i try and run LFS.exe it just dumps and exits. I run netstat to see if the port is open but there is nothing but LFS.exe and wineconsole is in the process list....

What command are you using to start LFS and Wine?
'screen -dmS lfs wineconsole --backend=curses LFS.exe /cfg=setup.cfg'

I've also tried the nohup version and other versions of the command throughout this thread... i re-emerged wine last night and now, if i run just 'wineconsole --backend=curses LFS.exe' It dictates that it is trying to open X and that there is no $DISPLAY set.

The setup.cfg has 'invisible' set instead of 'nogfx'. Everything else is default atm while i try and run the server for the network.

Guide: Running an LFS Server
(666 posts, started )