The online racing simulator
Guide: Running an LFS Server
(682 posts, started )
i tried to start the server with screen and nohup. both do not working after i logout. the server always shut down. what can i do that the server wont shut down after i logout and close the xwindow?
In a terminal:
screen
[press enter]
wineconsole lfs.exe /cfg=/path/to/config
[press control + a, press d]
disconnect

If that doesn't work then you're probably actually running LFS with a visible window and therefore a server with X.org/Xfree86 running (therefore not "invisible")?
thx for your help but your hint did not work. but it was my fault i did not setup the display correct. for all linux users out there who have the same problem just export your display

screen
echo $DISPLAY
localhost:10.0 (if you get this localhost message you have to change it with the following command)
export DISPLAY=ip.of.your.server:1.0
wine LFS.exe /cfg=setup.cfg

dedicaded=nogfx
HI, it won't show up on the server list within LFS for you. It will for others. If you want to check if its showing, login to the LFS Desktop, and open Hosts online, and look for your server there. Mine never shows up in the lists in lfs. But it works great

Just hit Join rather than display lists.

As to your error. Not sure. Did you reset your modem after you setup the ports? I'd say go back to what you were doign first time; it was working then, as it said it was Online. Just make sure u reset your router after you get all ur port info in. Remember u need TCP and UDP forwarded.

V
Quote from T1_3VOM :I still get the "SetupServerSocket : bind failed" error when I run the server. LOL

Have you set the /ip directive?

Do I need to stab you in the face for ignoring the advice of not setting it?

If you've not set it then you have a firewall or another program consuming the ports LFS uses.

If you're unsure, paste your config.
running a server
Hi

I have a similar problem that Kinght had wayy back on the first page:

My server will not appear on the master server list as well. The only thing I can think of is the port... In Lfs, they say to make sure you are using the right UDP/TDP ports. How do I know if mine is right or not. If it isn't, can you somehow give me a good port to use?

Maybe this will help too: When I try to connect under "join specific game", it says client connect: connected failed

Thanks,
MBenz
T1_3VOM,
Whilst it's probably right, unless you have a multi-homed machine, I'd still recommend not supplying the /ip directive.

I can't see the game in the masterserver list at the moment, so perhaps it's shutdown, or simply not registering. In which case, take a look at the stuff below. If it's not up, then I apologise as I was out.

MBenz,
Have you checked LFSWorld, and gotten someone else to check? Some home routers can't deal with the loopback required when connecting from the same location as the server is running and basically don't report it as active in the in-game list. In this instance you have no choice but to connect via local address, as there's no fix for it except changing routers.


If it's not registered on LFSWorld, then the fact it's not registered on the masterserver suggests you have an outgoing firewall that's preventing LFS from contacting the masterserver. This maybe due to your own setup, or due to your ISP. Failing that, you've told LFS not to use the master server. Assuming you've not set /usemaster=no;

Do you have Norton Internet Security or anything like that? Windows firewall perhaps. Have you taken a look at the Windows Firewall section?

You might want to try editing the Master Server configuration in cfg.txt and change the port number to 8080 (an alternative port the Master Server is available on). If that works then it's the fault of your ISP.

If it doesn't work then you've likely got a local firewall on your network. Temporarily disable them to test and then check LFSWorld.
T1_3VOM, there were 2 responses in my last post. One for you and one for MBenz. This is for you.

I'm being a cock tonight apparently. You're quite right it is registered on the master server.

It appears that it's not answering, which goes back to the bind error, which I assume you're still getting? In which case, either something else is using the ports, or you're binding to the wrong address. In which case, remove the /ip directive and restart the server. IF you still get it then you've got something else using the ports. Another LFS server, a firewall, anything. A p2p client perhaps.
thank you so much you have been so helpful

but unfortuantely i am retarted and can't figure out how to register on LFS World. where do u go?
thanks for your help,

Yup it is registered on the website. When I connect the server to the master server, there seems to be no problem whatsoever. It says satus Online, and then lower it says Track loaded. Under "host 8080" here is the information there:

lfs=0.5V
status=online
guests=0
maxguests=9
host=LM racing server
pass=
usemaster=yes
trackcfg=BL1
cars=1110000000000000000
qual=15
laps=10
conn=

If anything seems wrong or out of the ordinary with that, please let me know. Also if you wouldn't mind, please try logging on the the server "LM racing server." Whenever i try to connect to it via "join specific game" it says CLIENT CONNECTL:CONNECT FAILED. what in the world does that mean?

Thank you for your support
Mbenz



P.S I have tried making both dedicative, and non-dedicative servers and both do not work
Ports not forwarded.
do you have to forward your ports even if you do not have a firewall up?
Ports can be typically marked as stealth because whilst the port is open, and a TCP/IP handshake occurs, nothing is actually responding, or transmitting packets from the destination.

You usually get this if the ports are forwarded on a home router, to the incorrect location, or if there's another firewall in the way.
Quote from MBenz :If anything seems wrong or out of the ordinary with that, please let me know. Also if you wouldn't mind, please try logging on the the server "LM racing server." Whenever i try to connect to it via "join specific game" it says CLIENT CONNECTL:CONNECT FAILED. what in the world does that mean?

Connect failed means that the game cannot talk to your server.

If you're trying to join using the name, try using your local address (if the server is on the same PC, use the address 127.0.0.1). If this doesn't work then it's a firewall issue.

Quote from T1_3VOM :I know I have ZA but I am unsure on how to configure the ports on that

That's probably your problem.

Take a look at this article.
http://portforward.com/english ... ve_For_Speed_ServerIn.htm

Assuming you meant a DG834G, if you're forwarded the ports correctly, the internal "firewall" on the router itself shouldn't affect it. We deploy them for home-workers and I've done some really stupid things with them, and I can vouch they work fine for hosting games behind.
Ok I am sure that this is a port issue,

It makes sense because I can connect to the server on my computer (server is on my computer) but not on another. So the question is, how do I open my ports for the public. Is that what u guys are talking about with "port forwarding?" If that is what I have to do, how do I forward a port if I do not have a firewall? I am convinced that my computer does not have any other firewall besides the Windows one, which just for this purpose i have temporarly turned completely off. I feel like I'm almost there, thanks for all of your help!!!
Quote from MBenz :It makes sense because I can connect to the server on my computer (server is on my computer) but not on another. So the question is, how do I open my ports for the public. Is that what u guys are talking about with "port forwarding?"

Sort of. To answer that I need to know what your home network is like.

How do you connect to the internet? Something like this:
One or more PCs / Laptops <----> Home Router <-----> Internet

Or like this:
One PC <---> Modem <----> Internet
I appologize, I am very uneducated with this kind of stuff

However I do know enough to be able to tell you that I have a home router; I have multiple computers linked to the same modem.
does anyone else know how to fix my problem (scroll above)
-thanks
hey need help
HI i did all wat u said and it works fine but i want the BL1R curcuit but wen i go to play it its the rally one. I want BL1R not BL2. Wats happened?
i put in BL1R in the setup folder but when i run the server that deb folder or watever had track BL2??? Why is it doing that? I put Bl1R in the setup then it runs the server with the map BL2. I dont et why its happening. Also i tryed making my own batch file but wat do i put in it exsacly? You should make a forum just for how to make a batch file for the server because you didnt tell us wat exsactly to type in it. Plz help me.
T1_3VOM,
Honestly, if I could get in front of your setup I could probably work out whats going on. Unfortunately talking people through debugging and the various things in some situations would take longer than you'd believe

Some reversions of netgear firmware may prevent you from connecting via the in-game list, in which case you can only join directly via the ip address - it shouldnt prevent others from connecting though. If it does then there's something else, somewhere blocking stuff, probably. Or you're forwarding the ports to the wrong local address.

I don't like admitting defeat, but there's a crap load of things it could be, and would probably be obvious if I was standing in front of it.

MBenz,
we'd need to know your exact network infrastructure to talk you through opening ports so that people can talk to your LFS server inside your network. Specifically we need to know the make and model of your home router.

brendonv,
A batch file is just a text file that runs commands you'd type into the command prompt. - so that it gives you a nice clickable link. You should acheive the same thing with a shortcut.

All it runs is
LFS.exe /cfg=setup.cfg

You can see this if you edit the batch file with notepad.

To be honest, and not to be mean, I've discovered that a lot of people bare read and adding more about batch files won't help - especially when its
1. out of scope
2. there are plenty of resources about batch files else where on the 'net
3. not necessary

The only reason I can think of BL2 being loaded is that you have 2 cfg files and you're not loading the right one. By default is you just double click on LFS.exe and run the dedicated that way, it will run setup.cfg. If you're not using that one, I'd suggest deleting it.
thnx man u have been alot of help. Cheers
OK I figured out all of my home router information and I think I know how to "forward my ports"

I have followed all of the instructions for my router (which I figured out is called "Linskys BEFSR81") on portforward.com.

Here is a copy of the instructions that I used: http://www.portforward.com/eng ... Live_For_Speed_Server.htm

I believe everything went well except for one part. The last instruction: ( You should see another page of settings that need to be entered into one of the blank lines on your routers Forwarding page. Go ahead and enter those settings now.) I found to be unclear. What am I supposed to change according to what you can see.

Also, you will notice that under the forwarding chart, they fill in everything, but keep the last digit of the IP adress blank. What should I fill in?

What I have done so far is fill out this table, and put a "1" in that last digit blank under IP. I feel like I'm so close, but when it tried to reconect back to my server, It said once again "Cleint Connect:Connect Failed".

I am not having a lot of luck with this, and any feedback you can give will help me a great deal.

Thank you,
MBenz
P.S if anyone else has experienced difficulty in this field, please relply too

Guide: Running an LFS Server
(682 posts, started )
FGED GREDG RDFGDR GSFDG