The online racing simulator
Guide: Running an LFS Server
(704 posts, started , go to first unread)
Quote from Kada_CZ :I overlooked this.

Try to install:
libx11-dev
xlibs-dev
libxxf86dga-dev
libxxf86misc-dev
If it doesn't work:
- What is your wine version? (wine --version)
- Did you compile wine for 64bit or do you use 32bit pre-compiled package?
- Does "wine notepad" command work (try it without tty driver)?

- wine 0.9.30
- i installed wine_0.9.30-1_amd64.deb, libwine_0.9.30-1_amd64.deb, libc6
- notepad command does not work (module not found wine failed with return code 126)
- xlibs-dev cant install (depends to another package)
- other libs are installed

do u have an icq? send me pm
First of all, you have to have working wine, it can be tested by the "wine notepad" command. If this doesn't work, then there is something wrong with your wine configuration/instalation. There can be several reasons for it (especially on a 64bit architecture). It's far beyond a scope of this thread to solve wine specific problems, I think .

My recommendation is: uninstall wine (purge it ideally), backup your configuration (~/.wine directory), then delete it (rm -r ~/.wine). Install a clean new actual version of wine (0.9.31). Run "winecfg" program, it creates a new ~/.wine directory. Try "wine notepad".

Hope this helps,
Quote from Kada_CZ :First of all, you have to have working wine, it can be tested by the "wine notepad" command. If this doesn't work, then there is something wrong with your wine configuration/instalation. There can be several reasons for it (especially on a 64bit architecture). It's far beyond a scope of this thread to solve wine specific problems, I think .

My recommendation is: uninstall wine (purge it ideally), backup your configuration (~/.wine directory), then delete it (rm -r ~/.wine). Install a clean new actual version of wine (0.9.31). Run "winecfg" program, it creates a new ~/.wine directory. Try "wine notepad".

Hope this helps,

thx for your help. one question does the notepad run under a terminal without gui?
Quote from Faikez :one question does the notepad run under a terminal without gui?

It opens a window like..... windows notepad :-). It should work with tty driver, but it won't be usable.

Hm, I just discovered, that tty driver for wine is broken/not present, at least in 0.9.31.
Quote from Kada_CZ :
If ttydriver does not work, you could use "virtual" Xvfb x-server.

The following script runs xvfb, then wine on it (untested).

#!/bin/bash
Xvfb :1 &
pid=$!
export DISPLAY=:1
wine /dir/LFS.exe
kill $pid

I still recommend, first of all get the notepad working with "real" x-windows. One more thing, if you are connecting to your linux machine (debian64) from another PC (pc) and you run x-application (wine notepad, xterm, ...), then x-server must running on the PC. There are other, more complicated methods, like VNC, see this thread.
Hi, my dedicated server appears in lfsworld.net (racers & hosts online) but not appears in the LFS browser

I also try to create a server inside the game, friends search me inside LFS and it shows that the server is running with me inside. But they can't connect.

This is not the first server I created in my PC. I created servers for other games without problems (TO, Wolf ET, SWAT4, AA...). I check all things that are explained here (router ports opened, xp firewall disabled, kaspersky shut down...) but all times the same, I can see the server in lfsworld and i can't see in LFS.

I have and XP with SP2 and a US Robotics 4 ports router. Any idea that what is my mistake?


PS: Sorry if the solution is replied in this thread. My english is bad and its hard to me to understand all.
Is there any way to ban by user id instead of typing in the user's name? I had to try and get rid of a wrecker but he cleverly typed in some character that prevented me from getting a valid response to the ban command. In fact, he cloned the name of another player beforehand, which was "I have" and I tried the obvious alternative "l have" but that did not work. I'm not even going to try typing in colors or alternative character sets...
Quote from undertech :Is there any way to ban by user id instead of typing in the user's name? I had to try and get rid of a wrecker but he cleverly typed in some character that prevented me from getting a valid response to the ban command. In fact, he cloned the name of another player beforehand, which was "I have" and I tried the obvious alternative "l have" but that did not work. I'm not even going to try typing in colors or alternative character sets...

I think that LFS bans works using the license name, not the nick in game. So if you play the demo you can't do this. To see the license name in S1 and S2 you must press SHIFT+CTRL in game, in the list that appear when you press the "N" key.
hi lads ,
i have my firewalls off barr my computer firewalls have all internet ones off !does computerhave to be two ?
also my internet box has no wireless? is that an issue
thanks guys !
Quote from 11SuLLy11 :i have my firewalls off barr my computer firewalls have all internet ones off !does computerhave to be two ?

Either there's a contradiction there, or I'm not understanding...
What firewalls do you have/use?

Quote from 11SuLLy11 :also my internet box has no wireless? is that an issue
thanks guys !

Unless you're connecting via wireless, no.
Quote from the_angry_angel :Either there's a contradiction there, or I'm not understanding...
What firewalls do you have/use?

Unless you're connecting via wireless, no.

hey mate,im using my windows firewalls !
will i have to forward my ports !?
A big help is www.portforward.com to understand how to set up your router! Once you enter portforward all you do is select your make and model of router from a very extended list and it will ask you for what application, LFS Server is listed so it tells you exactly what to do!
finally i managed to start the dedicated linux server with xing. now i have a new problem. when i use nogfx the server will start and runs perfect. but i cant close the xwindow (server would shut down). so i tried to use invisible. but the server wont start (screen is always terminating). what can i do? please help
Either start the dedi within a screen session (man screen), or run it under nohup. In either of these situations once you disconnect the server should continue to run.
i tried to start the server with screen and nohup. both do not working after i logout. the server always shut down. what can i do that the server wont shut down after i logout and close the xwindow?
In a terminal:
screen
[press enter]
wineconsole lfs.exe /cfg=/path/to/config
[press control + a, press d]
disconnect

If that doesn't work then you're probably actually running LFS with a visible window and therefore a server with X.org/Xfree86 running (therefore not "invisible")?
thx for your help but your hint did not work. but it was my fault i did not setup the display correct. for all linux users out there who have the same problem just export your display

screen
echo $DISPLAY
localhost:10.0 (if you get this localhost message you have to change it with the following command)
export DISPLAY=ip.of.your.server:1.0
wine LFS.exe /cfg=setup.cfg

dedicaded=nogfx
I have been trying for a few hours now to get a dedicated server running for my clan. I have followed the guide and opened the ports on my router. The server will not work, it will not appear on the server list either. Anyone want to try and join it?



The server is on now!

EDIT: I have opened the ports etc correctly now and whenever I start the server I get this...



What does the "SetupServerSocket ; bind failed" error mean? This is really confusing me now!
HI, it won't show up on the server list within LFS for you. It will for others. If you want to check if its showing, login to the LFS Desktop, and open Hosts online, and look for your server there. Mine never shows up in the lists in lfs. But it works great

Just hit Join rather than display lists.

As to your error. Not sure. Did you reset your modem after you setup the ports? I'd say go back to what you were doign first time; it was working then, as it said it was Online. Just make sure u reset your router after you get all ur port info in. Remember u need TCP and UDP forwarded.

V
I just started all over again and made a new .cfg and I reset the settings on the router. I then opened the ports again and probed them to check if they were open.

I still get the "SetupServerSocket : bind failed" error when I run the server. LOL
Quote from T1_3VOM :I still get the "SetupServerSocket : bind failed" error when I run the server. LOL

Have you set the /ip directive?

Do I need to stab you in the face for ignoring the advice of not setting it?

If you've not set it then you have a firewall or another program consuming the ports LFS uses.

If you're unsure, paste your config.
Well as far as I know I have the right IP address entered. For some reason when I restarted my computer is loaded the track and it says it is online. Only problem is when I try to join the server specifically it looks as if it is loading then goes straight back to the screen it was at before. I am still not sure.

/host=^7[^4D^7Pro]^4S^7how^4D^7rift
/admin=xxxxxxxxxx
/ip=192.168.0.xxx
/port=63392
/insim=29339
/mode=demo
/usemaster=yes
/track=BL1
/weather=1
/cars=XRG+XRT
/maxguests=11
/carsmax=11
/carshost=1
/carsguest=1
/pps=4
/qual=0
/laps=5
/wind=0
/dedicated=nogfx
/vote=yes
/select=yes
/rstmin=60
/rstend=30
/autokick=spectate
/midrace=yes
/mustpit=no
/start=finish
/welcome=[DPro]ShowDrift_wel.txt

That is the CFG file there. If anyone wants to try and go to the server now then please go ahead and try. It will be on for as long as it can tonight.
running a server
Hi

I have a similar problem that Kinght had wayy back on the first page:

My server will not appear on the master server list as well. The only thing I can think of is the port... In Lfs, they say to make sure you are using the right UDP/TDP ports. How do I know if mine is right or not. If it isn't, can you somehow give me a good port to use?

Maybe this will help too: When I try to connect under "join specific game", it says client connect: connected failed

Thanks,
MBenz
T1_3VOM,
Whilst it's probably right, unless you have a multi-homed machine, I'd still recommend not supplying the /ip directive.

I can't see the game in the masterserver list at the moment, so perhaps it's shutdown, or simply not registering. In which case, take a look at the stuff below. If it's not up, then I apologise as I was out.

MBenz,
Have you checked LFSWorld, and gotten someone else to check? Some home routers can't deal with the loopback required when connecting from the same location as the server is running and basically don't report it as active in the in-game list. In this instance you have no choice but to connect via local address, as there's no fix for it except changing routers.


If it's not registered on LFSWorld, then the fact it's not registered on the masterserver suggests you have an outgoing firewall that's preventing LFS from contacting the masterserver. This maybe due to your own setup, or due to your ISP. Failing that, you've told LFS not to use the master server. Assuming you've not set /usemaster=no;

Do you have Norton Internet Security or anything like that? Windows firewall perhaps. Have you taken a look at the Windows Firewall section?

You might want to try editing the Master Server configuration in cfg.txt and change the port number to 8080 (an alternative port the Master Server is available on). If that works then it's the fault of your ISP.

If it doesn't work then you've likely got a local firewall on your network. Temporarily disable them to test and then check LFSWorld.
Not sure who that was directed to but the server is listed on LFSWorld but I have been asking around for people to try and join but with no luck. They are either busy or jsut plainly can't be bothered. I will find someone though to try it!
T1_3VOM, there were 2 responses in my last post. One for you and one for MBenz. This is for you.

I'm being a cock tonight apparently. You're quite right it is registered on the master server.

It appears that it's not answering, which goes back to the bind error, which I assume you're still getting? In which case, either something else is using the ports, or you're binding to the wrong address. In which case, remove the /ip directive and restart the server. IF you still get it then you've got something else using the ports. Another LFS server, a firewall, anything. A p2p client perhaps.

Guide: Running an LFS Server
(704 posts, started )
FGED GREDG RDFGDR GSFDG