Guide: Running an LFS Server
(682 posts, started )
Question to anyone: When I try to host any of my servers I never get any people, like if I started a host today, waited a week, nobody would join?

This just started happining in the V patch :/

Any clues?
The blanks number to fill in depends on the PC you need to forward to.
For example, my server is 192.168.1.101 or 192.168.1.102 depending on which PC I am using to host.
You will have to find out what your number should be.
Open a command prompt and type ipconfig and hit enter, (on the host PC) you will get a list of numbers including the IP address you require.
thank you for all of your help, i got the server up and running!

Please come visit it, the name is:

[MB] racing
2 Questions: whats the difference between nogfx/invisible in /dedactaed=
and whats this?
// no/yes: allow car reset
/canreset=no

edit 1,000 POST
Reading the documentation is always a good idea.

Any way,

nogfx will run the dedicated host in a window where you can perform commands and monitor the server activity.

hidden will launch the dedicated host as a background process. You will not be able to monitor the server without connecting to it or using some insim application.

If I remember correctly canreset is not available in patch W. It is, however available in the test patches. Isn't the command pretty straight forward? Can clients use the 'reset' button, yes = why yes of course. No = no, they can not.
I am usin the v3 dedicated patch right from lfsforum but I dont understand what "reset" is suppost to do :S... Plus I sent a pm to TAA with a question
Reset = putting your car back on the wheels when it is on its side/roof.
Thats what I thought but I dont think it workes for me :P
/canreset=no should prevent cars from being resetable
/canreset=yes should allow cars to reset

Unless I'm missing the question? I have the feeling it's a W only thing though, if I remember correctly.
Ok, I have the server set up but no one can join... what am I doing wrong!

[html]
// host name
/host=^7[^2DWLYTS^7] Soccer
// optional: password
//pass=password
// optional: admin password
//admin=password
// optional: InSim port
//insim=29999
// optional: local specified ip address
//ip=xxx.xxx.xxx.xxx
// a high number below 65536
/port=63392
// demo/s1/s2
/mode=s2
// no/yes/hidden
/usemaster=yes
// BL1/BL1R/BL2, SO1/SO1R/SO2, etc
/track=AU1
// weather
/weather=1
// cars allowed - see README.txt
/cars=ALL
// max guests that can join host
/maxguests=11
// slots reserved for admins (0 to 8)
/adminslots=0
// max cars in a race
/carsmax=10
// max cars (real+ai) on host pc
/carshost=1
// max cars (real+ai) per guest pc
/carsguest=1
// smoothness (3-6) number of car updates per second
/pps=4
// qualifying minutes, 0 for no qualifying
/qual=0
// number of laps, 0 for practice
/laps=0
// if laps not specified: hours
//hours=24
// 0=no/1=low/2=high
/wind=1
// nogfx/invisible
/dedicated=nogfx
// no/yes: can guests vote to kick or ban
/vote=yes
// no/yes: can guests select track
/select=no
// no/yes/ban/spectate: wrong way drivers
/autokick=no
// no restart within X seconds of race start
/rstmin=1
// no restart within X seconds of race finish
/rstend=1
// no/yes: allow join during race
/midrace=yes
// no/yes: pit stop required
/mustpit=no
// no/yes: allow car reset
/canreset=no
// fixed/finish/reverse/random: race start order
/start=finish
// optional: welcome message up to 200 chars
//welcome=Soccer.txt
// optional: text file listing allowed tracks
//tracks=tracks.txt
// optional: message log file
//log=deb.log[/html]
I'd suggest that you either have a firewall, or a router that's blocking the ports for clients to beable to connect to.
Im pretty sure its the ports... I checked portfoward.com but it gets me more confused!
i have the same problem, i created a server but no one can join.
I´m sure i checked portfoward.com (got a zyxel prestige 660 router with many pc on network) and did all right. i have ZA and configured right too, and even disabled the firewall. I only can join via the same PC (local network using 127.0.0.1). I see in the dedicated server program window that many users try to connect but always get "new guest timed out". If i try to join from another PC i get "client connect: connect failed". How do i know if the port are correctly open? don´t know what else to do....
ok.... now, i did it all again and seem to connect. I ran the dedicated server on a PC and joined from another (not from the same network). Later i tried to join again and while connecting.... i get no response, i mean, it says "connecting to server" and returns to the menu again... what would be the problem?

Thanks for your time...
i hope i can figure this out by tommorow because i have a awsome computer and amazing t1 bandwitch i think i could run a great no lag server for everyone D. i will look at it a bit more tommorow
Quote from RaDuS :i hope i can figure this out by tommorow because i have a awsome computer and amazing t1 bandwitch i think i could run a great no lag server for everyone D. i will look at it a bit more tommorow

Nice! Just be careful with the dedicated server. it make the pc work, wich cause heat wich cause boom!!
well its water cooled and had 4g of ram should be find ive ran cs servers fine but yea something i could keep an eye out for.
Quick question,have a server right,mate off mine set it up for me
I am running a fun event in a few weeks and I want to password the server,can i do it or does my mate have to do it?
Anyone with the admin password can change the user password. Just log on to the server as an admin (enter the admin password in the "host password" input field. Then type /pass mypassword

Now your server is password protected and users can not enter it without knowing the user password. To clear the password simply type /pass

See lfs/docs/commands.txt for more info.
Is this the same for making the server private?
Yes
I've got the dedi server up and running on our dedi box. My problem is i can't see it in the serverlist but people can join by typing in the server name manually using the non server list option. How do i get it to show up in the serverlist? Does it just take some time?
nevermind, i had canreset enabled in server but not in my game DOH.
Ok Server fille dup nice and quick. CPU load is 14% so my next question is can i run more than one server off the same box?
Yes... Just make sure they use different ports obviously.

Guide: Running an LFS Server
(682 posts, started )
FGED GREDG RDFGDR GSFDG