The online racing simulator
Guide: Running an LFS Server
(682 posts, started )
Yea, I did change the Ply name and then after restarting the dedi it's still says "host" instead of what I had entered
Permissions problem on the server the dedi runs on (so its not allowing you to overwrite the file) perhaps?
That isn't a problem, because I can overwrite/upload files into FTP. Even when the server owner/administrator have changed the Ply name line, after restarting the dedi it was still saying "host". Seems that dedi overwrites the files automatically after relaunch

However, when I downloaded all the stuff from the server with settings etc and run it, then it showed the text which I had entered in Ply name line. Maybe something is wrong with the server?
Perhaps
Wine
this is going to sound stupid, but what is WINE?
-
(Blas89) DELETED by Blas89
Quote from MBenz :this is going to sound stupid, but what is WINE?

WINE is a windows API compatibility layer for linux and other unix like OS'.
port forwarding...
under the port forwarding section:

Everything is fine until after i type in "ipconfig" after that, you say to "click" application and gaming. Well there is nothing to click, all it says is my IP information but nothing clickable, any suggestions?

Thank you
Quote from MBenz :under the port forwarding section...

You should note that I specifically say that I use DD-WRT and those are the instructions for DD-WRT. If you use a home broadband router without DD-WRT, then you should check Portforward.com.
hi, i already read a lot of tuts about wine & lfs dedic at linux. but i cant still get my server started. i always get following error

wineconsole LFSserver --backend=curses LFS.exe /cfg=setup.cfg

Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly

screen -S wineconsole LFSserver --backend=curses LFS.exe /cfg=setup.cfg

Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly

screen is terminated


i changed dedicated option to invisible but it still dont work.

my os=debian 64bit linux

please help me
Are you editing setup.cfg and adding the /invisible=yes line?
Try adding the following to ~/.wine/config, under the [wine] stanza
Quote :"GraphicsDriver" = "ttydrv"

Be aware that if you use WINE for other applications this might screw them up.
Quote from the_angry_angel :Are you editing setup.cfg and adding the /invisible=yes line?
Try adding the following to ~/.wine/config, under the [wine] stanzaBe aware that if you use WINE for other applications this might screw them up.

Wine does not use ~/.wine/config anymore, see docs.
For using Wine without X server add:
"Graphics"="tty"

into section:
[Software\Wine\Drivers]

in file ~/.wine/user.reg

Faikez: It seems to me, that X-server is not running, try the above.
EDIT: I just checked, that wine complains even if "/dedicated=invisible" option is set, it works fine with ttydriver. If ttydriver does not work, you could use "virtual" Xvfb x-server.
Quote from Kada_CZ :Wine does not use ~/.wine/config anymore, see docs.
For using Wine without X server add:
"Graphics"="tty"

into section:
[Software\Wine\Drivers]

in file ~/.wine/user.reg

Faikez: It seems to me, that X-server is not running, try the above.
EDIT: I just checked, that wine complains even if "/dedicated=invisible" option is set, it works fine with ttydriver. If ttydriver does not work, you could use "virtual" Xvfb x-server.

i tried the tty driver. now it says

Application tried to create a window, but no driver could be loaded. The X11 driver is missing. Check your build!

but x11 is installed and runs. whats wrong now?
I overlooked this.
Quote from Faikez :my os=debian 64bit linux

Try to install:
libx11-dev
xlibs-dev
libxxf86dga-dev
libxxf86misc-dev
If it doesn't work:
- What is your wine version? (wine --version)
- Did you compile wine for 64bit or do you use 32bit pre-compiled package?
- Does "wine notepad" command work (try it without tty driver)?
Quote from Kada_CZ :I overlooked this.

Try to install:
libx11-dev
xlibs-dev
libxxf86dga-dev
libxxf86misc-dev
If it doesn't work:
- What is your wine version? (wine --version)
- Did you compile wine for 64bit or do you use 32bit pre-compiled package?
- Does "wine notepad" command work (try it without tty driver)?

- wine 0.9.30
- i installed wine_0.9.30-1_amd64.deb, libwine_0.9.30-1_amd64.deb, libc6
- notepad command does not work (module not found wine failed with return code 126)
- xlibs-dev cant install (depends to another package)
- other libs are installed

do u have an icq? send me pm
First of all, you have to have working wine, it can be tested by the "wine notepad" command. If this doesn't work, then there is something wrong with your wine configuration/instalation. There can be several reasons for it (especially on a 64bit architecture). It's far beyond a scope of this thread to solve wine specific problems, I think .

My recommendation is: uninstall wine (purge it ideally), backup your configuration (~/.wine directory), then delete it (rm -r ~/.wine). Install a clean new actual version of wine (0.9.31). Run "winecfg" program, it creates a new ~/.wine directory. Try "wine notepad".

Hope this helps,
Quote from Kada_CZ :First of all, you have to have working wine, it can be tested by the "wine notepad" command. If this doesn't work, then there is something wrong with your wine configuration/instalation. There can be several reasons for it (especially on a 64bit architecture). It's far beyond a scope of this thread to solve wine specific problems, I think .

My recommendation is: uninstall wine (purge it ideally), backup your configuration (~/.wine directory), then delete it (rm -r ~/.wine). Install a clean new actual version of wine (0.9.31). Run "winecfg" program, it creates a new ~/.wine directory. Try "wine notepad".

Hope this helps,

thx for your help. one question does the notepad run under a terminal without gui?
Quote from Faikez :one question does the notepad run under a terminal without gui?

It opens a window like..... windows notepad :-). It should work with tty driver, but it won't be usable.

Hm, I just discovered, that tty driver for wine is broken/not present, at least in 0.9.31.
Quote from Kada_CZ :
If ttydriver does not work, you could use "virtual" Xvfb x-server.

The following script runs xvfb, then wine on it (untested).

#!/bin/bash
Xvfb :1 &
pid=$!
export DISPLAY=:1
wine /dir/LFS.exe
kill $pid

I still recommend, first of all get the notepad working with "real" x-windows. One more thing, if you are connecting to your linux machine (debian64) from another PC (pc) and you run x-application (wine notepad, xterm, ...), then x-server must running on the PC. There are other, more complicated methods, like VNC, see this thread.
Hi, my dedicated server appears in lfsworld.net (racers & hosts online) but not appears in the LFS browser

I also try to create a server inside the game, friends search me inside LFS and it shows that the server is running with me inside. But they can't connect.

This is not the first server I created in my PC. I created servers for other games without problems (TO, Wolf ET, SWAT4, AA...). I check all things that are explained here (router ports opened, xp firewall disabled, kaspersky shut down...) but all times the same, I can see the server in lfsworld and i can't see in LFS.

I have and XP with SP2 and a US Robotics 4 ports router. Any idea that what is my mistake?


PS: Sorry if the solution is replied in this thread. My english is bad and its hard to me to understand all.
Is there any way to ban by user id instead of typing in the user's name? I had to try and get rid of a wrecker but he cleverly typed in some character that prevented me from getting a valid response to the ban command. In fact, he cloned the name of another player beforehand, which was "I have" and I tried the obvious alternative "l have" but that did not work. I'm not even going to try typing in colors or alternative character sets...
Quote from undertech :Is there any way to ban by user id instead of typing in the user's name? I had to try and get rid of a wrecker but he cleverly typed in some character that prevented me from getting a valid response to the ban command. In fact, he cloned the name of another player beforehand, which was "I have" and I tried the obvious alternative "l have" but that did not work. I'm not even going to try typing in colors or alternative character sets...

I think that LFS bans works using the license name, not the nick in game. So if you play the demo you can't do this. To see the license name in S1 and S2 you must press SHIFT+CTRL in game, in the list that appear when you press the "N" key.
hi lads ,
i have my firewalls off barr my computer firewalls have all internet ones off !does computerhave to be two ?
also my internet box has no wireless? is that an issue
thanks guys !
Quote from 11SuLLy11 :i have my firewalls off barr my computer firewalls have all internet ones off !does computerhave to be two ?

Either there's a contradiction there, or I'm not understanding...
What firewalls do you have/use?

Quote from 11SuLLy11 :also my internet box has no wireless? is that an issue
thanks guys !

Unless you're connecting via wireless, no.
Quote from the_angry_angel :Either there's a contradiction there, or I'm not understanding...
What firewalls do you have/use?

Unless you're connecting via wireless, no.

hey mate,im using my windows firewalls !
will i have to forward my ports !?
finally i managed to start the dedicated linux server with xing. now i have a new problem. when i use nogfx the server will start and runs perfect. but i cant close the xwindow (server would shut down). so i tried to use invisible. but the server wont start (screen is always terminating). what can i do? please help
Either start the dedi within a screen session (man screen), or run it under nohup. In either of these situations once you disconnect the server should continue to run.

Guide: Running an LFS Server
(682 posts, started )
FGED GREDG RDFGDR GSFDG