The online racing simulator
Guide: Running an LFS Server
(682 posts, started )
Quote from leonardo555 :PLS GUYS HELP ME!

I DID ALL THINGS I COULD DO. I OPENED PORTS, AND....
BUT WHEN I TRY TO CONNECT TO MY SERVER IT SAYS (ClientConnect:connect failed)

same here
Probably you don't have a public IP address.
Having problems here. I tried to set up a server and I can see it on Lfsworld but nobody can connect (ClientConnect: connect failed).
I called my ISP, the tech told me that all ports should be open. I followed the LFSwiki instructions but it still won't work.

Server: SR SERVU
Pass: streetrace

What should I do now ? Thanks in advance.
Question re: false starts
Dumb question;

I noticed on other servers that false starts result in a penalty, but the driver stays in the race.
However on my server (Z3, s2, Dedicated) whenever a driver false starts, they get a penalty message but then get spectated instantly.

Is it possible to shut off the spectate, and leave them in the race with the original penalty?
Quote from RobbyMac :Dumb question;

I noticed on other servers that false starts result in a penalty, but the driver stays in the race.
However on my server (Z3, s2, Dedicated) whenever a driver false starts, they get a penalty message but then get spectated instantly.

I believe you are mistaken. The effects that you speak of are not server options.

On all servers, you will first receive a penalty when doing a false start. If you immediately stop your car you will not be removed from the grid. It is when you keep on moving you will be removed. I suppose it is a measure to prevent disruptive players from crashing in to other cars before green (which obviously would have given the innocent driver a false-start penalty as well).

Perhaps you were so eager to see what happened on your server that you did not try to move just a little bit?
Quote from felplacerad :...Perhaps you were so eager to see what happened on your server that you did not try to move just a little bit?

Now I feel really dumb lol. That was it. If I had false started on another server I always stopped quickly, but during testing of my own server I'd just keep going. I just tested it on my server and it worked. thanks bunches!
I feel dumm, Im wanting to create a host for a small league and it seems on alocal host i can connbect to the dedcated host but from out side I cant. Im not sure what wrong i followed the instructions recheaked them but still no joy.

the joining people get connection timed out if this helps
Quote from typhirion :I feel dumm, Im wanting to create a host for a small league and it seems on alocal host i can connbect to the dedcated host but from out side I cant. Im not sure what wrong i followed the instructions recheaked them but still no joy.

the joining people get connection timed out if this helps

Make sure you have forwarded all ports on your router, and/or allowed them in your firewall.

Ports are listed somewhere in the guide.
Iv sorted the above out but know i have a new problem ( i think it my router that the problem and the way to sort it out is to move it. so my problem is:

Iv set up a host for a lan game and when i connect the local Laptops up they go online( to the host fine for say 30 secs then they disconnect andthen when i try and re connect to the host, a messagew boxapprears saying host timed out

i think as im having problems with my Wireless network in my host picking up the siginals asthe wireless card in it is not very powerful. so It should be a easy fix, ofmoving the router back in to the study
Can somewone try and connect to my server called "Cheese Land" It should work but... meh

If you cant find the server search for for user and type cheesomatic

Cheers
Quote from cheesomatic :Can somewone try and connect to my server called "Cheese Land" It should work but... meh

If you cant find the server search for for user and type cheesomatic

Cheers

I can't connect.
darn it anyone got any ideas?
I have Ports set correctly and everything
Maybe you don't have a public IP address.
might as well post it on here

I have a vps and when i run LFS i cannot join ( guest info not found) or similar,

i contacted my host about opening port 63392 and got this reply ?

"""Port 63392 is open under TCP but blocked for UDP and can't be open."""

Any ideas,

Thank you
mick
Quote from Mikjen :"""Port 63392 is open under TCP but blocked for UDP and can't be open."""

Change the port number that LFS runs on to one that is supported (i.e. open-able) by your VPS provider. /port=X will set LFS to use TCP/X and UDP/X, where X is a number between 0 and 65535.
thanks Angel,

To do this do i have to contact my host, l looked all over the help files on me server, and kees mentioning "
Opening Ports and Approving Applications

But cannot see this anywhere ?

thanks
Mick
That's a question that either your provider can answer, or their help files, I'm afraid.
Thanks Angel,

I spoke to my host @ VPSLand.com and they switched me to another server which will allow that port to be open.

Thanks
Mick

Spoke too soon, its still not allowing me to join
Ubuntu Intrepid, Wine wine-1.0.1 + dedicated host
Hi Lads,

I'm trying to setup a new host on my ubuntu server here. When I try to run
wine LFS.exe /cfg=setup.cfg I'm always getting the following message:

Make sure that your X server is running and that $DISPLAY is set correctly.

dedicated=invisible of course, so I'm a bit lost now

I've tried ubuntu gutsy and hardy as well but no joy...
Just one more remark, for security reason I'm running hosts as chroot, but I guess this shouldn't affect it

Thanks for any help. Hopefully we'll get it sorted.

BigFoot
Check your config on a window box, or a box with an X server. The odds are that there's something wrong with your config and LFS is throwing an error message up, which will create a messagebox (which requires an X server).
After reading all instruction (good work mate) i try to start with dedicated host a server.
From the panel i receive "status online".
If i start LFS and i try to connect in local to 192.168.1.28 i can connect to my server and game.
But if i find it online, in lfs world, i can't find it.
I've opened in router 63392 in tcp and ucp and 29339 in tcp.
I also set firewall that permit lfs.exe and port 63392 and 29339.

Which is the problem ?

I use a specified IP (my external) and if a use o not ( xxx.xxx.xxx.xxx) don't change anything.

The server now is online, the name is "Demolition Park", autocross, can u see it ?

---

updated: interesting !!! the server is online, but in S1 !!!
Why if a use this in my config.cfg ?

// demo/s1/s2
/mode=s2
Just joined perfectly michele0676
Thanks Angry Angel, why this now ?

updated: interesting !!! the server is online, but in S1 !!!
Why if a use this in my config.cfg ?

// demo/s1/s2
/mode=s2

In lfsworld, it result in S1 ! Why this ?
The server automatically becomes S1 when you use a S1 car on a S1 track.
Quote from zeugnimod :The server automatically becomes S1 when you use a S1 car on a S1 track.

Thanks mate !!!
And why i can't find it with my lfs game in the server list ? Is'it right ?

Guide: Running an LFS Server
(682 posts, started )
FGED GREDG RDFGDR GSFDG