The online racing simulator
Test Patch 0.6R8 (now R12)
(178 posts, started , go to first unread)
Test Patch 0.6R8 (now R12)
WARNING : THIS IS A TEST

NOTE : THIS DOES NOT CONTAIN NEW TYRE PHYSICS

THIS PATCH CONTAINS A MORE ROBUST METHOD OF CONNECTING TO THE MASTER SERVER

PLEASE TEST BEFORE YOU POST


NOTE :
When you first run this test patch there will be a hang of
around 20 seconds while the old .raw files are converted



Hello Racers,

Here is a new TEST PATCH : 0.6R12

It contains some updates related to some recent changes on our servers :

- A more robust method for connecting to the master server
- Skin downloading now works with the updated website

0.6R12 is compatible with 0.6R

- You CAN connect online with 0.6R
- You CAN play replays from 0.6R

You cannot upload hotlaps made with this test patch because it is only a test patch, not an official patch.

Please back up or rename your LFS.exe from version R so you can revert to it if necessary.


Changes from 0.6R11 to 0.6R12 :

Interface :

New free view camera position text command /cp
/cp will copy a text camera position to the clipboard
The resulting text can be saved in a text file, forum, etc. or into
another instance of Live for Speed to reproduce.the camera position

Many translations updated - Thank you translators!

Graphics :

Slight reduction in some excessively bright driver models

InSim :

New value PMO_POSITION for IS_AXM packet to report a blank position
New packet IS_CIM reports a connection's interface / editor mode


Changes from 0.6R9 to 0.6R11 :

More informative error report for "Unknown file transfer error"
FIX : Lighting restored to most objects (to appear darker in shade)
FIX : Some objects at Blackwood looked the same e.g. ads over pits
FIX : XR front lights were plain white in the recent test patches


Changes from 0.6R8 to 0.6R9 :

Faster one time file conversion straight to DDS about 20 seconds
FIX : Multiplayer replays corrupted file error message in 0.6R8
FIX : Misleading warning messages about missing sky textures
FIX : A message about a missing file when loading Fern Bay


Changes from 0.6R7 to 0.6R8 :

More robust method for connecting to the master server
FIX : Skin downloading now works with the updated website
FIX : Rare hang while recovering from a graphics driver error
FIX : LFS logo no longer overlaps the small map or InSim buttons


Changes from 0.6R to 0.6R7 :

Textures :

PNG files are now used in the few cases where RAW files were used
Removed option to view sky in 16-bit colour
Sky now uses DDS (compressed) textures

Commands :

Improved processing of command line to be more flexible
New command /settings=X.txt - uses X.txt instead of cfg.txt
Command /settings must be the first on command line or in file
Command /mp (join local host) can now be used on the command line

Misc :

Live for Speed can now recover from a graphics driver error
Textures are no longer reloaded when changing weather (faster)
LFS starting in borderless window mode now goes to the same monitor
New option "Display LFS logo in game" (not optional in demo mode)
English file is no longer saved when LFS starts (can be deleted)

VR :

New commands to skip F8 menu /vr reset_headset and /vr use_relative


INSTALLATION INSTRUCTIONS :

A FULL version of LFS 0.6R must already be installed


To install the PATCH using the SELF EXTRACTING ARCHIVE :

1) Move or save the patch into your main LFS folder
2) Double click the patch to extract it to that folder
3) When you see "Confirm File Replace" select "Yes to All"
4) Now you can start LFS in the normal way

NOTE : You can see if the patch is correctly installed when you run
the program (LFS.exe). At the bottom of the entry screen : 0.6R12


DOWNLOADS :

IF YOU ALREADY HAVE 0.6R :
PATCH 0.6R TO 0.6R12 (SELF EXTRACTING ARCHIVE)
www.lfs.net/file_lfs.php?name=LFS_PATCH_6R_TO_6R12.exe (1.2 MB)

FOR HOSTING ONLY :
DEDICATED HOST 0.6R12 (non-graphical version for hosting only) :
www.lfs.net/file_lfs.php?name=LFS_S3_DCON_6R12.zip (1.8 MB)
Will try and post how it goes hopefully in the next half an hour Smile
Slick turnaround, nice one!
Firstly. Upon launch I got this in the expected 40-1.5minute hang:

Could not read texture Skysunny7 - File not found

Overall connection to Master Server was quick, somewhat quicker than usual, out of every host I got the following results:

(Demo on, empty on, private on, public on.)

Can join: 249 - No Reply: 14 - Wrong version: 0.

Direct connect seems to be working perfectly for itself as well as hosting from LFS.exe itself (non-dedicated)

Errors within gameplay:

KYOTO:

Cloudly afternoon returns: Could not read texture sunsetoc1 - File not found

Ingame however there is a sky.

Addition: This seems to happen on most things for me at least under a different filename each time.

Tracks also load quicker than what I remember from 0.6R itself.

This info might be completely useless, but its here!
thank you Scawen. you are awesome Big grin
Thanks for the feedback.

I think you get that "Could not read texture xyz - File not found" the first time you use a sky.

It then creates the dds of the sky from the png so it's a misleading message.
From patch notes, not in forum post Smile.

Quote :Due to various updates, the rendered lighting has been removed from
modelled objects in the game. This can only be fixed by supplying
freshly rendered tracks but this is just a small test patch.

Does this mean the official update will include the current WIP tracks?

No problems installing / unlocking.
Quote from Scawen :Thanks for the feedback.

I think you get that "Could not read texture xyz - File not found" the first time you use a sky.

It then creates the dds of the sky from the png so it's a misleading message.

Possibly, looked more out of place than anything else overall, hopefully when this new system comes into the mainbranch release this simple message should be fixed.
Hi,

When reloading the game I get two texture messages about RALY_pole1_ALP. This is after all the conversions are done, on a fresh install.
Sorry for the mood killer but the replay function seems broken.
I've played on a R & R8 server. Both replays won't start with a "Corrupted file" message.
Quote from chucknorris :Sorry for the mood killer but the replay function seems broken.
I've played on a R & R8 server. Both replays won't start with a "Corrupted file" message.

Same thing happens to me, also on some replays, it displays message "Could not read texture [Texture name] - File not found" on chat as well.
Quote from chucknorris :Sorry for the mood killer but the replay function seems broken.
I've played on a R & R8 server. Both replays won't start with a "Corrupted file" message.

I got the same.
Just noticed remote is dead did you guys turn it off?

Seems I can't reactivated them.
I didn't get the 40 second hang and can't connect to any servers. Also did not have to re activate which is weird.
LFS R8 can't connect to master also Dcom R8 lost connection to master Frown
After installation:

Could not open vertex shader (World2)
Could not open pixel shader (World2)

And the maps/car tires invisible.

https://imgur.com/L9oWsEv
Quote from Krisz16 :After installation:

Could not open vertex shader (World2)
Could not open pixel shader (World2)

And the maps/car tires invisible.

https://imgur.com/L9oWsEv

You didn't installed the patch correctly. Use the auto extracting exe, and replace all files.
Quote from bobloblaw :Does this mean the official update will include the current WIP tracks?

That's not the plan. This patch is supposed to be a quick update to help get LFS back online again. On future plans, I'm hoping to release the new graphics system and new updated tracks with the new physics, not in this update (that is "hope" not "promise" for anyone reading - and we are talking months, not weeks, for that). I don't know if it's possible to re-enable any of that lost lighting info in the test patch but I'll have a look.

Quote from chucknorris :Sorry for the mood killer but the replay function seems broken.
I've played on a R & R8 server. Both replays won't start with a "Corrupted file" message.

I can reproduce that bug - seems you can record MP replays but you cannot playback MP replays.

Quote from dragon66 :I didn't get the 40 second hang and can't connect to any servers. Also did not have to re activate which is weird.

Maybe you had R7 before so you already converted the files. You can't connect to the servers when we are under attack. Check the status at www.lfsworld.net - we are still working on the server side solution for that.

Quote from RC-Maus :LFS R8 can't connect to master also Dcom R8 lost connection to master Frown

Please check the status at www.lfsworld.net - you can connect when we are not under attack.

Quote from Krisz16 :After installation:

Could not open vertex shader (World2)
Could not open pixel shader (World2)

Incorrect installation - there are some World2 files in the installer which need to be in the data\shaders folder.
Good to see the update, after testing it, I had 2 problems and they were:

1. "Could not read texture xyz - File not found" <- only happened once so thats clear
2. While 0.6R replays should work as the text suggest, it seems that they don't and just to prove it here is a screenshot:

http://i1117.photobucket.com/albums/k600/arankakis1/corruptedfile_zpsctowd8a1.jpg

Good luck Smile

[EDIT by Scawen : Removed IMG tags. MPR replays can't be played - already reported]
Quote from PeterN :Hi,

When reloading the game I get two texture messages about RALY_pole1_ALP. This is after all the conversions are done, on a fresh install.

I confirm that file is not supplied in the full version and that message comes up when loading Fern Bay.

For some reason, 0.6R doesn't mind about that but 0.6R8 does. I'll have a look.
"Changes from 0.6R7 to 0.6R8 :
FIX : LFS logo no longer overlaps the small map or InSim buttons"
Attached images
Untitled.jpg
Quote from valiugera :"Changes from 0.6R7 to 0.6R8 :
FIX : LFS logo no longer overlaps the small map or InSim buttons"

You can remove LFS Logo Options>Misc>Display LFS Logo in game=no
This test patch seems doing what it was suposed to do in the first place. I can actually connect into the master server(and yes,its a fresh new port but more protected).

Great work Big grin I notice this port's being under attack(I might be wrong) and its pulling it off!

UPDATE: And I can connect into the servers available
Attached images
Screenshot_2.png
Quote from Daniel564 :This test patch seems doing what it was suposed to do in the first place. I can actually connect into the master server(and yes,its a fresh new port but more protected).

Great work Big grin I notice this port's being under attack(I might be wrong) and its pulling it off!

UPDATE: And I can connect into the servers available

You're lucky.. i still can't to connect with master server... :/

Test Patch 0.6R8 (now R12)
(178 posts, started )
FGED GREDG RDFGDR GSFDG