The online racing simulator
Test Patch 0.6R8 (now R22)
(407 posts, started )
Quote from Scawen :Is it possible to find more information, so I know where the crash was?

What I need is:

1) Exception code
2) Crash address or Crash offset

Sometimes this is available in "extra information" or something like that. Which version of Windows are you using?

You can look at the picture. It says nothing but that.

To bad we couldn't test if bullet proof today Taped Shut
Anyway, I'm reloading LFS. I'm not going to use this patch..
Quote from Scawen :Strange that you are the only one to report that error (so far). I'd better include a more informative error message in that case.

It was also reported here
Quote from neonmateo :I don't remember this grass being like this

(Probably shaders I use)

I think that is because of the lighting information that was removed because of changes to modeller objects.

Today I've disabled some of those modeller object changes to allow me to disable the lighting removal but there are some issues I still need to solve.

Unfortunately the code now in the public version contains an early version of some of the graphical updates that was merged in. But then the graphical updates went so much further it has become something that can't be merged in at all and for the new graphics we will be releasing new versions of all the tracks and most of the textures.

For this current update I just need to try and backtrack a little so everything looks OK with the lighting mostly restored, in a small patch.
Quote from Degats :It was also reported here

Tnanks. I've made a note to add a more informative error message in the next test patch.
Will I be able to update my host from lfs.net to test patch or only dedicated servers?
Quote from greg_slideways :Will I be able to update my host from lfs.net to test patch or only dedicated servers?

Can download dcom.zip. If u host somewhere i'm sure u have some rights.
No, lfs.net subscription hosted, only allows 0.6r h/j/k/l/m ect
When skins will work again on stock 0.6R version?
Quote from Mikus1212 :When skins will work again on stock 0.6R version?

I don't know specifically when, but when the official LFS update comes out. Skin downloads will be possible.
-
(Mikus1212) DELETED by Scawen : spam / off topic
-
(Scawen) DELETED by Scawen : spam / off topic
Quote from greg_slideways :Will I be able to update my host from lfs.net to test patch or only dedicated servers?

From this morning it is now possible to use R9 on the LFS rented servers.
Small update: It turns out that some skins actually came through, while the rest gets rejected. (see screenshot)
Attached images
lolwut.png
Quote from rosewood2 :Small update: It turns out that some skins actually came through, while the rest gets rejected. (see screenshot)

Thanks, please check here in a couple of hours - I'll try to post an R10 test that shows the actual error text so we can figure this out.
So now online activity is recovering back to normal it seems...
Just curious: Are those narrow minded people still trying to attack the master server?
Rule one in the book; do not give it attention
Test Patch R10 is now available.

Changes from 0.6R9 to 0.6R10 :

More informative error report for "Unknown file transfer error"
Lighting restored to most objects (so they appear darker in shade)

https://www.lfs.net/forum/thread/92067

I know there are more things to fix but I wanted to get this one out more quickly so we can solve the skin download issue that affects some people. Anyone else can also benefit from the restored lighting on objects.
Quote from bobloblaw :Thanks for the update. With custom shaders, the game became way too bright. It looks fine in a fresh install- so no worries here about the lighting.

Looks like you are using my shader pack. I just made a quick hotfix for version 0.6R10 that fixes this. Wink

https://www.lfs.net/forum/post/1935847#post1935847
Quote from Scawen :Thanks, please check here in a couple of hours - I'll try to post an R10 test that shows the actual error text so we can figure this out.

Oddly enough, now all of the skins are downloading correctly for me now.
Attached images
wat.png
Hmm, strange! Uhmm

Don't think I changed anything but the error message!

Maybe the bug will come back.
Quote from Scawen :
Maybe the bug will come back.

Let's rather hope that it doesn't come back. Ever. Big grin

Thank you for your hard and devoted work, Scawen! Oh those teasers you give us...
Quote from Scawen :Hmm, strange! Uhmm

Don't think I changed anything but the error message!

Amusing! Tongue

Quote from Scawen :Maybe the bug will come back.

A second round of downloading skins later, turns out it didn't come back (not yet anyway)!
Attached images
wat2.png
-
(driftforza112) DELETED by Scawen : spam / off topic
-
(RC-Maus) DELETED by Scawen : spam / off topic
-
(neonmateo) DELETED by Scawen : spam / off topic
-
(driftforza112) DELETED by Scawen : spam / off topic
-
(driftforza112) DELETED by Scawen : spam / off topic
-
(crazyboy232) DELETED by Scawen : spam / off topic
-
(neonmateo) DELETED by Scawen : spam / off topic
-
(driftforza112) DELETED by Scawen : spam / off topic
Test Patch R11 is now available with more graphical fixes.

Changes from 0.6R9 to 0.6R11 :

More informative error report for "Unknown file transfer error"
FIX : Lighting restored to most objects (to appear darker in shade)
FIX : Some objects at Blackwood looked the same e.g. ads over pits
FIX : XR front lights were plain white in the recent test patches

https://www.lfs.net/forum/thread/92067
Just tried it, works nicely, no more missing light textures. And skins downloads as they should for me. Wink

Test Patch 0.6R8 (now R22)
(407 posts, started )
FGED GREDG RDFGDR GSFDG