The online racing simulator
Searching in All forums
(496 results)
Victor
Developer
Yep, looks like that was temporary. Replied, so the thread can be "answered".
Victor
Developer
Damn, missed one check. Fixed it - I think it will work next time.
Victor
Developer
Ouch, yes you might be right. There was a check on number of people in race, limited to 32 Frown
Thanks for reporting it so that it could be fixed. Unfortunately though I can't bring back the race data Frown
Victor
Developer
Looks like the domain no longer exists. As it wasn't controlled by us, I can't bring it back.
Could make a new url though, if it's still interesting.
Victor
Developer
Ah, fixed. Thanks.
Victor
Developer
Should be ok now.
Victor
Developer
Fixed. Was regression bug after implementing "ctrl-enter to submit".
Victor
Developer
ah, right. I've added a redirect to enforce https.

Thanks for figuring that out!
Victor
Developer
eh .. how then? I didn't change any javascript code that last time ... also it's working fine here in all my browsers.
I've no idea atm. Will have to get back later on.
Victor
Developer
Hmm, that's odd.
I made a few more changes - can you please try once more?
If it doesn't work now uhm, then I'll have to think about it.
Victor
Developer
Hi, thanks for the report. This should be fixed now (might have to ctrl-f5).
Victor
Developer
Since last month you can always see your own stats.
Others still won't see them (tried it - I don't see them).
Victor
Developer
Hm yeah I guess you should be able to get your own stats, even if you've chosen to hide them from others.

Give it another go please. Should be fixed.
Victor
Developer
Quote from Racon :I get this too, it's on https://lfs.net/login , where it says this: ...etc.

That time there is always the current time, no matter how long you've been logged out up until that log in.

Ah, finally found the cause of the previous visit time bug. That's fixed now.

Quote from Racon :If you're tinkering anyway, the javascript "you have not typed your username/password" thing on that page drives me nuts - it doesn't notice when the fields are auto-filled, or focused, so each has to have a character added and then deleted before the form will work.

Hm, not sure what you mean. It should not matter how they are filled in because the only thing javascript does there is check for blank input fields upon pressing the submit button. The input fields should already have been populated by then.
Which password manager / autofill method do you use?

Quote from Racon :...and if you wanted to make it 100% perfect, save the referring page when I hit /login, then send me back there if the login works. (I guess some people like the confirmation, so maybe a checkbox for 'send me back to <blah>'?)

Done.
Victor
Developer
Hmm do you mean the message you see immediately after logging in? On the "LOGIN SUCCESSFUL" page?
Thing is, I cannot reproduce this reported bug for that message.
But yes, if you mean that page, then it should indeed show your previous login or return to the site. Otherwise there's no point in that message.
But maybe Sobis was thinking of the time on your profile page? Bit of confusion here I think.
Victor
Developer
Ah, I see. Should be ok now.
Victor
Developer
Try again - should work now (was caching issue).
Victor
Developer
Hi,

Some host processes were killed unexpectedly due to a configuration error, causing some dynamic files like Airio DB files to not be saved.
This is quite unfortunately and more so because I noticed I didn't back up those files Frown So there's nothing to be done at this point.
Will make sure to back those up as well.
Victor
Developer
How about now?
Victor
Developer
SSL has been added to lfsworld.net, *.lfsmanual.net and img.lfs.net now.
I think I've updated all links pointing there.
I'm not enforcing it hard (always redirecting to https) on www.lfsworld.net yet though, because I need to assess usage of e.g. pubstat in the different applications it's being called from. Not sure they can all handle a redirect and / or ssl. So that means plain http lfsworld will still work for now.
Last edited by Victor, .
Victor
Developer
Thanks for the report. That's now fixed, though you may have to do a forceful reload of the analyser (ctrl-f5).
Victor
Developer
Lapper support has been added now (though I think the OP has left the building, judging by his host name Uhmm ).
Victor
Developer
Hm I cannot seem to reproduce this.
Take note that you cannot rate your own files or when you're not logged in. But as you make the comparison between browsers and mention weirdness with opera, I guess that's not the case?
Victor
Developer
Thanks for the report. It was a cached value that was oos. Fixed now.
FGED GREDG RDFGDR GSFDG