The online racing simulator
Searching in All forums
(500 results)
Victor
Developer
Have added the LFS Version option.
Victor
Developer
Quote from Gutholz :I uploaded a setup for test, commentented, all worked.
The text "Drag your setups here to upload them" could look more like a Drag&Drop area, like the one used for skins upload.

It might be good to still allow uploads of the same setup. Several people might get the same setup from the same source (other forums or getting sent it online) and might want to upload it, just to have it listed in 'their' collection.
Or maybe have a button: [Add to my collection] or so?

In same way it would still have to be combined, so that public comments & ratings stay in sync across all uploads of the same set.

It is already useful if only to organize your own setups with notes like "tires lasted for 45 laps" or laptimes etc. (I was always too lazy to use an excel sheet or such)

It does allow uploads of the same setup, across different users. But if you upload a setup that you already have, it will skip the new upload.
On the public pages I'll deduplicate those setups while totaling their stats.

An 'Add to my collection' button will be useful indeed.

Quote from englishlord :Looks good. I uploaded a set, it read locked diff as viscous diff. I'm not sure about the accuracy of the rest as it's just off the top of my head.

Could there also be a field to put what version of LFS the set is made in and for that to be searchable?

Could you share the setup (here or email)? Or just upload it on your account (again) so I can grab it for a test?

I'll have a look at LFS versions.
Victor
Developer
Very strange.
I've pushed a sort-of-fix, so you can post your texts now, but I still don't fully understand the actual issue at hand.
Must be related to the upgrade to php7, but not sure why this is happening, yet.
Victor
Developer
I'm still working on the public browsing part. That's the next phase. Right now you can only upload setups.
Victor
Developer
Quote from mbutcher :I noticed there was no mention of intake restriction. This would be a particularly handy value to have displayed prominently on the setup details screen (Eg. For GT2/3 setups).

Added a Handicaps block. If you don't see it, the car has no handicaps.
Victor
Developer
Fixed
Victor
Developer
I've added basic functionality for maintaining your own setups. I'm curious for any feedback.

You can upload setups there by dragging and dropping them onto the screen.
Setups that you upload on the forum will also be added.
Setups that you already had uploaded before now should also be available on that page already.

When you upload a setup, it checks if it's an exact duplicate of one that is already uploaded. If it is, it skips the new upload.
If the new setup is a replacement of an existing one (same name), then the old one will be replaced by the new one.

You can set access permissions to private, team and public. Team is the same as private atm. Need to check team stuff a bit and maybe rearrange that. Note that access permissions will be ignored if the setup is used as an attachment on the forums. These are public by nature.
You can add a classification, tracks and a note to the setup.

These latter options will be used later on in the public setup viewer.

But I'd like to hear your thoughts on this first part. I'm not sure if the setup overview page will do. I tried to keep it in same style as the skins page, but setup might need a different approach - mostly if you have a lot of setups.
Victor
Developer
Hm ok, it's because attachments that are uploaded are linked to the reply page you are on. Going to another page discards the attachments and the attachments will not be tied to your new post.
That ties in with some attachment permission thing where demo users cannot download attachments that aren't used in posts (those because private attachments, although you cannot browse them - it's a kind of forgotten idea).

Anyway long story short ... I'm not actually sure how to fix this. It's kind of a bug, but not really. Basically you should try to upload images on the page you are actually going to submit the reply on. Then it will work. But I've made it so that images can always be viewed, for the time being anyway.
Victor
Developer
Sorry for the late reply and that it's not fixed yet. I currently have very little time to spare, but some free time is on the way, so I'll be looking into any issues then.
Victor
Developer
Done

(i have PM's switched off)
(don't you have my email? Smile )
Victor
Developer
It's not that straight forward a feature I'm afraid. I had a look this week - I can super easily ignore posts made by users, but there's also post counts in threads and forums that would get oos then. It would for exmaple be possible to have a page with 1 post which could be ignored and then you have an empty page. The same with threads started by an ignored user. Do we hide the whole thread? (and then forum thread count is wrong).
So .. it's not so easy I'm afraid.

That said, Racer X NZ, you've also worn off my patience and you are on a thin line right now. You last post again is filled with pure non sense and it just not adding anything to this conversation or in general.
You decide how to go on from here.
Victor
Developer
then icode it is, now
Victor
Developer
yeah I was wondering about that, but got no feedback until now.
code vs icode
or
code vs c

hmm if you write it like that, c just seems shorthand for code.
Victor
Developer
inline code block rather than the usual block-type.

I've made this in my version with [c]. Should go live over the weekend I think, after I finish the first part of car setup management.
Victor
Developer
Is [c] a standardised tag for that use? Because otherwise I think I'd prefer [icode].

EDIT - but i'm on the fence about it really. On second thought [c] could work too ...
Victor
Developer
The joy of dynamic ips and inheriting others' abuse : http://www.blocklist.de/en/view.html?ip=109.201.154.200

Can you easily cycle your ip?
Victor
Developer
I've removed the filters altogether. They weren't really splitting S1, S2 and S3, but rather letting you show stats from very old versions vs new versions. And the old data is so old now that it's become a bit irrelevant, so I've removed that filter.
Victor
Developer
Please give it another go now.
Victor
Developer
Quote from CLRS530 :That's correct but post1902292 shows a new solution if he agrees.
And this one would costs him 5 min.

I'm afraid that doesn't work. The car is cut off near the bottom then (see attachment).

I will have a look but just not now. Sorry if that annoys anyone, but i really don't have that much time to spare and have to prioritise.
Victor
Developer
Fixed. You may have to press F5 or ctrl-ft5 to reload javascript.
Victor
Developer
The fix is now live.
I've also changed the default sorting to "next race". I think that makes the list more interesting upon first sight. Also fixed that "next race in the past" bug.
Victor
Developer
This seems to be fixed now in my version. Will test it a bit more while finishing another thingy. Should be live a bit later tonight.
Victor
Developer
Can't remove the hidden overflow just like that. You'll get a horizontal scrollbar every time the car at the top moves to the right.
It can probably be fixed, but to do this correctly, and for devices other than desktops, a whole lot more needs to change. This is not very high on my list tbh. But it'll be looked at at some point.
Victor
Developer
Quote from JPol :I'm running 0.6K6 and wanted to upload a hotlap from UF1/WE4, but LFSWorld says: "Westhill hotlaps must be driven with version 0.6H or up."

I thought 0.6K is higher than 0.6H. Am I missing something?

This is now fixed.
FGED GREDG RDFGDR GSFDG