The online racing simulator
LFS stats is born again
(396 posts, started )
Hello
  • yamakawa have graph.exe source
  • Use System.Xml on C# to read and write xlmdocument
  • How to read lfsworld stat? here http://www.lfsforum.net/showthread.php?t=14480 and take a look on LFSLapper reading lfsworld info
  • For automatic upload, take a look on LFSLapper ftp upload working in thread mode
  • To avoid tarpiting from lfsworld, you have to pay for this. But you can turn around this reading info and store it in DBS
  • Take a look at insim.txt to view what it's possible to catch from insim connection
thanks, I looked in insim.txt, but he's changing it, adding etc. :/
it's a lot of work, maybe I will get to it someday

tarpitting? it's protected so you can't upload/download so often? omg
can i use this program to make a list of the best track times on a auto cross server that wil be updatet every 5 minutes or so?
Greek translation for LFS_sTaTs v2.00
Attached files
greek.txt - 3.1 KB - 131 views
-
(migf1) DELETED by migf1
Please forgive my ignorance, but could some kind soul explain me step by step how am I supposed to use the LFS_sTaTs templates? I'm clueless!

You see I have the attached template file, which I'm supposed to use so that LFS_sTaTs produces a single file according to that template.

Thanks in advance!
Attached files
sls.rar - 219 B - 117 views
I can't make it work.. must be doing something wrong...

I get two types off error instead of connecting to LFS, dependig on IP i use in the config file:
1. if I use the ip: 192.168.0.120 (from my ipconfig output) i get an error from attachment 1
2. if I use the ip: 127.0.0.1 (the standard for localhost...) i get attachment 2
config file edited with notepad, saved as Unicode, other settings (except for admin password of course) untouched

Is there any step by step guide how to set it up properly that I missed?

LFSRelax for example is running perfectly so it sholudn't be any poblem connected to InSim/ports themself
Attached images
Clipboard01.jpg
Clipboard02.jpg
One question, does this work on Vista?
How this software work in patch X?
I'm off for a while, studying abroad, feel free to update, change, what ever.

Vista? don't know, I don't use this cr4p, why should I anyway, besides in schools are XP, in work you have XP, Vista not needed
but the question should be why it may not work in Vista
I think it works, just try it.

patch X? quite old? now I'm updating to Z15 I think you should update to newer version to
may work, depends on InSim version
Quote from pandera :I can't make it work.. must be doing something wrong...

I get two types off error instead of connecting to LFS, dependig on IP i use in the config file:
1. if I use the ip: 192.168.0.120 (from my ipconfig output) i get an error from attachment 1
2. if I use the ip: 127.0.0.1 (the standard for localhost...) i get attachment 2
config file edited with notepad, saved as Unicode, other settings (except for admin password of course) untouched

Is there any step by step guide how to set it up properly that I missed?

LFSRelax for example is running perfectly so it sholudn't be any poblem connected to InSim/ports themself

hey hey, would take me some time to discover what happened
original version works well?
do you have LFS insim port opened, with command like insim=29999
or try debuging it
but I think the original v1 will do the same
firewall OK?
didn't try with other version so far
the insim should not be an issue, using LFSRelax with no problems, port opened for 100%
runnig hosted games on the same machine and no problems with firewall so far
and the system is.. Vista , already tried runnig it in compablility modes but nothing changed

I'm runnig a home network with 2 comps, that is where the ip: 192.168.0.120 comes from, from the router.. if it can have any meaning..
Hi

I'm trying to use lfsstats again, but i'm having serious issues.

To start, i'm getting this message on the lfs client:
InSim : password does not match your multiplayer admin password
So i went to multiplayer and i've deleted the pass i had there...

Without lfs running and using the default config, lfsstats tries to connect without success, firewall doesn't seem to be the problem.

I've created a simple config file that i believe have all parameters, it is as follow:

Host = 127.0.0.1
Port = 29999
TCPmode = true
Password =
lang = english
raceDir = ./resultsrace
qualDir = ./resultsqual
maxTimeQualIgnore = 10
exportOnRaceSTart = yes
askForFileNameOnRST = false
exportOnSTAte = no
askForFileNameOnSTA = false
generateGraphs = true
PubStatIdk = (using mine here)

Also using a batch file:

LFSStat.exe .../LFS_sTaTs_v2.00/config.cfg

Of course that config.cfg file matches the name of the file that i show above.

And i use this batch to run lfsstats with that config, i get the error shown in the attachment.

Can you see what could be wrong?

Cheers
Attached images
lfsstats_error.JPG
Quote from pandera :
2. if I use the ip: 127.0.0.1 (the standard for localhost...) i get attachment 2
config file edited with notepad, saved as Unicode, other settings (except for admin password of course) untouched

Is there any step by step guide how to set it up properly that I missed?


I have this too, but in... XP

For example LFSLapper works perfect. Firewall off.

indie try change the pubstats ident key
Quote from indie :...

probably something with the feature I don't use, the WR, PubStat
I didn't changed anything in this part of program, so the same problem you will have with ver. 1
looks like some string cannot be converted to number, like "a" can't be converted to number and the program is expecting number not letter
Hi helpers

i've some Problems with LFS-Stats under my Vista-System.

look at the screenshot..

Can anyone help me to fix that problem..

big thx
UER@Delgado
Attached images
Unbenannt1.jpg
i could be wrong, but it might be choking on ipv6.
In LFSStat.cfg, change the last line of "TCP mode" to false:

# TCP mode.
# true if you want to use TCP
# false if tou want to use UDP
TCPmode = false
Quote from Whiskey :In LFSStat.cfg, change the last line of "TCP mode" to false:

# TCP mode.
# true if you want to use TCP
# false if tou want to use UDP
TCPmode = false

Thank you !!!

I had the same problem under Vista


Everything work now
It's a pleasure help you guys
UDP Mode won't work correct with fastforwarding. i had the same problem and i solved it like this:

TCP Mode still activated. I downloaded hamachi of www.hamachi.cc and startet it (unconnected) then i put the hamachi ip (you get it when you create an account) into the stats configfile. Everything works fine now in TCP Mode.
Quote from commandermas :UDP Mode won't work correct with fastforwarding. i had the same problem and i solved it like this:

TCP Mode still activated. I downloaded hamachi of www.hamachi.cc and startet it (unconnected) then i put the hamachi ip (you get it when you create an account) into the stats configfile. Everything works fine now in TCP Mode.

I tried the way you say, but still getting the same message "Connecting.Connecting..."

Anyway thanks for the help
did you also try with hamachi connected?
Quote from commandermas :did you also try with hamachi connected?

Yes, I tried many compinations

The only way I can run LFSstats with TCP ON, is

1. Run LFS at my Laptop (Vista 32bit)
2. Run LFSstats at my Desktop (Vista 64bit) using the LAN IP of my Laptop in the "LFSStat.cfg"

This way the TCP working fine.


Thank you commandermas, for your help
Quote from Ant0niS :Yes, I tried many compinations

The only way I can run LFSstats with TCP ON, is

1. Run LFS at my Laptop (Vista 32bit)
2. Run LFSstats at my Desktop (Vista 64bit) using the LAN IP of my Laptop in the "LFSStat.cfg"

This way the TCP working fine.


Thank you commandermas, for your help

so what was the problem? On Vista (don't use it )
that when you wanted to connect stats to server it won't connect?
or it won't connect to localhost like that? Then there is probably something wrong with your OS, firewall, ... I would have to test on Vista, but now there W7 so maybe I'll test it there soon.
#### CONNECTION CONFIG ####
# Host IP.
Host = 127.0.0.1

# Insim UDP or TCP port.
# Before starting LFSStat you must configure LFS server to use this port for InSim.
# You can do that in command line when starting LFS (/insim=29999) or in talk window of LFS (/insim 29999).
Port = 29999

# TCP mode.
# true if you want to use TCP
# false if tou want to use UDP
TCPmode = true
Linux (mono) ;

Quote :The following error occurred:
SetConsoleCtrlHandler
LFSStat
at (wrapper managed-to-native) LFSStat.ConsoleCtrl:SetConsoleCtrlHandler (LFSStat.ConsoleCtrl/ControlEventHandler,bool)
at LFSStat.ConsoleCtrl..ctor () [0x00000]
at LFSStat.LFSClient..ctor (System.String scriptfilename, Boolean debugmode) [0x00000]
at LFSStat.LFSStat.Main (System.String[] Args) [0x00000]
Void .ctor()

Any clues?

LFS stats is born again
(396 posts, started )
FGED GREDG RDFGDR GSFDG