The online racing simulator
Test Patch Y30 : XF / XR Interiors
(447 posts, closed, started )
Great patch Scavier. Thank you!

BTW, the thumbnail pictures in the car selection screen do not show the new wheels (data/pic/x_XRG.jpg for example)

Also a little suggestion regarding the rear view mirror location on the XFG. From cockpit view the mirror looks as if it's in the centre of the windscreen however in shift-u it looks fine. Moving the mirror half way up in the big gap would be perfect. Maybe a spinoff thread to discuss this?
Quote from Scawen :I can't resist any longer - please tell me who is that in your avatar?


That's my girlfriend
I'm sure this probably isn't related to the test patch, but it's a bit confusing anyway and has to do with Patch Y. When you host a game from within LFS.exe (which I haven't done since Demo/S1/S2 were combined) you still have the option for Demo / S1 / S2. Since all clients can now interconnect, should this option still be there? Is it just to make it easier to limit the server to particular content? If I select demo, can I then add a non-demo car without stopping the server and changing modes?
I think (but don't quote me on this, I don't want to go looking for the post...) that Scawen has said that that value doesn't matter in Y14+
Quote from dougie-lampkin :I think (but don't quote me on this, I don't want to go looking for the post...) that Scawen has said that that value doesn't matter in Y14+

That's kinda what I thought. But if it doesn't matter, why is it still there?
so all my RB4 hl's will be invalid because new physics in suspensions?
Quote from chanoman315 :so all my RB4 hl's will be invalid because new physics in suspensions?

I'm afraid so.
Quote from LineR32 :I found that I can see through the dials when using my custom cam and chase view in XRT, and the shadow has a big hole in it when the car is flipped. I've not checked the other cars yet.

Best way to check the dials is to drive over the painted rumble strips, it's not that visable in the screen shot.

I tested on all cars, the shadow bug only happens on XRG, XRT and XRR.

I also found a bug on Fern Bay Green and Black:
Every car that hits this wall will pass throught it [see attachment]
for XRT: the speed has to be higher than 160km/h
for the other cars: the speed has to be higher than 175km/h
if you hit the wall on the right it will get back with the same force you putted, usually flying back and distorcing the car.
Its easier to pass throught the wall hitting more to the left.
When you pass throught, sometimes the car respawns back on track, but it can also respawn under the track and stay there. I think the bug happens on Y too, but I didn't try on Y.

And another bug: if you change the transmission from auto to manual using Shift + G and the engine dies, the replay get OOS. This only happens on single player (I couldn't reproduce this on multiplayer) and it doesn't matter the car/track, it will always get OOS. Tried starting on auto and then switching to manual: OOS. Tried starting on Manual, switching [Shift + G] to auto and then to manual [Shift + G]: OOS.
This happens on Y, Y21, Y22, Y24 and Y30. [Replay from Y30 attached]

And hey, why can't we see the Options Menu (Shift + O) when in Shift + U mode? I usually need to do that and I can't. Edit: If you press F9-F12 when in Shift + U mode, the HUD appears but the tires [for example] doesn't show on.

Anyway thank you so much Scawen this test patch is awesome
Attached images
bug.JPG
Attached files
Velociround_FE2_XFG_2.spr - 2.6 KB - 154 views
it is still in blackwood
Attached images
still there.JPG
My new interiors are a bit broken... see the attached image.

Any ideas why this happened? I did go from Y24 -> Y30, so I don't know if that has anything to do with it or if I've just got a legacy setting set somewhere that it shouldn't be...
Attached images
cockpit.JPG
^ Looks like both interiors are displayed at the same time

E: Ok, now I lost 2 unlocks to find out if my suspicions were right, and alas, they are.

You didn't install the patch correctly.
You're running Y30 .vob (vehicle mesh) files with an Y24 (or older) LFS.exe.
Attached images
lfs_00000101.jpg
... Looks kinda neat though...

/me must try the other way (y30 vob in y24 exe )
Damn, that's hell smart. Maybe that's the way how we could play y30 in y24 servers ..
OMG i love this patch...
Sorry if this has been posted before, but here is a bug on FE green. if you go into the sandy area, your car somehow sinks in there, then you can't move. If you don't have a reset button, you are screwed:
Attached images
LFS bug.jpg
That's the point of sand traps, actually. That you're able to wiggle out of most sand traps in LFS is the bug - what you describe is how it's supposed to be.
Quote from Furiously-Fast :Sorry if this has been posted before, but here is a bug on FE green. if you go into the sandy area, your car somehow sinks in there, then you can't move. If you don't have a reset button, you are screwed:

Yes, it's already known bug.
Quote from jonny__27 :ps: HOLD ON!!! i got something and THIS is pretty interesting! I started LFS to compare the wheels, and when i got to the main menu i noticed the bottom-right corner: "WTF! S2 License???" i exited lfs, reinstalled it, and it was in demo state again. Scawen do you know what could have caused this?

No, I have not heard of demo versions suddenly saying they are S2 licensed. Did you try to see if you could load a S2 track or car in that mode?

Quote from Cue-Ball :I'm sure this probably isn't related to the test patch, but it's a bit confusing anyway and has to do with Patch Y. When you host a game from within LFS.exe (which I haven't done since Demo/S1/S2 were combined) you still have the option for Demo / S1 / S2. Since all clients can now interconnect, should this option still be there? Is it just to make it easier to limit the server to particular content? If I select demo, can I then add a non-demo car without stopping the server and changing modes?

Yes it is just a simple way to limit the server to Demo, S2 or S2 content. If you start the server in demo mode (or dedicated host with /mode=demo) then you can't enable non-demo cars.

This is to allow starting a host that is guaranteed to allow demo racers or S1 racers, with a single option.
Quote from Furiously-Fast :Sorry if this has been posted before, but here is a bug on FE green. if you go into the sandy area, your car somehow sinks in there, then you can't move. If you don't have a reset button, you are screwed:

There is another bug that happens in most sand traps where the car appears to be floating in mid-air, but i suppose everyone knows about that one..
I have a little problem I think, I downloaded lfs again from the main website then installed it in a different map and installed the Y30 patch. When I load the game it runs very good, but I don't have the new interior for the GTR cars etc.

Does anyone know why perhaps?

Thanks Scawen for the patch makes the game graphics allot better and smoother
Quote from Frost_More :I have a little problem I think, I downloaded lfs again from the main website then installed it in a different map and installed the Y30 patch. When I load the game it runs very good, but I don't have the new interior for the GTR cars etc.

Does anyone know why perhaps?

Thanks Scawen for the patch makes the game graphics allot better and smoother

Does it say Y30 on the bottom of the opening screen?
This thread is closed

Test Patch Y30 : XF / XR Interiors
(447 posts, closed, started )
FGED GREDG RDFGDR GSFDG