LFSRelax 3 in 1 (TS View, AutoMessages, Pit Spotter) by Gai-Luron
(475 posts, started )
Hi Gai-Luron, I tested v1.47 online and found pitspotter to still be a little inaccurate although I think at times that it seems that it is trying to finish its 1st message before being able to adjust for the change of car positions and saying the correct message. Not sure if that has something to do with it. But I did here "your in the middle", so well done on getting that working
(sorry I didn't save any replay's, will try to next time)

Thanks again and keep those patches coming.
yep it does the same for me.
One thing I noticed when using TSView...
I have my Mic bound to my 'CTRL' key, and when I press it to talk, InSim throws a wobbly, spams me with a load of error messages, and then dies

Next time I get this phenomena I will try and save the repaly, so you can see what I mean.
Quote from Bladerunner :One thing I noticed when using TSView...
I have my Mic bound to my 'CTRL' key, and when I press it to talk, InSim throws a wobbly, spams me with a load of error messages, and then dies

Next time I get this phenomena I will try and save the repaly, so you can see what I mean.

Change to 1.47

Quote :I just tested it on the replay of the last OWRL race, and it stil makes big mistakes. In turn 4/5 you can see/hear what I mean:
http://www.lightning-racing.com/owrl_28072007.rar
I start from place 6

I look for 10 laps, and i view nothing abnormal. Can you more explain the problem? one time you pass a car stopped and pitSpotter say nothing, it's normal because your speed is more higthter.
The second time you pass a car, pit Spotter say correctly where this car is.
Sorry, but i don't understand . In other case, cars in front of you are to far.


Quote :Hi Gai-Luron, I tested v1.47 online and found pitspotter to still be a little inaccurate although I think at times that it seems that it is trying to finish its 1st message before being able to adjust for the change of car positions and saying the correct message. Not sure if that has something to do with it. But I did here "your in the middle", so well done on getting that working

Normally, when a position change, the first message is cutted with the new message. Here it work in this mode


Gai-Luron
Quote from Gai-Luron :Change to 1.47

I did...now it just crashes Relax, but without the spammed error messages..
If I can find out exactly what causes it, I'll let you know.
Quote from Gai-Luron :Change to 1.47
I look for 10 laps, and i view nothing abnormal. Can you more explain the problem? one time you pass a car stopped and pitSpotter say nothing, it's normal because your speed is more higthter.
The second time you pass a car, pit Spotter say correctly where this car is.
Sorry, but i don't understand . In other case, cars in front of you are to far.
Gai-Luron

in turn 4 or 5 of the first lap it says left or right a few times when there is no car. I heard the same mistake on 2 computers, but if you hear nothing wrong than it must be computer related somehow?
Quote from mrodgers :Is there anyone else using the outgauge gateway and using LFSRelax and finding it to work for them?

No, I've got the same problem No OutGauge apps works when insim is inicialized. Even when turn on OutGauge in Relax cfg. The problem is that Relax uses outgauge itself when its turned on. The best way would be to implement outgaugegateway or relay into Relax to make other outgauge apps work.
Think the idea is to stop LFSrelax from using outgage (there is a setting at top of config for that). You wont get the fuel calc then.
Quote from Demon68 :in turn 4 or 5 of the first lap it says left or right a few times when there is no car. I heard the same mistake on 2 computers, but if you hear nothing wrong than it must be computer related somehow?

What's your config in LFSConfig
DxR, DxL, DxB, DxF?

Edit: On slow machine, PitSpooter don't work correctly ( i try it on an old computer ). What is your frame Rate on LFS and your config?

Gai-Luron
Quote from Gai-Luron :What's your config in LFSConfig
DxR, DxL, DxB, DxF?

Edit: On slow machine, PitSpooter don't work correctly ( i try it on an old computer ). What is your frame Rate on LFS and your config?

Gai-Luron

Config is standard.
Frame rate on my gamecomputer ( http://www.lfsforum.net/showthread.php?p=473517#post473517 ) is more than 100 FPS with a full grid, on my old computer (pentium 3,2 Ghz + 6800GT) it is +/- 70 FPS
On these computers and on a computer of a friend it makes the same mistake every time so it can't be the hardware.
If you play the replay and watch my car, you don't hear nothing wrong in turn 4/5 ?
I have seen it calling out stuff with no cars around also, even on singleplayer. No idea what would cause it. I am using standard config settings.
Hello,


Test version : 1.48 in first post ( pit Spotter on certain config ). It work on a CPU AMD XP2000 and on 4400GT graphic card

Warning:

Don't put LFS in Hight Priority mode, in this mode LFSRelax loose most insim packet and pitspotter don't work correctly

Send me report!

Gai-Luron

Try also the exe attached to this post ( an alternate )
Attached files
LFSRelax.rar - 37.8 KB - 133 views
Confused??? which one is which now?? 1.48 or the attachment, which one should i use/test?
Test 1.48 before, after replace exe and test again. Look for better.
This was with 1.48...as you can see, the Pitspotter part is all over the place, and the TS View part crashes out halfway through!!
Attached files
lfs relax test.mpr - 419 KB - 213 views
is your LFS is in hight priority? Replay work fine on my old computer also.

Gai-Luron
New version : 1.49


Rewrite many part of the collision routine in 1.49. I hope this work fine for all now

Gai-Luron
Quote from Gai-Luron :Hello,

For the new add-on, i need your help because now you are an expert of configuring LFSRelax.

You can make a HOWTO for the noob and contribute to this way in the happyness of LFS community. I include this HOWTO in distrib under your name and your PM.
But even if you do this, i think there will be always people who don't read this file and they will fill your email or pm because they don't want search a little before post. I think of answering the requests as often as possible, but I cannot spend my time holding the hand with all.

Now, i wait your contribute, "your add'on" to LFSRelax.

Bye

Gai-Luron

I wish someone would write basic manual or smth. I still haven't got Relax to work - I think I don't still know where or how to "install" it.
Quote from PLAYLIFE :I wish someone would write basic manual or smth. I still haven't got Relax to work - I think I don't still know where or how to "install" it.

PLAYLIFE, not sure what your doing but I will go through the install, how I do it anyway.

Installation Procedure:
1. Open LFSRelax.rar file.
2. Within the rar window open the release folder.
3. Extract or Drag the bin folder to a folder of your choice on your HDD. (I put it into my main LFS folder).
4. Rename the bin folder (the one you just extracted onto your PC) as LFSRelax.

Start Procedure:
1. Start LFS (as you normally do).
2. Once LFS is running, open a text/chat message box by hitting "T" on the keyboard.
3. Type "/insim 29999" in the chat box then hit "enter".
4. Start LFSRelax.exe in you LFSRelax folder.
5. If successful you will see a message within LFS indicating LFSRelax is connected.

I will post how to edit the config file & what each of the main parameters mean later, after I work out the best way to write it for everyone to understand.

Gai-Luron, If you would like to include this in your documentation then please feel free to do so.
It is great to see you trying to sort out the pit spotter accuracy issues & 2 patches in a night means you are trying to match Scawen
Thank's flinty72,

Doc updated

@flinty72: it's the last version for 4 week, i go in Italy in this afternoon

bye

Gai-Luron
Quote from Gai-Luron :Thank's flinty72,

Doc updated

@flinty72: it's the last version for 4 week, i go in Italy in this afternoon

bye

Gai-Luron

Thanks Gai-Luron, have a great trip
-
(Demon68) DELETED by Demon68
@Gai-Luron

I have the following probs, i use LFSRelax only for using Pitspotter, but Pitspotter get no connection to port 29999 because LFSRelax is using this port ?

And in LFS i get this message

"INSIM: first byte in package does not match size"

What can i do to run Pitspotter with LFSRelax ?

twingo
LFSRelax has a pitspotter buit in (along with some other programs).
You don't need the old pitspotter (it doesn't work anymore with the new patch)
how can i get rid of the numbers in the middle of screen on ver 1.49?? thanks for a nice program.

LFSRelax 3 in 1 (TS View, AutoMessages, Pit Spotter) by Gai-Luron
(475 posts, started )
FGED GREDG RDFGDR GSFDG