The online racing simulator
Vcom tool and rotator
(131 posts, started )
You cannot get all laps into XML file currently (although the required information is there so it would simple to add). The best times XML file is for the best split and lap times for each player (and for each car) ever visited the server (offline is like a single player server).

You can get all your laps done during that 'stint', by typing !laps. It displays all splits and lap times for each lap. It also displays the pit stop duration and reason. If some time is in red it is the best for that race/stint. If it is yellow, it is your personal best for that race/stint. You should do this before restarting or going to car setup (they clear the lap stats because they also reset the lap number back to 1).

Another way to see consistency is to type !stats and checking the best lap, theoretical best lap and average lap time, and compare them.
Okay, that's what I thought. Thanks for the reply. Hopefully you may find time in the future to add this little feature for us offline-types. Thanks again and I enjoy your program.
Three more suggestions...

1) Option not to reset points when a driver disconnects.
2) Option to only count points when there are 5+ drivers on server.
3) A command to select which track in the rotation you want.*

* When you as admin type !rotate you go to the next track in the loop. But say you'd like to reach a track earlier in the loop. To reach that you'd have to write !rotate a lot of times, if the loop of tracks is long. Better to be able to type !rotate ## where the ## is the unique number for that track in the loop.

---

Thanks for the best Server tool ever. It's stable and run with no problem at all. And so much more idiot friendly than lapper
Quote from X-Ter :Three more suggestions...

1) Option not to reset points when a driver disconnects.
2) Option to only count points when there are 5+ drivers on server.

Yeah. Well those and the ranking system requires bit more coding and changes, because they are tied together and I would like to make as flexible as possible. Although those are in the todo list...and even quite high.

Quote from X-Ter :
3) A command to select which track in the rotation you want.*

* When you as admin type !rotate you go to the next track in the loop. But say you'd like to reach a track earlier in the loop. To reach that you'd have to write !rotate a lot of times, if the loop of tracks is long. Better to be able to type !rotate ## where the ## is the unique number for that track in the loop.

Have you tried that? If not, try and be amazed

(!rotate changes the next track on the user defined way (e.g random). !rotate <number>, select the track no matter what there is in the setup (even if the rotator is off) )


The rotator action can be called before the number of races is actually done.
Any user with admin rights can type !rotate, which makes the rotator to call
the track change immediately. [B][U]If a number is given after the !rotate command[/U][/B]
[B][U]the normal rotator track selection is overridden and it chooses the numbered[/U][/B]
[B][U]entry instead.[/U][/B] If you call the track change by !rotate, it resets the count of
finished races back to 0. (Example: "!rotate 2" -> chooses entry #2)

There is 0.473 now, but I haven't had time to test it very much. Wanna have a test?


0.473 - Aug 14, 2007
- NEW: Lap time estimator has now 2 modes (one to compare to the old best time
during the session and another to compare to theoretical best)
- NEW: Curse filter (can control people who use bad language)
- NEW: Lap data can be exported out into an XML file
- NEW: Added the missing 'std' class name (XFG, XRG)
- NEW: The directory where the logs are kept can be given in the setup file.
- NEW: !race.pit command to show the list of pit stops
- BUGFIX: lap time estimator giving sometimes odd times
- BUGFIX: One possible (but rare?) situation of hang up

Thanks, I missed that part of the rotator in the doc
And yes, I would love a go at the new version, hehe. Vcom is my favourite server tool ever
Quote from LFSn00b :I do not run a server, but i like the ability to change songs while driving, so i use VCom. I get millions of errors, which is kinda annoying. Screenie attached

Niko...just comment out ('#') the bits in the .cfg file that concern multiplayer!


Quote from Aquilifer :There is 0.473 now, but I haven't had time to test it very much. Wanna have a test?

Linky??
Quote from Bladerunner :Niko...just comment out ('#') the bits in the .cfg file that concern multiplayer!

The setup file and // - do not comment all stuff out, use the mode to select which is on and which is not.

@Niko
Niko you are trying to run things which are not ment to be run as a client. Those split time etc logger things work only as a server (dedi or non dedi). Well they work, but the printings does not (it tryes to send some messages to everybody but it cannot do that because client does not know IP addresses for other players). That's why the errors (for every line it tryes to send). With some tweaking I could make them work also in client. Radio is for client, stage rally for client and server. All others for server. Offline you are basicly a server so all work.

If you only want to use the radio, start it with "vcom 64" or set the mode to 64 (mode=64; ) in the setup.

Change songs? Sure you can but not to choose some particular song. You can put the "/o vcom radio next" to the F keys or if all your F keys are reserved for spamming, you can use global hotkeys too (a way which makes every player work - not just Winamp).

For example I do nicely with just On, Off, Next and volume+/- set in the F keys.

I know the readme is bit long and not very well structured. But is it really hard to understand or is it that nobody wants read it? This is just a humble question...maybe i should rewite the whole thing

Quote from Bladerunner :
Linky??

Attached files
vcom0473.zip - 446.3 KB - 164 views
Latest version up and running on SCORE. I like the default curse.txt

About the readme.txt... It's great, I couldn't be happier with it. In the future when I ask for stuff that's already in there, please respond with a RTFM. Tested the !rotator ## function in the latest version and it seems to work just as I was asking

Thanks for your hard work on this
lmao, like whats in the curse.txt
it gives me some messages about the configuration file. and it doesn't seem to work, when i try "/o vcom radio next" winamp doesn't respond. I'm using v5.24.
Quote :setup.dat: Line 108: Unknown label - autohi/delay
setup.dat: Line 181: Unknown label - radio/winamp_ip
setup.dat: Line 182: Unknown label - radio/winamp_port
setup.dat: Line 183: Unknown label - radio/vcom_ip
setup.dat: Line 184: Unknown label - radio/vcom_port
setup.dat: Line 185: Unknown label - radio/password
setup.dat: Line 186: Unknown label - radio/show_trackname

Quote from MonStarr :it gives me some messages about the configuration file. and it doesn't seem to work, when i try "/o vcom radio next" winamp doesn't respond. I'm using v5.24.

Did you copy the dll and ini into the winamp dir? If you use the 2nd method (window class or name), you cannot send commands to Winamp and that case you have to use global hotkeys (see Winamp preferences/global hotkeys). In the first method (with dll winamp plugin) you can send commands to Winamp without the need of hotkeys.

The list is warnings about labels it cannot recognise. Currently I hardcoded the car radio IPs into the code (as 127.0.0.1 because any other IP wouldn't make much sense). You don't have to care about those particular warnings currently. It reminds me about what I should still make. (I get the exact same warnings myself)
Ok, Ok, i figured it out! Seems like the stupid M$ firewall was the problem...
Looks ok. Check these:

- In winamp/options/preferences/plugins(general purpose)
There should be "UDP Controller v0.224". Double click it and check
if there is client information (connected=yes, ips, etc).
- Especially if the above didn't show a connection. In LFS, type "/o vcom radio connect"

Vcom establishes connection to the player only when vcom is started. So if the player wasn't on, when vcom was started, you need to type that radio connect command after the player is on. That's why it is better to start the player you are going to use before vcom (but it is not needed as explained).

Also to type commands in Vcom...you need to have a player 'connection' in the game (it checks the person who typed the command has enough rights to invoke it). When you start the game and you are in the main menu there might not have any connections. Try go first into a race/hotlap etc entry screen at least.

If that sounded difficult to understand, it is actually really simple when you get it.

EDIT: lol...did I really use over 20mins to type the answer...didn't see your answer before this. Well, good you made it work
Sorry for the huge bump, but...

I just found this tool and I wanted to say thanks! I've only messed with a with a few features, but what I've seen (rotator and xml results file) is very nice!

Got any future plans for it?
Hi, i just find Vcom this week, and install it on my Demo server. Great job !! Everything works fine, except track rotation. I have read this post and try all tips (reinstallation, syntax verification, vcom in is own directory, etc...)
But i allways hav this obvious message :

Admin called track rotation....
FAILED

Any idea ?

Vcom 0.473 with LFS 0.5 Y

Hers is the rotate section of config file :


// track rotator
rotate{
races_per_track=2; // races before changing track
//races_per_track=2-5; // min 2 and max 5
randomize=0; // 0=in order, 1=randomize, 2=randomize, not same track(entry) twice
// NOTE: 6000 is enough for offline, online put atleast 15000
wait=15000; // millisecs (1000..30000) - how long to wait track changes etc

track{
id=BL1;
qual=0; // minutes before the first race
laps=5; // race laps
bias=0; // bias used in randomizing new track (0=not used)
wind=0; // 0=no wind, 1=light wind, 2=strong wind
weather=1-3; // 1=day/brigh clear, 2=evening/cloudy, 3=dusk (usually)
cars=XFG+XRG+FBM;
mustpit=1;
}
track{
id=BL1R;
qual=0; // minutes before the first race
laps=5; // race laps
bias=0; // bias used in randomizing new track (0=not used)
wind=0; // 0=no wind, 1=light wind, 2=strong wind
weather=1-3; // 1=day/brigh clear, 2=evening/cloudy, 3=dusk (usually)
cars=XFG+XRG+FBM;
mustpit=1;
}
track{
id=BL2;
qual=0; // minutes before the first race
laps=5; // race laps
bias=0; // bias used in randomizing new track (0=not used)
wind=0; // 0=no wind, 1=light wind, 2=strong wind
weather=1-3; // 1=day/brigh clear, 2=evening/cloudy, 3=dusk (usually)
cars=XFG+XRG;
mustpit=1;
}
track{
id=BL2R;
qual=0; // minutes before the first race
laps=5; // race laps
bias=0; // bias used in randomizing new track (0=not used)
wind=0; // 0=no wind, 1=light wind, 2=strong wind
weather=1-3; // 1=day/brigh clear, 2=evening/cloudy, 3=dusk (usually)
cars=XFG+XRG;
mustpit=1;
}
}


Try changeing
bias=0 to bias=2
for all tracks. Oh and you can forget about reversed version in the demo. They won't load.
Nice, X-Ter, everything is working fine, now
Thanks a lot for your quick and good answer
You're most welcome
vcom on a unix-machine?
Hi there!

I was wondering, whether vcom would run under a unix environment (using wine) as i would like to run it on a unix-host.
Didn't manage to get it to work though ...
Quote from avetere :Hi there!

I was wondering, whether vcom would run under a unix environment (using wine) as i would like to run it on a unix-host.
Didn't manage to get it to work though ...

works for me, but you can't use any commands inside of the console itself, if you want to stop vcom, you have to ^C it or quit it from inside lfs.

Quote :$ wine --version
wine-1.0-rc3

cheers
Hi there i have 500 servers hosting me a server but i cant seem to get Vcom working i am running the latest version but once i type /insim 29999 and load up vcom i get this (IS_MTC - only for multiplayer hosts)
Quote from royk1991 :Hi there i have 500 servers hosting me a server but i cant seem to get Vcom working i am running the latest version but once i type /insim 29999 and load up vcom i get this (IS_MTC - only for multiplayer hosts)

my guess, the config on your dedicated host is borked.
i nedd help. it keeps saying

Insim: First byte in packet does not match size
Quote from bunder9999 :

edit: i think 0.474 is the latest,

Slight bump, 0.476 is last version released by Aquilifier but isnt in this thread or at LFS Database, so thought its probably good to have a link to it here in the vcom thread.

You can find 0.476 here , though i have attached it to this post also. 0.476 supports the fbm properly.
Attached files
vcom0476.zip - 450 KB - 92 views

Vcom tool and rotator
(131 posts, started )
FGED GREDG RDFGDR GSFDG