The online racing simulator
Test Patch U11: Fixes / VR updates
(257 posts, started , go to first unread)
Quote from Scawen :In the old system, there was some code that reduced the number of FF updates sent from LFS to the wheel drivers (to avoid overload which was a problem in the past, and may still be now, for some wheels) by making sure some number of frames had elapsed since the previous FF update. That number of frames depended on how different the current force was to the last force sent (more different, less frames needed to elapse). The relevant point is that it was related to a number of frames, so people discovered that having otherwise pointless frame rates like 1000 fps gave them more immediate force feedback. Now that code is gone, and you can set to allow 100 Hz FF updates, there is no need to use extremely high frame rates as you can't get higher then 100 Hz FF updates anyway.

Thanks, I love reading insights like this Thumbs up
Quote from luchian :And, if I may, a question that seems to be popular these days

As much as I hate derailing a thread like this, that was a good link, thanks for sharing.
Scawen do you know at what point lfs generally clips in regards to ffb? / at what point you get the most out of it on the software side.

Ie I run ffb at 100% ingame I can feel "tire direction", going forward the wheel changes ffb heavily when going to center while slaloming.
In a drift you can very distinctly feel when you've hit the point where the car will start to straighten. Kinda like a different ffb texture.

but with for example 25% ffb you don't feel this, though the strength kinda feels similar across the whole range.

At 60% the ffb gets heavier with more steering in a drift much more gradually/smooth giving a "round" feel
@Scawen: In multiplayer replays you have smoothed the steering wheel movements some time ago. Would that be possible or feasible during a multiplayer (live) race?

The background of my question is that I stream our training races (more or less) weekly on Youtube. The view changes among other things also in the cockpit view. If the cockpit is shown by a vehicle that is not on the streaming PC, the steering wheel movements are still jerky. Is the information missing for the "gentle" movements or is it possible to improve the behavior? Maybe - depending on the effort - does this improvement still have a place here? :-)

As a concrete example a stream / recording from the last race:
https://youtu.be/TXRA1Yp3Zv0?t=1143
Even when the cars are on the same PC, but on different instances of LFS, the wheel and car movement is still slightly jerky. It is due to network connection...
I have just tried on a valve index. I feel that there is an fps cap at 90Hz.i don't know how to unleash 100fps... As the index is 120Hz capable.
-
(THE WIZARD DK) DELETED by THE WIZARD DK : guess scawen has seen it.
Quote from emiljensen2 :Scawen do you know at what point lfs generally clips in regards to ffb? / at what point you get the most out of it on the software side.

Ie I run ffb at 100% ingame I can feel "tire direction", going forward the wheel changes ffb heavily when going to center while slaloming.
In a drift you can very distinctly feel when you've hit the point where the car will start to straighten. Kinda like a different ffb texture.

but with for example 25% ffb you don't feel this, though the strength kinda feels similar across the whole range.

At 60% the ffb gets heavier with more steering in a drift much more gradually/smooth giving a "round" feel

Heh, I've upgraded to a simucube 2 which has an option to beep when clipping, and tried out drifting with the XRT. I was seemingly clipping while in drift at 60%
I've settled at 18%, this doesn't clip when force transitioning with the wheel, or doing car park burnouts to cause a tank slap in the other direction. Though those are rare cases, so can increase by like 10-15% safely with little loss.
Test Patch U9 is now available.


- When LFS is set to close the reason is logged to deb.log file

TRM.13: please try to enter VR and then as soon as it goes wrong and LFS closes, please attach the deb.log file

- Live telemetry is available in a new customisable OutSim packet

Programmers: https://www.lfs.net/forum/thread/93701

- Yellow and blue flags now alternate with RCM or penalty message
- FIX: Stop-go penalty caused car to get stuck in custom pit stop


Download: https://www.lfs.net/forum/thread/93185
What were the FF Steps and FF Rates in 0.6U6 and earlier?
TRM.13: I've moved our discussion about your crash into a separate thread in the bug reports section. That's because it's quite a long discussion now and isn't really related to the test patch (although I'd like to fix it in a test patch).
https://www.lfs.net/forum/thread/93703
emiljensen2: TRM.13 found the reason for the crash. It crashes if "fixed foveated rendering" is enabled.
https://www.lfs.net/forum/post/1951489#post1951489

EDIT: If it's easy to do a quick test, I'd be interested to know if the same thing happens on your computer.
when you press "T" and make /AI and restart the race
all car plates change automatically to name "AI 1"

tested on 0.6U7

now i install 0.6U9

works well at this part
0.6U test first time use Valve Index VR and full tracking test.



Smile
Quote from GT4_PL :0.6U test first time use Valve Index VR and full tracking test.

https://youtu.be/P2FU7lxlf30

Smile

That's really low fps, even for a normal screen. I guess you could get much better experience if you manage to get them higher.

The video itself reports to be 60 fps, but to be honest I got pretty uncomfortable watching it, it's not smooth at all.
Quote from Whiskey :That's really low fps, even for a normal screen. I guess you could get much better experience if you manage to get them higher.

The video itself reports to be 60 fps, but to be honest I got pretty uncomfortable watching it, it's not smooth at all.

It's not smooth only at the beginning. Later on it gets better.

It's pretty hilarious (6:30) that you can just get out of the car and walk around it. I don't have a VR set and I just wonder - how many other racing sims allow you to do that?
Yea when i see my headset look like 60 fps above but FPS say 45 fps that strange. xd
I need better GPU or Less Resolution Render quality.

i play newest version 0.6U9 tested, use Valve Index set 90hz.

Look better resolution quality adjust 150-200% enough and 4x antialiasing. Tried 8x see no different a bit drop fps. 4x better stable fps 90 fps smooth.
Still no optimized there are input lag a bit tearing. I tried set lowest 25% resolution adjust quality so same input lag tearing, i mean frame rate mismatch.

I tried set to 120hz VR. Weird bad optimized input lag than 90hz, becuase LFS engine physics is 100 fps limit?. Because Index have 144hz.

Scawen when fix optimized for VR? and 100fps limit to 150fps limit physics?

Sorry my bad english.

my specs:


I played BONEWORKS VR so great optimized and smooth.
Quote from GT4_PL :...
Scawen when fix optimized for VR? and 100fps limit to 150fps limit physics?

...

iirc, Scawen mentioned that among the tire physics update he would like to segregate physics and graphics in different thread, allowing a largely greater optimized VR experience than the current 100Hz used.
This implies aswell the timescale with a 10ms unit currently, and not 1ms as we may expect in a coming future (drag racing fans on the starting line Big grin )

Let's first expect a great progress regarding SO 2.0 (Eric, do not be afraid, you can show it to us Big grin ) and Scawen lightings tests before having Scawen getting hardcore on the above topic ^^
Just wanted to note a bug I've seen in single player mode (and maybe once or twice on online). The bug is effectively the car setup automatically switching to whatever the default is (race/hard/autocross).

It always occurs after you have shift+p or shift+s and rejoined the race/session. I can't replicate it though and it's very rare. Just an FYI.
Asseto Corsa played test really great smooth but LFS nope. Frown

LFS did Valve Index support?
A very, VERY anoying bug that occurs often to me. (sadly I didn't record it or have anymore helpfull stuff but:

Often after I've been afk for a while in a multiplayer server, with it usually minimized. And come back when other cars are there, the other cars don't "load". They are completally invisible to me, yet if I would drive on track. (problem persists after race restarts) they will see and be able to collide with me, yet I would drive like a lonely car on track.

Cars hitting me in this moment on their screen, get shot away. Yet I notice nothing and seem to drive in ghost town.

So:
- After idling for a while
- Usually with LFS minimized
- Other cars become invisible
- Other drivers can see my car

Edit:
What usually fixed it for me was reconnecting, not nessecary to restart the entire game.
Quote from rockclan :Often after I've been afk for a while in a multiplayer server, with it usually minimized. And come back when other cars are there, the other cars don't "load". They are completally invisible to me, yet if I would drive on track. (problem persists after race restarts) they will see and be able to collide with me, yet I would drive like a lonely car on track.

Edit:
What usually fixed it for me was reconnecting, not nessecary to restart the entire game.

That sounds a lot like your computer is messing up a socket.
Did you try to switch between UDP and TCP packets in LFS? That should work even without leaving the server.
Quote from GT4_PL :Asseto Corsa played test really great smooth but LFS nope. Frown

LFS did Valve Index support?

Both run smoothly. There must be a problem in your setup.
Yes LFS also uses OpenVR!
I don't see anyone else with the same set-up to just to say, I have been messing around with a new HP Reverb in LFS, and it works very well.

It's pretty awesome seeing Blackwood in such crystal clear Virtual Reality. Like watching a classic in 4K remastered! The only thing I'd say is the shimmering of distant shadows is quite bad. For comparison the same issue affects AC and it's much worse, can't say I really noticed it on the Rift CV1, not sure if it's an OpenVR thing or due to higher resolution and clarity on the Reverb.

Not to detract, but I want to try the Valve Index, whilst the Reverb hits a gold standard - I can see distant detail with the same clarity as a 1080p monitor - but it has other flaws that I'd consider trading for a resolution between CV1 and reverb. Need to spend more time with it.

Test Patch U11: Fixes / VR updates
(257 posts, started )
FGED GREDG RDFGDR GSFDG