The online racing simulator
Patch X Released!
(305 posts, started )
well done bouys patch x rocks,,,now go take a long earned break in a nice sunny place
Thx u devs! :headbang:
Ok when i got patch X, i put it on. Click the LFS.exe file and it comes up with some recangle box thingo that takes commands. thats all it is and i cant play LFS at all.
thanks, 32 cars is great fun!
Quote from Kaizu :Ok when i got patch X, i put it on. Click the LFS.exe file and it comes up with some recangle box thingo that takes commands. thats all it is and i cant play LFS at all.

You have some screenshot of the recangle box thingo ?
PrntScrn Key >> paste to MS Paint >> Save As .JPG if you dont know how.

Or you could try downloading the whole of version X from http://www.lfs.net/?page=downloads to see if that works first.
&/¤%&¤
this versjon sucks dick ! ! ! no one that knows where i can downloadn any older versjon ?? pleeas !
search button maybe?
care to elaborate why this version "sucks dick"?
Quote from Spazeman :this versjon sucks dick ! ! ! no one that knows where i can downloadn any older versjon ?? pleeas !

i'm glad you would share your opinion with us. but you should've kept it for yourself, you're an embarrassment to the whole community.

atleast you could've explained why didn't like it. by the way, are you really 24 years old?
Just want to say big thanks for this great new patch! I just got a G25 wheel and the addition of realistic starts couldn't have been better timed for me. Now the race starts feel totally realistic with the clutch and shifter and having to react to the lights
Heyho, i'm not finding the option wich causes the game jump in windowed mode if i wanna see the server list. Thats really annoying with 256 MB RAM. :/

Anybody can tell me where to find that option?
just weird that i found that option on patch V.
It's on the multiplayer screen "Window while connecting"
I seem to be having FPS issues with ai Cars on the track. I have gone through these threads and tried just about all and have a modern system that runs all my other racing sims very well. Without ai I run in the 80-90s. I saw one post that mentioned trying the simple track option, but I cannot find it in my interface? Can someone direct me to it to try that(probably the only thing I have not tried yet)

Thanks guys

btw, yes I have an active spy and virus program and have tried them disabled too. All unneccasry stop stopped in the background. My GPL even runs a solid 36 at all times!

this sim just has me baffled on this issue.

Is there a place to manually pick simple track if it is not in the interface?

Thanks guys.

btw....
I seem fine online too, with many cars. Just strange

system should be up to it= dual core 3.2 800mhz
2g ram
6800 ultra pci 256

Temps are good and run one and a half hour races in leagues with all other sims and no issues.

I love LFS, but would like to race the ai sometimes in practice.

Thanks for any help guys

BG
The problem (and big plus) with the AI in LFS is that they use the same complex physics calculations that the human player does. The problem, of course, is that it takes a ton of computing horsepower to get an entire field of AI running with all those physics calculations. That's all the problem is.
Quote from DeadWolfBones :The problem (and big plus) with the AI in LFS is that they use the same complex physics calculations that the human player does. The problem, of course, is that it takes a ton of computing horsepower to get an entire field of AI running with all those physics calculations. That's all the problem is.

Thank You sir for that view of the problem. It makes perfect sense. Because it runs fine without the 14 or so we can run now. I will just start taking one ai out at a time till I find my sweet spot and leave all the eye candy running. I like to start in the back and work my way through many cars.....


oooo and btw, I would still like to try the simple track deal that someone said helped a lot.

Thanks
BG
Yes - as DedWolfBones said, each AI car is in full physics - unlike in multiplayer where distant cars are invisible (no physics) and middle distance cars use a simple physics model and only the 4 nearest cars use full physics, so you have much better frame rates online with a full field.

I think the "simple track" option is only available on graphics cards that do not have Hardware Vertex Shading. HVS is no longer an option because people often disabled it thinking it was slowing down their computer when in fact it can only speed things up - massively. Simple track on a modern card would do nothing but slow down the card - so I don't think that would help you at all - and anyway if you can't see it in graphics options then it's not available to you because your card is too new (made within the last few years).
Quote from Scawen :Avoided most of the "Can't x - a player is connecting" messages

The messages have been removed but still you can't do anything untill the new comer is finally connected to the server.
Yes, I know. That's not by chance, I coded it that way.

Every time that happens, that you are delayed for one, two or three seconds after clicking something that changes the game state (like pitting, spectating, leaving pits, etc) you should be happy that it delayed you for two seconds.

Well, be happy for the guy who joined, because he didn't then get kicked immediately because he was out of sync. And be happy for yourself each time you join a server and don't get kicked, because LFS is protecting you by making people wait one or two seconds occasionally if they try to do something at that momnet you are connecting.

There is a lot of data, connection info, car and setup info, damage, player info, which must be transmitted to a joining player. If the game state changes while he is joining, then he is out of sync and gets kicked.

This is not "stupid" or "ridiculous" as some people say it is - that's because they have never tried to make a multiplayer game with mid game join. It's quite a complicated process getting all that info correctly to the new player so the "game state" on his computer matches the "game state" on everyone else's computer.

Some people here may remember before we introduced the OOS check, very strange things could happen, someone could talk and on some peoples computers, the name before the text was wrong. Half the field might restart race while the other half continued racing. On some computers, someone won the race, while on others, there wasn't anyone near the finish line. Sometimes, at race restart, one guy was off the line way before the others. The OOS check started making sure everyone was in sync before anything odd happened. It requires some protection to avoid synchronisation errors.
Quote from Scawen :Yes - as DedWolfBones said, each AI car is in full physics - unlike in multiplayer where distant cars are invisible (no physics) and middle distance cars use a simple physics model and only the 4 nearest cars use full physics, so you have much better frame rates online with a full field.

I think the "simple track" option is only available on graphics cards that do not have Hardware Vertex Shading. HVS is no longer an option because people often disabled it thinking it was slowing down their computer when in fact it can only speed things up - massively. Simple track on a modern card would do nothing but slow down the card - so I don't think that would help you at all - and anyway if you can't see it in graphics options then it's not available to you because your card is too new (made within the last few years).

Thanks for the definative answer on this Scawen! I will quit chasing my tail on this issue and reduce the number of ai till it is ok.

btw, Thanks for all the fun! My UF drives very much like my track-day Mini Cooper. Keeps me fresh and out of real speeding tickets

BG
Quote from Mike85 : add an option to reset and NOT fix the car

That was just removed
Quote from Mike85 :For patch Y I would suggest:

add an option to reset and NOT fix the car

This discussion has been covered pretty well already, let's not start it up here too.
Quote from Mike85 :Why was it removed in the first place?

It was unrealistic, as has been said gazillion time before.

And before you say that the fixing reset is unrealistic too: It is there to make it more convienent if you just want to practice or to fool around.
Quote from SamH :Think I've had a no-sound bug. I thought it was my system.. had to restart the PC to fix it. Since then, I've seen numerous people report the same thing.
...
The sound toggle doesn't work. It always shows Sound Off when we hit Shift+N.
...
Other applications work/ed for both of us (I was able to play MP3s etc)

I'm also losing sound in LFS only when I plug/unplug an USB device, usually an USB storage stick or an USB TV tuner or an USB external HDD.

However pressing Shift+N restores the sound.
Thanks for the good work (and dont stop ! )
Quote from Mike85 :
ability to configure ALL the buttons to your liking (nothing hard coded)


Yeah that is one thing that bugs the hell out of me every time I play LFS.. All those buttons that you cannot re-configure.. How many years must we wait? Anyway, it's nice to see LFS progression moving along.

Patch X Released!
(305 posts, started )
FGED GREDG RDFGDR GSFDG