The online racing simulator
Test Patch 0.6A4 (old content / old physics / many updates)
WARNING : THIS IS A TEST (hopefully the final test in this series)

NOTE : THIS DOES NOT CONTAIN NEW TYRE PHYSICS / VW SCIROCCO / ROCKINGHAM

PLEASE TEST BEFORE YOU POST

RULE : NO OFF-TOPIC FEATURE REQUESTS

RULE : NO UNRELATED COMMENTS

Hello Racers, here is a new Test Patch : 0.6A4

You can read the story behind this thread in the main forum thread :
http://www.lfsforum.net/showthread.php?t=73874

0.6A4 is NOT compatible with version 0.5Z28.
0.6A4 CAN play most version 0.5Z28 replays.
0.6 and 0.5 versions cannot connect to each other.

You cannot upload hotlaps made with 0.5Z30 to 0.6A4 because they are test patches.

Please keep a backup of your LFS.exe from version Z28 so you can go back to Z28 if there are any problems.


Changes from 0.6A3 TO 0.6A4 :

Updated Commands.txt and Autocross.txt
FIX : Small documentation error in InSim.txt (ISP_X / ISF_X)
FIX : Racing line did not work again after viewing invalid car
FIX : MAX ALPHA (unsorted) after adding a lot of chalk objects

InSim :

New IS_RIP option FULL_PHYS to use full physics when searching
FIX : TTime in IS_RIP was wrong in mid-join Multiplayer Replays


Changes from 0.5Z28 to 0.6A3 :

Contact detection and collisions :

Improved contact detection with road / walls / pit garage exit
Improved collisions with unmovable objects (e.g. red barriers)
Unmovable objects (e.g. ramps) now have concrete friction level
Improved wheel contact detection to reduce bad car collisions

SHIFT+U mode :

New free view mode replaces the old "low" and "high" path modes
Object or ground targeted by the mouse pointer is now detected
Left mouse button moves view point by "dragging" target point
Double click to move view point directly towards target point
Mouse wheel moves view point towards or away from target point
Left + Right mouse buttons rotate view point around the target
Arrow key movement follows ground below view point when possible
Store up to 10 views per track configuration with SHIFT+NUMBER
Recall a stored view with CTRL+NUMBER (or click the button)
Click on a car to follow it / look away to stop following
List of connections is now displayed in SHIFT+U mode
FIX : N key with options on caused overlapping text

Autocross editor :

New objects added and all objects are available at all tracks
Maximum number of autocross objects increased to 800 (was 512)
Multiple object selection - press CTRL and click object button
Selection can be deleted, copied (O), moved (M), rotated (,/.)
Object positioning is now accurate (uses mouse target detection)
Less CPU / better checks when adding / moving / deleting objects
Adding / removing autocross objects no longer resets all objects
Prevented mouse camera movement between button click and release
Reduced Z-buffer flickering of chalk objects and pit stop markers
Speed limit no longer enforced if autocross start position exists
Save layout button is now displayed in an SPR (same as in an MPR)
W/E/,/. keys now move values in minimum steps and use auto repeat
FIX : Name of loaded layout now remains or is cleared as expected
FIX : Could click on invisible replay slider when buttons visible
FIX : Could add marshall circles out of bounds (then undeletable)
FIX : High altitude layout objects appeared under ground on load
FIX : Start position sometimes remained active after deleting it

Open configurations :

New "drive anywhere" open configs (CTRL in track select screen)
Add checkpoints / barriers to use open configs as race circuits
Checkpoints can now be up to 62 metres wide to include pit lane
Open configs can be selected with text command like /track=SO1X
Custom layouts race progress / history now stored at LFS World
Qualifying / race positions list / blue flags are supported

Optimisations :

Frame rate increased - drawing most world objects is much faster
Optimised transparent objects (e.g. fences) to help open configs
Much better frame rate with many autocross objects (faster draw)
Removed continual small memory leaks (materials list corruption)
Number plate generation is much faster, reducing pit-out glitch

Hotlapping support :

Tyres section in garage - settings for tyre warmer temperatures
You can load a layout in hotlap mode (may include start position)
NOTE : LFS World hotlaps may include start position - not objects
Hotlapping is possible on open configurations (not for LFS World)
Exit from pits now results in a clean restart to hotlap position
Reliable detection of wall side impacts (e.g. at South City)
Pit stops are no longer available in Hotlapping mode

Interface :

Unlock screen now renames unnamed player to user name on exit
Clicking selected track loads that track (like pressing ENTER)
Windows messages processed in a cleaner way (affects key presses)
Mouse movements are processed more efficiently (drag / slide)
FIX : Mouse look info could go off screen in some languages
FIX : An invalid view could be selected when no cars in race
FIX : Meeting room scroll bar was invisible in recent versions
FIX : Occasionally refuelling did not match set amount

Graphics / Audio :

Improved display of help text / lesson text / welcome messages
F9 tyre diagram and SHIFT+L suspension diagrams now antialiased
Improved tyre optimisation - no missing parts of deflected tyres
Entry screen logo and frame are now drawn if a dialog box is open
FIX : In Driver Options the driver intersected with world objects
FIX : Reset from behind a barrier at South City could stop sound
FIX : Missing shadow on ground near fences at Autocross track

Multiplayer :

Wear limit for changing tyres can be set to 100% (never)
List of hosts can now show hosts you are not licensed to join
Host name is displayed in task bar and window title (if Latin)
Dedicated host window now adds new messages without flickering
Implemented VOB mod protection (physical changes will cause OOS)
Maximum qualifying time increased from 60 minutes to 240 minutes
Host options are now readable when opened from game setup screen
Default host IP address is now 127.0.0.1 (address of local host)
CTRL+SHIFT now displays time and date in all multiplayer replays
Driver sent his / her setup - message is now displayed only once
Removed TCP filter that allowed old versions in the list of hosts
FIX : On joining host, cars not past finish line showed wrong lap
FIX : Some problems resulting from multiple requests to join race
FIX : Pit stop did not end if car was knocked out of the pit lane
FIX : Some crashes that could result from an invalid unlock state
FIX : Some missing images (e.g. track select) caused LFS to crash
FIX : Suspension could incorrectly stay broken on remote computer
FIX : It was possible to get stuck on the track selection screen
FIX : Host restart exploit caused by multiple join packets
FIX : Avoided some possible unauthorised connections

Text commands :

New command /ck cancels any kick or ban votes in progress
New command /cv cancels game votes (restart / end / qualify)
Command /modified=yes allows a private host to avoid CP checks

InSim :

NLP / MCI minimum time interval reduced to 40 ms (was 50 ms)
Longer IS_MST now up to 128 chars / specify sound / send to all
Lap timing info added to IS_RST (standard / custom / checkpoints)
New packet IS_CON reports details of contact between two cars
New packet IS_OBH reports information about any object hit
New packet IS_HLV reports incidents that would violate HLVC
New packet IS_PLC sets allowed cars for individual players
New packet IS_AXM to add / remove / clear autocross objects
New packet IS_ACR reports successful or attempted admin commands
OutGauge : OG_SHIFT and OG_CTRL (keys) bits added to OutGaugePack
Security : InSim can no longer be initialised from a URL command
FIX : Clutch axis / button was not reported from Controls screen
FIX : IS_BTN did not allow the documented limit of 240 characters
FIX : InSim camera with vertical pitch would cause LFS to crash
FIX : OutGaugePack ID was always zero regardless of ID in cfg.txt

Track fixes :

BL : Repaired floating laptop on tool box in first pit garage
SO : Removed a ghostly collision object in South City pit lane
SO : Removed two barriers embedded in tyre wall (Sprint Tracks)
SO : Repaired a sunken barrier closing pit lane (Sprint Track 1)
WE : Fixed the position of the reversed configuration finish line
KY : Removed some barrier end segment errors from Oval / National

Misc :

New Ukrainian translation included
Hungarian translations of training lessons updated
CTRL+C now clips the mouse so window size cannot be adjusted
Admin commands from all connections are now logged (if enabled)
If logging is enabled a message is logged when an admin connects
TC Allowed Slip slider now goes up to 20% (previous maximum 10%)
The digit "1" now occupies the same screen space as other digits
On changing allowed cars, disallowed cars now join the spectators
Improved detection of invalid window positions when starting LFS
URL command is now case insensitive - LFS:// or lfs:// both work
Misc options : F9 / F10 accelerometer can be shown as one value
Cruise : current lap is not displayed if lap timing is disabled
Cruise : no need to drive a lap before serving DT / SG penalty
FIX : It was possible to set qualifying on an autocross layout


DOWNLOADS :

PATCH Z25 to 0.6A4 (PATCH INSTALLER) (if you already have Z25) :
http://www.liveforspeed.net/fi ... ATCH_Z25_TO_6A4_setup.exe (3.2 MB)

PATCH Z25 to 0.6A4 (ALTERNATIVE ZIP) (if you already have Z25) :
www.liveforspeed.net/file_lfs. ... =LFS_PATCH_Z25_TO_6A4.zip (3.5 MB)

FULL VERSION 0.6A4 (INSTALLER) (full version) :
http://www.liveforspeed.net/fi ... name=LFS_S2_6A4_setup.exe (134 MB)

DEDICATED HOST 0.6A4 (non-graphical version for hosting only) :
www.liveforspeed.net/file_lfs.php?name=LFS_S2_DEDI_6A4.zip (1.6 MB)
Thanks, will test soon, probably we won't find anymore bugs I suspect.

E:

When starting up it directed me through the whole first start-up procedure, so I was scared I had to unlock again. (since I have no unlocks left) However I didn't need, and was just able to join every 0.6 server.

Done some layout editing on single player, seems to work all fine.

Now driving cruise online, no problems.

Great job.
Bug report
I experienced the following minor issue:

After updating from 0.6A3 to 0.6A4, startup took a long time (30sec) with "textures loading" alternating between 1% and 2%. After that, it continued to the initial setup sequence. All my settings were the same, expect the language was set to Chinese (or a similar asian language).

Subsequent starts are instant and without problems.
Just tested racing line bug, now works thanks :auto:
InSim.txt errors
5 // InSim for Live for Speed : 0.5B
Must 0.6A4

16 // INSIM VERSION NUMBER (updated for version 0.5Z30)
Must 0.6A4
#6 - SJB
0.5B is the INSIM Version, its not the Game Version
The InSim version number was updated for 0.5Z30 and later, so I don't see a problem there.
0.6A4: in autocross editor still one undocumented button exists. I mean "D: measure tool". I didnt see info like this everywhere at screen in shift+U mode. It would be good if it appear in left-top of screen where all hotkey info located.
It seems that the join bug is still there. I tried to spec and then join and it showed me "cannot add car info - unknown id" :/
Quote from Flame CZE :
Edit: And another bug, it seems like it's an echo map bug or something... I get out of the pits with XFG at FE2X, turn left, go through the green chicane and suddenly the car sound volume decreases a bit.

Edit2: tested it on the original LFS 0.6A4 and it doesn't happen, so it can be my LFS only.

Echo and light maps haven't been made for the [X,Y] configurations. This was mentioned when the open configs first appeared.
I'm sorry, it was my TS fault
Scawen, when editing layouts it's possible to place/make only one start position. It's posible to increase then? (to 32)
Dunno if you wanna hear it, but its running ace
Probably it is too late, but I remembered one rare bug. Sometimes (1 of a 1000 races) the race time is delayed, usually by 2 or 3 seconds. I mean race starts, cars go properly, but race time stays at 0:00.00 for 2-3 seconds, only then it starts counting. The result is impossible lap 1 time and impossible race time too.
The whole counter is off by one or two seconds because of the delay? Does this save to the reply state?
Quote from EQ Worry :Probably it is too late, but I remembered one rare bug. Sometimes (1 of a 1000 races) the race time is delayed, usually by 2 or 3 seconds. I mean race starts, cars go properly, but race time stays at 0:00.00 for 2-3 seconds, only then it starts counting. The result is impossible lap 1 time and impossible race time too.

That usualy happen when someone timeout when race restarts.
I've sent mail to developers about it.
Here is the replay:
P.S. I'm not that bad driver, I was just confused about it....
Attached files
delay bug.mpr - 647.9 KB - 451 views
What about that Scawen :

Quote from Kova. :I've found a little bug a few hours ago when I was training for Kyoto 500.
The tires temperature is a bit on tires' band, which prevent us of seeing tires degradation of FO8. :/

IDK if the same thing happened to other cars...

E: I know that NDR's server is 0.5Z28, but after checking, there is the same bug on 0.6A3

http://www.lfsforum.net/attach ... d=114989&d=1308082403
Quote from Lucas McFly :Hello

The LFS version 0.6A4 is still error described in this thread.

http://www.lfsforum.net/showthread.php?p=1595554#post1595554

Scawen answered that here

Quote from Scawen :I see, you mean the collisions are not good when you hit the end of an object. No, that will not be changed in this version.

I couldn't link back to the old threads in a quote, but I think the ends of objects won't be fixed this time, and the barrier in South City would need a track change. So not this patch either.
delay bug happend today again on cargame S0 (looks like bug really love me, I've noticed it almost every week)

PS. look from start (when that happen) to first split, than skip to third lap, and look to end
Attached files
delay bug 2.mpr - 792.4 KB - 413 views
I'm not sure, whether this is old or new, but as of now it is possible to place autocross objects via insim:

It is possible to place an object in a place, where currently a car is. I've tried this for example with an armco5, placing it right inside my car. The result obviously is quite a nice flip (instantly).
Unfortunately I cannot provide you with a replay, as I can't save it, once I have altered the layout

Anyway: I think there should be a check, whether a car is present or not, before an object is actually placed. Especially if this is done during a session via insim there might be (more or less) funny effects otherwise.


btw: You are also instantly spinned away, if such an object is placed right where your car is placed on the grid (see replay) not sure, if there can be done anything about it though
Attached files
autoXspin.spr - 1.5 KB - 400 views
Good catch, Daniel! Especially in the 1st replay the delay seems to be about 1.5 seconds, easily noticeable. But I've had even worse delays, strange thing.
Quote from avetere :I'm not sure, whether this is old or new, but as of now it is possible to place autocross objects via insim:

It is possible to place an object in a place, where currently a car is. I've tried this for example with an armco5, placing it right inside my car. The result obviously is quite a nice flip (instantly).
Unfortunately I cannot provide you with a replay, as I can't save it, once I have altered the layout

Anyway: I think there should be a check, whether a car is present or not, before an object is actually placed. Especially if this is done during a session via insim there might be (more or less) funny effects otherwise.


btw: You are also instantly spinned away, if such an object is placed right where your car is placed on the grid (see replay) not sure, if there can be done anything about it though

That is also possible in the editor, so not InSim specific. In a multiplayer editing session it can be both fun and annoying to place a barrier at another car position and watch them flip.

Related to this, I've tried but not been able to provoke a car reset that re spawns the car where there are already layout objects. If no checks are made, this could happen, but I can't confirm it does, and in fact some checking may take place anyway. If that's the case, we are halfway there when placing objects in the editor or via InSim. Resetting on a ramp does cause odd things to happen, either car ends up inside it, or flips immediately, but other objects seem to be ok in this regard.

Personally I don't consider this an important bug, and more like a mis-feature, although an intersection test with cars might be very useful.
I know it is possible in the editor (I've done it that way). I actually pointed out insim, because that would be fully automated, whereas manually putting an object via editor involves the admin looking at what he does (though an intersection-check would prevent abuse also in this case)
Quote from Scawen :WARNING : THIS IS A TEST (hopefully the final test in this series)


Scawen,

two issues after "installing" the latest 6A4 patch.

- I can only start in Windowed mode; Shift+F4 or starting fullscreen freezes the system (Windows Vista up-to-date) - I have had to reboot several times upon this.
- I had to unlock the S2 content

No error messages.

Just the freeze-out.

Miguel
PS: I keep 2 other versions: Z28 and Z34 (in separate folders, with obviously different names). Both run OK and are unlocked. I launch them with ZERO problems.

FGED GREDG RDFGDR GSFDG