The online racing simulator
New Version 0.6T - More robust multiplayer system
(210 posts, started )
Hm yeah, the problem is that we've locked down the server the relay ran on. Port 47474 is open for the outside to connect to, but the relay is not allowed to make outgoing connections to random ports (the hosts). This is due to us locking traffic down upstream, on a switch and not a firewall. And the switch isn't stateful, so it's not capable of discerning between incoming and outgoing connections / traffic.
Because of that, I've moved the relay to another server with some more networking freedom. The relay is now connecting to all hosts again and you can use it if you connect [your app] to isrelay.lfs.net .
BUT this brings another problem ... the LFS Remote apparently was coded to connect to "lfs.net" and not "isrelay.lfs.net". So now it's trying to connect to the wrong thing. On top of that I seem to have displaced the source code for the LFS Remote ... so now there is no way of fixing it.
Sooooo ... I guess the need for a HTML5 remote is really there now.
Unfortunately that's not a quick solution, but one that can be realised if I can find some free time (or maybe it can be a community effort? I've no problems making it an open source project ... it'll be javascript anyway, so it's open by default Smile )
Can we PLEASE have an option for the old editor back.
Of course not. There is no way on earth we would drop the far improved editor to go back to the old fatally flawed one. Please try to understand how to use the updated editor. It does everything the old one did and quite a lot more.

Reasons, explanations: https://www.lfs.net/forum/thread/92152-The-layout-editor-changes
Quote from Victor :
Unfortunately that's not a quick solution, but one that can be realised if I can find some free time (or maybe it can be a community effort? I've no problems making it an open source project ... it'll be javascript anyway, so it's open by default Smile )

thanks for the review - for me that's OK.

Do you not have already a HTML5 version? Is not ready yet? Perhaps it is enough (with handycaps) then nothing? :-)

Small please: Can someone of the devs reset the activation counter or release one possible activation for my account? If not, I can also wait until friday. - Thanks anyway
#55 - troy
There is a working prototype on git, https://github.com/VictorVanV/HtmlRemote Maybe we could find somebody to help out Vic with some code. Smile

edit: Ah I just noticed you posted in the old thread too, so I guess you knew about this already.
How do I get the shaders to work like they used to again...This gets annoying having to fix the game for myself with every update, seriously.
https://i.imgur.com/u3Hq19i.png
https://i.imgur.com/Q6GH80g.png

uploaded shaders from 0.6r if someone can fix it to work in 0.6T....thanks

edit: never mind i fixed it again myself like usual, sorry for the tone
I removed the img tags in your post as they forced every visitor to this page to download huge image files.

For some reason your attachment has disappeared in the process, which I did not intend. Maybe a forum bug?

Anyway, obviously we provide patches and updates with working shaders. If you use modified shaders maybe you should keep the originals backed up so if there is a change you can install a working set until your custom shader developer updates his or her shaders.

We are going to update the shaders sometimes, it's part of the development process.
That seems very unusual! I think it looks as if the unfinished image is being presented as a completed frame.

Somehow I feel it's a driver fault. I suppose we'll wait and see if anyone else gets this.

Random thought: Is it the same if vertical sync is enabled / disabled?
Quote from DANIEL-CRO :I have encountered a graphics glitch on my computer.

Its not an issue for me as I'm not playing LFS.
https://www.youtube.com/watch?v=_-bTF3rIVQA&feature=youtu.be

It happens when I switch to full screen (SHIFT+F4) only. It starts like 5 seconds after that.
Sold my GPU, now on IGP.

That looks like a hardware/driver issue. I had similar happen alongside with a few other issues before I reformatted my pc a few weeks ago.

I don't know what causes it as I don't know how to recreate it, but deleting all traces of old gfx card drivers and reinstalling them may help.
Quote from DANIEL-CRO :I have encountered a graphics glitch on my computer.....

Try switching to other graphic card (Litteraly any will work) and see if the problem is still there.
sweet looks good from what i have read so I'm gonna test it out now.
I have problems in saving the changes made to the setups ever since I updated to 0.6T. The changes made are not shown when leaving the pits or checking the setup again despite showing "Saved setup" message. It is only affecting the setups I downloaded after the update. Old setups work fine, the changes made to them are saved.

I made fresh installs and on different partitions and the problem still persists. Also when I try to delete those setups, it shows "The setup could not be deleted".
Quote from redbot_ :"The setup could not be deleted".

I actually had the same problem tuesday - downloaded one setup from here,tried it,wasn't good for me,wanted to delete,had that message. Had to delete via file explorer. Thought there's some bug at my side,but now when someone else posts about it...
Are they set to be read only files for some reason?
I just checked and they are indeed set as read only files.

This only happens to the setups downloaded from online, and opened with lfs to automatically copy to setups folder. When I create new setup in-game, there is no problem.
To be more clear, for me the files that are getting from lfs.net is normal. It only becomes read-only when it is opened with LFS to be copied automatically to setup folder. If I copy the setup manually to the data/setups folder it stays as normal.
I can confirm that.
OK, I don't know why they are converted to read-only when they are copied from your download location into data\setup by LFS.

It's not something LFS is doing, at least not deliberately. I'm on Windows 7 and that doesn't happen on my computer.

LFS is using the CopyFile function.
https://docs.microsoft.com/en-us/windows/desktop/api/winbase/nf-winbase-copyfile

From the documentation:
File attributes for the existing file are copied to the new file. For example, if an existing file has the FILE_ATTRIBUTE_READONLY file attribute, a copy created through a call to CopyFile will also have the FILE_ATTRIBUTE_READONLY file attribute. For more information, see Retrieving and Changing File Attributes.


I don't see any reason why it would change the attributes. Uhmm
For the record I'm also on W7.
Just tried another option - downloaded the setup normally and stored on desktop - doubleclicked to store in setups folder as file associations do - no read only atribute. I wonder if it has to do something with browser - using Firefox.

Edit: Opera doesn't even offer option to open the file directly.
OK - I've reproduced that too. When selecting "Open with Live for Speed" in Firefox's download dialog it is copied with read only attributes.

I wonder why that is. I suppose that temporary copy held by Firefox is read-only for some reason.

EDIT: I think it can be fixed by writing my own version of CopyFile. It would read the file and save a fresh copy of it with default attributes, disregarding the source file attributes. Only trouble is I don't want to get back into test patches now so it could be a long wait.
Well,it's not a huge issue,so I think it's enough to be added to to-do list. But at least you found the problem!
I'm running Firefox also. I checked the temp file stored by Firefox and it's marked read only. So it seems to be a problem with Firefox itself.
In IE there doesn't seem to have a problem directly running setups with LFS.

@Scawen -Thanks for replying.

New Version 0.6T - More robust multiplayer system
(210 posts, started )
FGED GREDG RDFGDR GSFDG