The online racing simulator
I have to delete cfg.txt file before i run the sim
each time i try to upload the sim, i get black screen with the music and the mouse icon.
I solve this by deleting the cfg.txt file from the LFS folder.
I have 0.6G version.
I looked at difference of an old cfg.txt and a new cfg.txt and as its name implies this file is only basic game configurations... I'm baffled.

I just upgraded to teh .6G version as well and am having the same problem. Any suggestions? Aviad, have you asked for technical support? I am going to try that now.
I haven't received any proper answer, please share the answer.
I asked the developers. Hopefully they'll help out. If not, is there somewhere I can get an older S2 version? There are none in the downloads area.
#5 - troy
0.6G is using direct x 9 now, maybe you are running some custom dx8 injector dll's or something along the likes?
Thanks for your reply, Troy. I am running DirectX11
Quote from biggal76 :Thanks for your reply, Troy. I am running DirectX11

No, you are not. LFS uses DX9.
Try making a empty cfg.txt and make it read only. This could be a temporary solution.
You could try reinstalling DirectX 9 - can be found HERE

Do it even if you have later versions of DirectX.
Did you check the contents of the modified cfg.txt to see what's changed? Some settings related to graphics only take effect after you restart LFS. There is also "card_cfg.txt" file. Do you have to delete that one as well to get LFS to start properly again? Does its content change?

Another thing is that LFS relies on the latest revision of DirectX 9 which you might not have so reinstalling DX9 as Sinanju suggested is a good idea. What GPU do you have and how old are its drivers?
I tried reinstalling DX9. Didn't help. Also, MS claims that DX11 is backwards compatible anyway. Doesn't work closing it from a window either. Tech support claims that this is the 1st time they've heard of this issue had no other suggestions other than the ones you guys suggested. Making a blank read only cfg text file fixed the issue but I have to re-setup all my user and control settings every time I open the game. There has to be a simple solution. I have trouble believing that this isn't a more common issue than just me and Aviad. MadCatX, I've got an Intel Core I3 2120 chip. I forget if I upgraded the Graphics Card or not, but I believe I'm using the onboard graphics.
Hi, I'd be interested in what is causing this issue. If we can find out the problem, then maybe I can fix it in the test patch which is coming soon.

What we need to know is exactly which lines of cfg.txt are causing the problem.

As you are the only two people we have heard of with this problem, only you can find the answer.

You can do it any way you like but I would suggest:

1) Allow your cfg.txt to be written as usual.
2) Run LFS and exit. Now you have a cfg.txt that causes the problem.
3) Back up the cfg.txt file. We need to find the offending line.
4) Make a cfg.txt with the first half of the file removed. Run LFS.
5) Try again with the 2nd half removed. Run LFS.
6) Now you know if the problem is in the 1st or 2nd half of the file.
7) Now go down to quarters, then eighths, etc, until you find the line.

There must be a relevant line or lines in cfg.txt that cause the problem. It can't be the entire file. Please let me know when you have found the offending line.

Scawen, Thanks for the offer. I'll do that later today and get back to you. It's crazy that there are only 2 of us with this issue!
Yeah, maybe there will be a good reason for it. I don't really have a clue at the moment!

I do have a vague memory of something like this in the past but it seems like a very long time ago...
How about, disabling Full-scene Antialiasing in LFS graphic option,
or Antialiasing 0 in cfg.txt.

if you didn't have this problem in the past with the same machine, probably old LFS version had FSAA set to OFF by default (?).

in my situation (nVidia gpu), FSAA (LFS option) blocking some feature of d3d9 sweetFX,
so I had to turn it off, then using nVidia FXAA & AA (I don't see FSAA in nvidia option),

and about intel onboard graphic + FSAA, look here:
i5 graphics card anti-aliasing black screen
Third line down in cfg.txt is "Welcome G 0" and sometimes "Welcome G 1" When I remove this each time I start the game, it starts, but without having saved any settings from before.
Disabling Antiliasing fixed the problem! Thanks a bunch. Try it Aviad