The online racing simulator
LFS goes random to desktop screen twice
(11 posts, started )
#1 - rik97
LFS goes random to desktop screen twice
Hi all,

Since some time a same problem is coming up and I can't figure out why it happens and how to solve it. While I play LFS sometimes it returns random back to desktop homescreen. When it happens once, I know the second time will come a few seconds later. I don't push any button apart from my controlls to drive and gear up/down.

Does anyone has the same problem or have a solution for this? Because it's really frustratating, especially when it happens in events.


Kind Regards,
Rik97
i have heard about this issue before. hopefully someone got a solution for this. i had a simular problem some time ago,but it seems to have fixed itself now. im not sure but as said in server. i think this could be related to the virtual keyboard but i am far from sure about that.
Have had this problem in windows 8 and I solved it back then with reinstall windows. Never found out what caused the minimizing of lfs and problem was always random. Sometimes happend after an hour playing or somtimes after few min.
#4 - lucaf
I remember i had the same issue with my older pc. The problem was Windows had a problem or something which was causing this minimising... It was displaying for less than a second a small window saying lfs or explorer is not responding and there was a button saying "end task" or similar. No idea how i fixed it but i think it was reinstalling windows!
Which full screen method are you using?

These two work quite differently so it may be worth trying both:

- SHIFT+F10 : Full screen exclusive mode
- SHIFT+F11 : Borderless window mode

I think the second option is better these days.
I Always used the F10 mode. And have np since reinstall years ago also now on win 10.
i am using this mode : - SHIFT+F11 : Borderless window mode . 8.1 . but on my former computer i used - SHIFT+F10 : Full screen exclusive mode. i changed from vista to 8.1 and when installed LFS it auto set it to that i think.so i just kept it like that. i havent seen any problems regarding that.



however if i use ALT+TAB to go to desktop, it also does that. but if i use SHIFT+F4 it jumps to my second screen though i set LFS to single screen? that has me puzzled for some time.im only using LFS on one of them screens. if i use SHIFT+F4 again it jumps back to the first screen in full screen. the other screen goes into window mode.not sure if helpful related or not.

EDIT:
i am not using the windows or other options to move windows to another screen.the option is not even active on my system.

EDIT: also when i do screenshots it grabs the second screen in the capture aswell. which i find weird as said before ,as i set LFS to only single screen.but screenies capture the second screen aswell though its just black screen. im not sure why that is, so maybe "help" Smile (did i miss a setting somewhere ?)
Quote from Scawen :
- SHIFT+F10 : Full screen exclusive mode
- SHIFT+F11 : Borderless window mode

I think the second option is better these days.

The second results in slightly more input lag, the issue is caused by windows 10, I think specifically a feature called focus assist.
Quote from racerss :The second results in slightly more input lag, the issue is caused by windows 10, I think specifically a feature called focus assist.

I never encountered the problem in windows 10 Shrug
just hit me. did you click the NO to show in window mode when going to the multiplayer screen? theres a option there to not let lfs go into window mode while in serverlist. that one tricks me every patch. would be great if scawen could set it install NO as deafault. but its on yes as deafult.

LFS goes random to desktop screen twice
(11 posts, started )
FGED GREDG RDFGDR GSFDG