The online racing simulator
TEST PATCH 0.6E15 (now E19 - DirectX 9 + 3D / VR support)
(138 posts, closed, started )
I'm using Windows 8.1 Pro ( 64 Bits )

Works perfectly fine for me, as feedback.
Quote from Scawen :Hi paovi, thanks for the info. Please can we have more information? This will soon be the official version so we need to fix it.

1) At exactly which point does it crash? Do you see the race setup screen, and then it crashes when you press "go" or does it crash before that, when you are loading the track?

2) Can you provide information about the crash? Usually Windows gives you a dialog and you can click "more information" or something like that and it gives you information about the faulting module and the crash address or crash offset.

3) At the moment yours is the only known case of a crash. Are you using 32 or 64 bit Windows 8?

maybe his DX is not updated.
That is possible but E15 is supposed to detect that and give you a helpful message.

The message should be displayed if D3DX9_43.dll or D3DCompiler_43.dll are missing from your computer.

The files are missing if you have not visited this page to update your DX9.
http://www.microsoft.com/en-gb/download/details.aspx?id=35

A crash should never happen...
E16
New Test Patch : E16

The 3D support is now translatable - awaiting translations
Improved and optimised the Oculus Rift distortion function
Some other small performance optimisations in graphics code
FIX : Mouse drag movement in SHIFT+U mode in 3D modes

https://www.lfsforum.net/showthread.php?t=85807
There's a message saying "Render target texture X×Y", will it be removed in the official patch?

Also a text "Resolution XxY" doesn't seem to be in the translation file.
Fixed on the 6E16
Quote from Scawen :Hi paovi, thanks for the info. Please can we have more information? This will soon be the official version so we need to fix it.

1) At exactly which point does it crash? Do you see the race setup screen, and then it crashes when you press "go" or does it crash before that, when you are loading the track?

2) Can you provide information about the crash? Usually Windows gives you a dialog and you can click "more information" or something like that and it gives you information about the faulting module and the crash address or crash offset.

3) At the moment yours is the only known case of a crash. Are you using 32 or 64 bit Windows 8?

1) When I press Go

2) Can't even see that Dialog , when LFS Crash even when clicking on my mouse trying to open the Task Manager nothing happen so I have to close my computer from the Start Button

3) I use Windows 8.1 64 Bits

after trying the 6E16 Version , the crash problem Fixed
Quote from Flame CZE :There's a message saying "Render target texture X×Y", will it be removed in the official patch?

Yes, I think it should be removed.

Quote from paovi :after trying the 6E16 Version , the crash problem Fixed

Thanks, good to know it is fixed.
Quote from Scawen :Yes, I think it should be removed.

I noticed messages (in log) about adding controllers when you bring LFS to foreground (was minimized). Not sure if thats just debug?
Jun 07 11:39:07 Controller 1 (Controller 1) :
Jun 07 11:39:07 Added 8 axes
Jun 07 11:39:07 Controller 2 (Controller 2) :
Jun 07 11:39:07 Added 8 axes
Jun 07 11:39:07 Controller 3 (Controller 3) :
Jun 07 11:39:07 Added 4 axes

Scawen, are you going to update the docs/Commands.txt file to include the new commands? It would be good for the translators to be able to translate them before the official version is out.
redirecting CreateDevice
initialising shader environment
D3DXCreateEffectFromFile failed

Does it require a Oculus, or should it also work without?

If I start it, either as administrator or not, it flashes a blackwindow (LFS) for 1ms and then disapears, without crash message. Can't manage to start up LFS.
Issue solved. It seemed that I still had old ENBseries files in my LFS folder. And it crashed on that.

Now that I've removed them all, somehow it starts up including ENBseries, and automaticly makes the enbseries.ini file, which I don't want, since I didn't use to have it enabled.

Anyways, works now.
Probably need to remove ENBSeries' d3d9.dll. This wouldn't've worked with pre-DX9 LFS without the d3d8 wrapper.
Could it be possible 0.6E16 (or DirectX 9, I have yet to test older patches) introduced this rather futile anomaly related to the autocross measuring tool? The measuring tool looks fine with 0.6E.
Attached images
lfs_00000006.jpg
lfs_00000008.jpg
I've been lazy and haven't updated to last test patch,I have E15 and it already has this colorful measuring tool.
Remarks:
a) OOO, that's really pretty - don't fix it
b) Whoa, a measuring tool?? Cool! But it isn't listed in the "keys" list - is that deliberate or a bug? (Google helped me to find that "d" is listed in the wiki manual as the key for the measuring tool...)
c) what's that little window with "x400 x1 ... Width: 44 ..." etc in it? I don't get that when I hit "d"
d) are there any other keys that work in edit mode that aren't listed when you hit the "keys" button?
That's his own insim - Clavico. Might be newer version then the one you can find in unofficial addons section.
Aha, cool, thx.
Quote from sicotange :Could it be possible 0.6E16 (or DirectX 9, I have yet to test older patches) introduced this rather futile anomaly related to the autocross measuring tool? The measuring tool looks fine with 0.6E.

Quote from Eclipsed :I've been lazy and haven't updated to last test patch,I have E15 and it already has this colorful measuring tool.

Yes, I changed it at some point during this round of test patches. It was sharing the car frame drawing system (the slightly dodgy system as seen on the MRT5 and also used for moving suspension parts).

For some reason it wasn't convenient to use that system any more. I think it was something to do with supporting the 3D system. Can't remember...

Anyway it now has its own cylinder drawing function and I thought these sticks shouldn't really look like real objects and these colours seemed to make them really stand out. They are a bit odd and if anyone has a better idea they can be changed. I went with green and red for the start and end because it makes sense and I allowed the grading to yellow so they stick out and can be seen from far away.

Quote from Neilser :Remarks:
a) OOO, that's really pretty - don't fix it
b) Whoa, a measuring tool?? Cool! But it isn't listed in the "keys" list - is that deliberate or a bug? (Google helped me to find that "d" is listed in the wiki manual as the key for the measuring tool...)
c) what's that little window with "x400 x1 ... Width: 44 ..." etc in it? I don't get that when I hit "d"
d) are there any other keys that work in edit mode that aren't listed when you hit the "keys" button?

Well I have heard that "real men don't read the instructions" but rules are meant to be broken (specially stupid macho rules) so...

I'd suggest you read the instructions! They are found in docs\Autocross.txt
Quote from Scawen :
Well I have heard that "real men don't read the instructions" but rules are meant to be broken (specially stupid macho rules) so...

I'd suggest you read the instructions! They are found in docs\Autocross.txt

I think it would be convenient to add one more button to the list of keys saying "D - distance measurement" or something similar, because that's what the list is there for, isn't it?
Quote from Scawen :Well I have heard that "real men don't read the instructions"

The instructions meant for the weak
It is a pity that you are 3 people from the development team. These test patches slowed due to bad feedback because not everyone has oculus rift...
You guys planing to go for DX11?
-
(dawesdust_12) DELETED by Scawen : spam
Quote from [Audi TT] :These test patches slowed due to bad feedback because not everyone has oculus rift...

I think Scawen is waiting for his DK2 to finish this patch properly and in the meantime he is working on something else. It's amazing that he came this far without a DevKit. It must be hard to work on something that you can't even test by yourself and see if the end result is any good. Yet, I've read some comments of people saying that LFS was one of best experiences they had so far with the Rift. So yeah, well done Scawen.

Can't wait to play LFS with CV1 when they finally release it.

Quote from TrIpLe M :You guys planing to go for DX11?

Give a one reason why would they do something so pointless.
Quote from TrIpLe M :You guys planing to go for DX11?

DX11 doesn't have much to propose for Scawen, so it is far in future (not saying that dx11 will not be supported by Windows XP).
-
(malcomax) DELETED by Scawen : spam
Quote from TrIpLe M :You guys planing to go for DX11?

No, DX9 is a much better choice so LFS can still run on XP and Wine.
If we moved to DX11, LFS would be restricted only to the most recent versions of Windows.
And there would be no advantage at all, because DX9 can do all and much more than we need.

There is a long discussion on that subject that here:
https://www.lfsforum.net/showthread.php?t=84730
Quote from Scawen :...these colours seemed to make them really stand out. They are a bit odd and if anyone has a better idea they can be changed. I went with green and red for the start and end because it makes sense and I allowed the grading to yellow so they stick out and can be seen from far away.

Yup, they stand out nicely It actually crossed my mind briefly to wonder if the new colours were deliberate. (I dismissed that crazy idea about a second later though :P)
And omg, who could possibly vote to change them?
Quote from Scawen :
I'd suggest you read the instructions! They are found in docs\Autocross.txt

Darn yes, I keep forgetting that file exists, ta. (Having said that, one line early in autocross.txt says "All the editor keys are listed on that screen." )
This thread is closed

TEST PATCH 0.6E15 (now E19 - DirectX 9 + 3D / VR support)
(138 posts, closed, started )
FGED GREDG RDFGDR GSFDG