The online racing simulator
LFS Remote
(40 posts, started )
#1 - Defi
LFS Remote

Remote over Windows goes correctly.

Remote over give a insim_error 2048 (I dont get a Serverlist) (since, 2 days..)
It seems there is a problem with newest Adobe Flash Player version 9,0,115,0. Don't upgrade your player

In FF, error message is "InSim Relay connection failed : Error #2048"

In standalone player:
IO Error : Error #2031
Reconnection attempt #1
IO Error : Error #2031
go try to download the windows version , and see or you still have problems...



Quote from hotmail :go try to download the windows version , and see or you still have problems...

standalone player = windows version
Don't use just "" use the entire "". For some reason without the www., there's relay errors, but the instant you change the URL, it works.
#7 - SamH
Quote from dawesdust_12 :Don't use just "" use the entire "". For some reason without the www., there's relay errors, but the instant you change the URL, it works.

That's a native Flash security feature I believe. It may be possible to capture the error and correct for it in ActionScript, I can't remember. Definitely can be done in the PHP wrapper though.
well for me it isnt working with www. or without , i just get error #2024

when i donwload the remote its working fine , so i dont know the problem, it maybe have something to do with the new software or system on lfs world.

i hope we maybe can safe this problem.


Reint Jan
Yea, more people have that problem, including me. It's working fine when I try the downloaded version...
Assuming you are running Windows XP, try to delete the Flash cache from \Documents and settings\<your user name here>\Application Data\Macromedia\Flash Player

It might help
could the people with that error #2024 problem make a screenshot of when the error is displayed?
What the flash documentation states as the cause for a #2024 error isn't possible for as far as I can see, so i'm curious when it happens and where you see the error (in the top-left messages log or in a popup or maybe somewhere else)
Vic, I seem to only get errors on my laptop in very small cases. It doesn't happen if I use my iMac as a router and connect through that (rather than properly to my router), and the doesn't do it but site does (Just threw me a 2048 this time.)

#13 - need
Here's a picture.
I get it after the initial picture goes away, and before the host list comes up on the screen.

Seems to have started since the new version of the flash player came out, was working ok before that. The stand alone remote still works ok though.
Attached images
need - as a matter of fact, that's what does pop into my mind as triggering it. I only started getting that error after Safari (in OSX) decided that I didn't have flash installed, so I installed it again. Especially because in Windows where I'm using an older version, it works...

Velly Tricky...
Yea, could be the new version of flash player. I downloaded it a few days ago and then LFS remote didn't work anymore.

btw, I have the same error as need above^^ (using FF)
yep.. after updating Flash, it wont work anymore.. same error here..
hm ok, guess I'll have to check out that new player soon.
Flash's security model has changed recently.

For the interested ones : You cannot supply policy files via the webserver anymore _to create a Socket_. You need to run a special policy server on port 843 (so you have to be root!) that serves them. I've made this server now, but need to test it a bit more and make it fork as non root etc. But just so you know, the solution is underway.

Quote :A SWF file may no longer make a socket connection to its own domain without a socket policy file. Prior to version 9,0,115,0, a SWF file was permitted to make socket connections to ports 1024 or greater in its own domain without a policy file.

Quote :HTTP policy files may no longer be used to authorize socket connections. Prior to version 9,0,115,0, an HTTP policy file, served from the master location of /crossdomain.xml on port 80, could be used to authorize a socket connection to any port 1024 or greater on the same host.

Quote :Flash Player 9,0,115,0 introduces a concept of socket master policy files, which are served from the fixed TCP port number 843.

Quote :Socket policy files may be obtained from the same port as a main connection (the socket connection being made by ActionScript, which is authorized by a socket policy file), or from a different port, separate from the main connection. If you opt to serve a socket policy file from the same port as a main connection, the server listening on that port must understand socket policy file requests (which are indicated by a transmission of from Flash Player), and must respond differently for policy file requests and main connection requests.

#19 - SamH
What a nuisance!

I guess the Flash format must still be considered an emerging technology. Ya gotta roll with the punches
ok, policy server running - you can use the remote with the latest flash player again. If you still get the message, make sure you do a ctrl-f5 to re-load the remote (otherwise caching may happen)
nice work.. I can see Remote again!
#22 - need
Great, working again here
Would it be possible to add a column showing the number of pit-stops the racers have done so far during the race? (0,1,... etc)?
Im still getting this error:

nSim Relay connection failed : [SecurityErrorEvent type="securityError" bubbles=false cancelable=false eventPhase=2 text="Error #2048"] - Error #2048

I get that too, unless I use the

LFS Remote
(40 posts, started )