The online racing simulator
Exclusive full screen mode on Windows 10
(6 posts, started )
Exclusive full screen mode on Windows 10
Hello,
I noticed that LFS does not seem to enter the exclusive full screen mode (Shift+F10) correctly anymore.

A bit of backstory: Whenever I play (any game), I tend to play in full screen mode, because I notice the micro-lags (or jittering) any windowed mode causes (due to triple buffering, I believe).

I can't remember having any problems before, but LFS is jittery for me, even in full screen mode. All in all it feels more like borderless window, because if I, for example, change system volume via keyboard, the volume bar from windows is drawn over LFS - which just shouldn't happen, since I'm supposed to be in fullscreen exclusive.

Sadly these micro-jitters really bug me and I can't drive a clean lap with them.
My system should be more than capable at running synced 60FPS. It shouldn't be a performance issue. GPU and screen drivers are up to date.

I attached two screenshots. You can view my settings there.
Please notice the overlaid volume bar in the top left and the unevenness in the graph that shows the GPU timings.

Any help would be greatly appreciated.


Additional Data:
- LFS version is 0.6U
- GPU is an Nvidia 560ti
Attached images
Screenshot (23).png
Screenshot (19).png
Did u ever try not to sync?
Thanks for your reply. I tried every possible combination.
Exclusive full screen is, as far as my knowledge goes, by definition the most jitter-free mode.
I am used to playing any game in this mode, synced to 60FPS. While you can argue about input lag and so on, the thing that matters for me is frame consistency - which is crucial for racing.

The problem I am facing is, that LFS "ecxlusive full screen" doesn't seem that exclusive after all (on Windows 10).

You can try it yourself: Go into free camera mode (shift + u), move the camera up a bit and let it face straight down. Now move it with the arrow keys. Butter smooth or jittery?
Vsync ON 50Hz at 50FPS or 100Hz at 100FPS = smoothest possible experience.

So try with 50Hz with vsync on and enjoy! Omg omg omg

It has nothing to do with exclusive full screen mode.
Maybe also try playing with mip bias.
** Best answer **
Quote from Evolution_R : So try with 50Hz with vsync on and enjoy! Omg omg omg

It has nothing to do with exclusive full screen mode.

It seems that you are right, I tried it and the jitter is gone. I am very glad that my monitor natively supports the 50Hz refresh rate. At the same time it is a bit sad to see that the graphics are bound to the physics step that closely. I am also wondering as to why this issue isn't more commonly known, on the other hand I have many friends who just aren't bothered by unsmoothness or screen tearing.

Thanks for the fast replies, I am still a bit unsure about the system volume bar being drawn over a "fullscreen exclusive" LFS though. That's not, what full screen exclusive is meant to be - and opens up a wide range of issues that can be had in the future.

-> While writing this reply I found the solution: It's some stupid optimization Windows 10 does (I run on 1803): It automatically applies so-called "full screen optimizations" to any app, which is supposed to reduce Alt-Tab times and the likes. But that's also the reason, why the full screen mode was not really "exclusive".
(Temporary) Solution: Right-Click LFS.exe, go to Properties->Compatibility and tick "disable fullscreen optimizations" [Source: https://mspoweruser.com/tip-fu ... e-performance-windows-10/]

The only question I ask myself, why, just why do they always have to add new stuff and enable it by default...
Again thanks for your help Smile

Exclusive full screen mode on Windows 10
(6 posts, started )
FGED GREDG RDFGDR GSFDG