The online racing simulator
dedicated host not on master server.
(21 posts, started )
dedicated host not on master server.
i am running a dedicated server and it shows as status online, but it is not showing up on the master server list.
i can connect to it from my local LAN, but not across the internet.

any idea's??
Post your setup file with the password(s) blanked out
You won't see a server running on your computer.

You must join it using 127.0.0.1 IP. If you try to join other way you'll get an error.
#4 - zazzn
I'm having the same problem some help?

I am able to connect locally, and i'm also able to telnet to port 63392 from a separate cell hotspot on my laptop meaning I can reach the dynamic IP of zazzn.dlinkddns.com on that port and i see the LFS connection in the dedicated server yet i'm not listed on the master server list.

// Example host configuration file
// How to use: LFS /cfg=setup.cfg
// Lines starting with // are ignored

// host name
/host= Americas LFS Racers

// optional: password
//pass=password

// optional: admin password
/admin=*****

// optional: InSim port
insim=29999

// optional: local specified ip address
/ip=192.168.1.6

// a high number below 65536
/port=63392

// demo/s1/s2/s3
/mode=s2

// no/yes/hidden
/usemaster=yes

// BL1/BL1R/BL2, SO1/SO1R/SO2, etc
/track=BL1

// optional: weather
/weather=1

// cars allowed - see README.txt
/cars=ALL

// max guests that can join host
/maxguests=42

// slots reserved for admins (0 to 8)
/adminslots=2

// max cars in a race
/carsmax=40

// max cars (real+ai) per guest pc
/carsguest=1

// smoothness (3-6) number of car updates per second
/pps=4

// qualifying minutes, 0 for no qualifying
/qual=10

// number of laps, 0 for practice
/laps=3

// if laps not specified: hours
/hours=4

// 0=no/1=low/2=high
/wind=1

// no/yes: can guests vote to kick or ban
/vote=yes

// no/yes: can guests select track
/select=yes

// no/kick/ban/spec: wrong way drivers
/autokick=spec

// no restart within X seconds of race start
/rstmin=10

// no restart within X seconds of race finish
/rstend=10

// no/yes: allow join during race
/midrace=yes

// no/yes: pit stop required
/mustpit=no

// no/yes: allow car reset
/canreset=no

// no/yes: force cockpit view
/fcv=no

// no/yes: allow wrong way driving
/cruise=no

// fixed/finish/reverse/random: race start order
/start=finish

// optional: use the specified player name
/player=host

// optional: welcome message up to 200 chars
/welcome=welcome.txt

// optional: text file listing allowed tracks
//tracks=tracks.txt

// optional: message log file
/log=deb.log

// MPR autosave (0=off / 1=manual / 2=auto)
/autosave=2

// MPR folder
/mprdir=mpr

// LYT folder
/lytdir=layout
..
#6 - Racon
Are you using a router? Is your port forwarding set up correctly? Last time I had this problem I'd changed my computer's local IP and forgotten to change router setting
#7 - zazzn
Hi All,

Thanks for the updates, changed the spaces out (tried that before), fixed insim. I am using a router, but the router is configured properly and the server is on a static IP.

I have port forwarding on the LFS port and I also have the firewall open.

Again I can connect remotely if I use the external address from my ISP via Telnet so I know I can get to my server. It's just not listing.
#8 - zazzn
Can someone else try to connect it's running on zazzn.dlinkddns.com

This is what is in my Deb log

Jun 11 09:08:52 LFS DEDICATED HOST : 0.6P
Jun 11 09:08:52 load font
Jun 11 09:08:52 initialisations
Jun 11 09:08:52 tables
Jun 11 09:08:52 load objects
Jun 11 09:08:52 start intro
Jun 11 09:08:52 Blackwood
Jun 11 09:08:52 end of initialisation
Jun 11 09:08:53 Track loaded (BL1)
Jun 11 09:08:54 Handicaps :


BTW Cargame, I'm trying to replicate a server like you have, which was originally IHR, but back in north america so the pings are acceptable. It's so Sad that LFS has such a small community and really no presence in the USA. I wish we would add this to steam and make a big sale or something to bring a rush of new players.
#9 - zazzn
Anyone at all?
Just tried and got "connect timed out"
Did you remove that space in front servername?

Otherwise i can only think off firewall
..
hmmm I don't like steam software Smile
..
So strange.

Ok so I made my server the DMZ, disabled the firewall on the machine and tested it works (from cell hotspot)
I now connected again with he windows firewall on with the rules in place and it works...

So what other ports do I need to forward? I have only 63392 being forwarded to my internal server both udp and tcp, but that doesn't seem like it's enough to be listed on the master server list to be found.
"Could not open connection to the host, on prt 63392: Connect failed" Frown
..
So strange... Shitty Asus router.. I make no changes to rules, but put the machine on the DMZ, then disable the DMZ and now the rules are taking effect and the server is showing up.

Thanks for the help.
Quote from zazzn :Shitty Asus router..

Their motherboards are not much better, in my experience :/
..
I got it working eventually, i can't remember what it was.

dedicated host not on master server.
(21 posts, started )
FGED GREDG RDFGDR GSFDG