The online racing simulator
Graphics issue with .6K - my first issue with LFS since it came out.
(14 posts, started )
Graphics issue with .6K - my first issue with LFS since it came out.
Because of the new version, I just recently did a fresh install of Win 7, and LFS on a new VMware virtual machine. This has worked just fine in the past, but not with .6K....

These unwanted colors change with the virtual sun light, so it is related to the new reflections.

The Virtual Machine has 8GB ram, and 2GB video allocated to it.
The server has enough to run more than 12 of these Virtual Machines at the same time.

The Graphics Card does not really matter, because... Virtual Machine, but it is a FirePro W9100, with 16GB of ram.

I am trying to get graphics passthrough to work with it... which might help.

Would upgrading from "VMware WorkStation 12 Player" to Pro solves this?
Attached images
lfs_00000001.jpg
lfs_00000002.jpg
lfs_00000003.jpg
lfs_00000004.jpg
lfs_00000005.jpg
lfs_00000006.jpg
lfs_00000007.jpg
Quote :Changes from 0.6J to 0.6K :

Graphics :

New reflections system and shaders for cars and buildings
Nearby objects are visible in new dynamic reflections on cars
Option to set number of dynamic reflections in main view and mirror
Misc option to enable a programmable post-processing shader

I suspect your issue is related to these changes.
Your rig might be on LSD.
#5 - nacim
Disable realtime reflections and post-processing, the virtual machine must create some graphical glitches.
And by the way, LFS now allow input when window is not active and borderless window, you could load multiple instances of LFS and use wheels for each without having to use a virtual machine. Wink
That is one reason I am reinstalling, just did this one VM as a comparison, I had all my VMS removed recently to start over.

In the past I had multiple instances open on one machine, but there were many issues doing it that way.
The game runs fine in multi windows, better even... however, there is no way to allocate head phones or speakers to each window... so either everyone hears ALL the sounds from every screen, or just one person hears theirs.

So for me to be able to do it this way, I would need to be able to allocate a specific sound source to each window.


I have also already tried to set 0 reflections, and turn off the calculations... no change.
#8 - Bean0
Quote from SimulatorRental.com :The game runs fine in multi windows, better even... however, there is no way to allocate head phones or speakers to each window... so either everyone hears ALL the sounds from every screen, or just one person hears theirs.

So for me to be able to do it this way, I would need to be able to allocate a specific sound source to each window.


I have also already tried to set 0 reflections, and turn off the calculations... no change.

I've never used it before, but could Virtual Audio Cable do that ?
Apparently it is much simpler, but repetitive. I just have to change the default sound device, before starting each LFS instance. Smile It works...

So I guess I am glad I did not just go and buy a copy of VMware Smile Not going to be needing it.
..
Well I though the sound was sorted out, and I swear I had it sending two games to two different out puts, but now when I change the default sound source, it also changes all of the games of LFS running, to the same source............

I guess I Need Output selection in LFS...



And still no clue with the original graphics issue...
In that case they're using PCI passthrough, so each VM itself is controlling its own video hardware, so VMWare's support for 3D acceleration is irrelevant.

Graphics issue with .6K - my first issue with LFS since it came out.
(14 posts, started )
FGED GREDG RDFGDR GSFDG