The online racing simulator
Problem with Cars
(14 posts, started )
Problem with Cars
Im getting an erro on Insim...

Im editing one, that is LsGO insim, and when someone do !buy XFG , xrt wont go blue in cars show...

Can anyone help me please ? It would be good, thank you

i Tried a lot of things, but it doesn't worked..
Hello,

You're lucky i've made the thing you want one day when i was coding. ( For the LsGO Insim )

Quote : #region ' InSim GUI '
if (C.HideGUIorNOT == 0) // Switched On GUI
{
string TempCars = "^7UF1 ^7XFG ^7XRG ^7LX4 ^7LX6 ^7FXO ^7RB4 ^7XRT ^7RAC ^7FZ5 ^7UFR ^7XFR ^7FXR ^7XRR
Here you have.
^7FZR ^7MRT ^7FBM";
if (C.Cars.Contains("UF1"))
{
TempCars = TempCars.Replace("^7UF1", "^3UF1");
}
if (C.Cars.Contains("XFG"))
{
TempCars = TempCars.Replace("^7XFG", "^3XFG");
}
if (C.Cars.Contains("XRG"))

Enjoy it !

Regards

Note: Cars will change to Yellow when buy them , put ^6 in stead of ^3 for change them to blue.

Not working idk why
Bump, please can anyone help me ? Its easy....
#5 - PoVo
Another person has already posted the solution for the problem.

If you're asking for help, put in some effort into fixing your own problem. Also post the bit of code where you think the problem is caused.

I doubt many people would be bothered to download a copy of an insim application and read the source code to find the problem just because you said "X isn't working in Y application".
my problem is in CAR REPLACE povo....


I do !buy XRG and it dont change the color
Impresora , i did gave you the solution

Quote :#region ' InSim GUI '
if (C.HideGUIorNOT == 0) // Switched On GUI
{
string TempCars = "^7UF1 ^7XFG ^7XRG ^7LX4 ^7LX6 ^7FXO ^7RB4 ^7XRT ^7RAC ^7FZ5 ^7UFR ^7XFR ^7FXR ^7XRR
Here you have.
^7FZR ^7MRT ^7FBM";
if (C.Cars.Contains("UF1"))
{
TempCars = TempCars.Replace("^7UF1", "^3UF1");
}
if (C.Cars.Contains("XFG"))
{
TempCars = TempCars.Replace("^7XFG", "^3XFG");
}
if (C.Cars.Contains("XRG"))

Viewing that code , you need to know what you need to set into the "buy command , for set it working.

Find it yourself
Ohhhhhh !!!! Thank you ! I will try to find, now can you help me with help that is COUTING like, im not driving and it is COUTING DOWN ?

See:

#region ' Check Health per Kilometer '
if (C.HealthDist > 2000)
{
C.Health -= 1;


}


/*if (C.DistanceSincePit >= 2000)
{
C.Health += 1;
}*/

Bump
#10 - PoVo
#region ' Check Health per Kilometer '
if (C.HealthDist > 2000)
{
C.Health -= 1;
C.HealthDist -= 2000;
}

It doesnt count idk why :s
Where need to put this code:
#region ' InSim GUI '
if (C.HideGUIorNOT == 0) // Switched On GUI
{
string TempCars = "^7UF1 ^7XFG ^7XRG ^7LX4 ^7LX6 ^7FXO ^7RB4 ^7XRT ^7RAC ^7FZ5 ^7UFR ^7XFR ^7FXR ^7XRR ^7FZR ^7MRT ^7FBM";

if (C.Cars.Contains("UF1"))
{
TempCars = TempCars.Replace("^7UF1", "^3UF1");
}
if (C.Cars.Contains("XFG"))
{
TempCars = TempCars.Replace("^7XFG", "^3XFG");
}
if (C.Cars.Contains("XRG")) ;
}
else
{
InSim.Send_MTC_MessageToConnection("^1»^7 Invalid command. See ^2!help^7 for a command list", MSO.UCID, 0);
{
No thanks!

Problem with Cars
(14 posts, started )