The online racing simulator
Prism & php 5.4.0
There are a few things to keep in mind if your planning on running PRISM with PHP 5.4.0, you can find where the list of incompatible changes they have made from 5.3.x to 5.4.x. But there are also some new features that should be keep in mind as things that might not be supported by all platforms as right now PRISM only requires 5.3.0 and above. There are currently no plans to require a change to 5.4.0, however should you have custom plugins that you alone are going to use, it is safe to use these new features. I also have not tired to run PRISM with 5.4.0 yet, but I don't see anything that would be a show stopper.

I do think that the web server built into 5.4.0 is pretty cool, so I'll for sure take a look at that.

PHP 5.4.0 Traits

This is why I would LOVE to make PHP 5.4.0 a requirement for the next versions of PRISM. This would make my modules work together so much better. Currently, the Plugins module is a bastard child of many different classes that it extends from. With this, we can just have a clean defined class, and it can use the traits of the timer and button traits without having to worry about having to extend those classes into it.

Ok, after just trying PRISM with 5.4.0, we do have some issues, but they are pretty small. We get an E_STRICT warning with trying to call a Interactive::Query method in a static context, as of 5.4.0 that's a no no, we'll have to fix that. That's the only thing I've seen so far, but I'm still going through the setup from scratch, so we'll see.
I've wanted to do a rewrite of PRISMs core for a while now, and this have given me a pretty good reason to do that. The 0.4.3 release will fix some bugs that happen with PHP 5.4.0 that don't happen otherwise, but will works with PHP 5.3.x. This may end up being the last release the supports PHP 5.3.x before we move on to PRISM 0.5.x that will only support PHP 5.4.0 and greater. If you have any questions, comments or concerns, please do voice them now. I would love to hear what the community thinks.
No.. Just continue... If you want to move on with PHP6 its fine by me too.. I just compile a separate package if needed. No problem.
I say just go ahead and go on with PHP 5.4
Quote from :No.. Just continue... If you want to move on with PHP6 its fine by me too.. I just compile a separate package if needed. No problem.

PHP 5.4.0 is a pretty massive upgrade that will make some thing in PRISM much easier, such as the use of the web interface, that can be pretty much completely taken out and replaced with a native alternative that is much more in line with what other PHP programmers handle on the front end of the web sites every day. Vic did a great job, but it's very confusing to people who are no as adept to PHP as some of the devs are.

Quote from T3charmy :I say just go ahead and go on with PHP 5.4

That would result in some huge changes to the code base, and the interfaces that you're all given. The trait support would be front and center in the modules, and you'll fell that right away with the plugin class, should use decide to use it. But it also allows for the different paradigms to work as one with the plugins, even all in one if someone so desired. Would you still want to do it, knowing that it would be incompatible with anything you might of already programmed?
It's better to do it now instead of when even more gets programmed and its starting to get even more complicated to fix all incompatibilities.

In my opinion.
That's what I'm thinking. PHP 6 pretty much became PHP 5.4, as PHP 6 was all but abandoned in name, mainly due to it's requirement of UTF-16 being used everywhere. So short term we do get some of the cool things that where meant to be in PHP 6, but we just get them in PHP 5.4 instead. This works out quite well for us I think!

Did I mention that the <?= syntax is always available? Regardless of the short tag setting? I like that!
I also agree to the fact better now then when there is a bunch of plugins being made and have to be converted at a later date... Would be much more of a pain in the neck then...

Edit: ahh I see this: Online at: PRISM 0.5.0 on PHP 5.4.0 Nice !
Right now, PRISM 0.4.3 it compatible with both PHP 5.3.x and 5.4.x, simultaneously. The next update to PRISM, 0.5.0 will require everyone to PHP 5.4.x. There is a pretty substantial advantages to running even 0.4.3 with PHP 5.4.x over PHP 5.3.x right now as it offers a 20% memory reduction, and speed increase. I will continue to support PRISM 0.4.x and release a couple of releases to ensure that they are no major bugs in it, but you can consider it to be deprecated around the time 0.5.0 is released.