The online racing simulator
LFS lapper Drift Point system Error
(17 posts, started )
LFS lapper Drift Point system Error
hey guys ive got lfs lapper working as a drift point system on my server, but for some reason i keeps getting an error in the corner chat saying (id main_ongooddrift notfound) the drift points are working fine, but it dose not show the amouth of points the drifter has drifted to after they have done a lap?

Thanks In advance.
Search for this "id main_ongooddrift" in your Lapper script. I think it tries to display a text which should be in the translation section but isn't there at all or the id is spelled wrong at some point.
Quote from Yisc[NL] :Search for this "id main_ongooddrift" in your Lapper script. I think it tries to display a text which should be in the translation section but isn't there at all or the id is spelled wrong at some point.

Yeah ive found it but nothing seems to be spelt wrong? apart from the # is missing from the start.
It's a bug that's been around for a little while.

Look in the driftmeter.lpr file (in the /includes directory) for

main_ongooddrift

and change it to

driftmeter_ongooddrift
i had same problem. its cause u drift more then 3k in one single drift change it to 10 and u wont see it no more u'll find that in your lpr file where angel speed is. hope this helps
Thanks guys. is there also a way to turn auto spec off? the Idle car detection thing? thanks agen
Quote from LFSMasterMan :Thanks guys. is there also a way to turn auto spec off? the Idle car detection thing? thanks agen

If you mean the #Options for idle player on track#, then with the line that starts
$OnIdleTimeout1
put a # (hash mark) in front so it now reads
#$OnIdleTimeout1

Hash mark at beginning of line tells lapper to ignore everything on line afterwards (bit like a / to show comments line used in other types of coding).
Quote from sinanju :If you mean the #Options for idle player on track#, then with the line that starts
$OnIdleTimeout1
put a # (hash mark) in front so it now reads
#$OnIdleTimeout1

Hash mark at beginning of line tells lapper to ignore everything on line afterwards (bit like a / to show comments line used in other types of coding).

Sorry to ask agen but where would i find that setting ? turning that setting of wont mess with the lapper would it? and oh how do i turn of the swear and car reset warnings?
Quote from LFSMasterMan :Sorry to ask agen but where would i find that setting ? turning that setting of wont mess with the lapper would it? and oh how do i turn of the swear and car reset warnings?

Edit! ive done all that myself now all i need now is to turn of the swear warnings lol
Quote from LFSMasterMan :Edit! ive done all that myself now all i need now is to turn of the swear warnings lol

just delete the swear words they should havethere own seperate txt file... btw bud how did u fix the headers in !drf im gettin id main nick not found. i cant seem to find it the lpr file or the top gui file
Quote from LFSMasterMan :Edit! ive done all that myself now all i need now is to turn of the swear warnings lol

Look in your /default directory for the LFSLapper.lpr file, then search for #Swearword filter#

Put a # symbol in front of the line that starts
$SwearWordsMax

or delete whole swearword section.
Quote from 240sxdaniel89 :just delete the swear words they should havethere own seperate txt file... btw bud how did u fix the headers in !drf im gettin id main nick not found. i cant seem to find it the lpr file or the top gui file

You may have a corrupted LFSLapper.lpr file.

Check at the end of the LANG "EN" section (just before you get to the LANG "FR" section), and there's a number of lines that start built_ under BUILT COMMANDS.

Make sure you have a built_nick = "NickName"; in amongst the rest.
Quote from sinanju :Look in your /default directory for the LFSLapper.lpr file, then search for #Swearword filter#

Put a # symbol in front of the line that starts
$SwearWordsMax

or delete whole swearword section.

Thanks a lot man, everything is working fine now
Sorry to bunk this tread back up, but is there a way to turn car reset penalty off? its starting to get very annoying. thanks guys!
Look in the LFSLapper.lpr file for "car reset".
Quote from sinanju :Look in the LFSLapper.lpr file for "car reset".

yeah i have.. and its off?
Remove that whole section to make sure.

LFS lapper Drift Point system Error
(17 posts, started )
FGED GREDG RDFGDR GSFDG