The online racing simulator
v0.7D and Oculus v42 (Quest 2)
(5 posts, started , go to first unread)
v0.7D and Oculus v42 (Quest 2)
Hello,

I've started building a new sim rig with VR as the main use. I've downloaded LFS 0.7D, but I'm having an issue getting LFS to work inside my headset. I've searched, but doesn't appear anyone has had my exact issue.

Steps:
  1. I connect my headset via the link cable
  2. From the headset in link mode, I select desktop to view my computers desktop
  3. I start LFS from the headset (in window mode)
  4. I go to Options > View > Select 3D
  5. I leave display type to "VR headset", VR system to "Oculus Rift", Monitor View to "single"
When I click "OK" my headset just shows a little window that says "Loading..." forever. On my computer screen I see an error on LFS that says "Cannot create swap textures"

Anyone else familiar with this error?

P.S. OS is Windows 11 fully updated
Update on this. I found log files that are pointing me towards some potential issues. I'll report back my findings shortly while I troubleshoot. Hopefully this will be able to help others that come across similar issues.
** Best answer **
SOLVED!

For those that comes across similar issues... Inside the LFS install directory (C:\LFS for me), you'll find a riftvr log file. This log will have the latest logs from your game session.

In my case I noticed and "ERROR -3009 Graphics adapters do not match between client and service. required: c85e (NVIDIA GeForce RTX 2070 with Max-Q Design)...

This tells me that the game is utilizing the integrated graphics (at least in windowed mode).

My FIX:
  1. Open NVIDIA Control Panel
  2. Click "Manage 3d Settings" on the left pane
  3. Click the "Program Settings" tab in the main window
  4. Select "Live for Speed (lfs.exe) from the #1 option drop down (browse to the exe if it's not in your list)
  5. In section 2, your setting is likely the default "global setting" which uses the integrated graphics. Swap this to high performance and apply.
  6. Restart the game and now try swapping view to 3D
#4 - Pasci
Thanks for sharing

BTW: You can check the current used GPU also in LFS under Options > Graphics > Adapter
Quote from Pasci :Thanks for sharing

BTW: You can check the current used GPU also in LFS under Options > Graphics > Adapter

Thank you. Not sure how I missed that... would have saved myself some time.

v0.7D and Oculus v42 (Quest 2)
(5 posts, started )
FGED GREDG RDFGDR GSFDG