The online racing simulator
Skipping frames
1
(26 posts, started )
Skipping frames
Hey, I'm having a bit of a problem with LFS. The game seems incredibly choppy and laggy even though the frames per second displayed in the game are at a steady 100 or 200 or whatever.

I'm on a laptop that's definitely good enough to run LFS. I've already tried disabling VSync in game, running the game with the actual graphics card and not the integrated one, upping computer performance to high, making the game high priority for the CPU etc...

Anyone got any other ideas?
Quote from ABCode :I'm on a laptop that's definitely good enough to run LFS.

Which is.. And what OS (version).

Essential information is missing.
Dell XPS15 with GTX 960M GPU, Windows 10
Okay.. And can you download Nvidia Inspector and CPU-Z .. Play a replay on LFS and do like I do in this screenshot?

As you can see my GPU does NOT run full speed, it's throttled down. 405 Mhz instead of 666 Mhz, also the memory is on 800 Mhz instead of 1800 Mhz. And this, most of the time is the problem nowadays with LFS. You can set GPU on full power in Nvidia control panel but with the risk of getting more noise due to cooling.

This is P5 state by the way, but it has happened to me that it even switches to P8 state (234 Mhz) and then you get this laggy/choppy screen effect to the extreme while FPS can be reported as 'normal' as you described.
Attached images
hmz.jpg
Try full acreen.
For me if its windowed same thing happen..
Here's the screenshot with GPU on full power:
Attached images
Screenshot_1.png
I see.. CPU is running full speed also..

Hate to say it but at this point I don't know what can be the problem.
Try using v-sync, it may help, but it increases input lag
Does the sound also become choppy during frameskips?
I can't play with V-sync, the input lag is too much. Frown

Also sound doesn't appear to become choppy at all.
Here's a couple ideas...

LFS settings > misc > sleep every frame - I think we like "no" here

LFS settings > screen > Does it happen with both window and borderless modes? What about lower resolutions?

Try launching LFS in windows XP compatibility mode?

I'm guessing that Dell added some power saving software on top of the win10 stuff. Have you looked into that?

Any settings in the BIOS/EFI that look like they could be causing this?

Boot into a live USB of your favorite flavor of linux. Install WINE and LFS. Problem solved? (I'm only half joking)
Quote from bobloblaw :Here's a couple ideas...

LFS settings > misc > sleep every frame - I think we like "no" here

LFS settings > screen > Does it happen with both window and borderless modes? What about lower resolutions?

Try launching LFS in windows XP compatibility mode?

I'm guessing that Dell added some power saving software on top of the win10 stuff. Have you looked into that?

Any settings in the BIOS/EFI that look like they could be causing this?

Boot into a live USB of your favorite flavor of linux. Install WINE and LFS. Problem solved? (I'm only half joking)

I tried changing sleep every frame to NO a while ago, didn't work.

Seems it's happening with all resolutions and in windowed and borderless modes as well.

Tried XP compatibility mode, sadly nothing changed.

Dell's power saving software is completely turned off and the battery is put to High Performance.

I have no idea what would I look for in the BIOS

skip
is your laptop running full process if on idle?
That if your laptop uses CPU and memory close to 100% even when doing nothing, the flaw is in the system itself.
Can you still return the laptop, thats what I am wondering.
2/3 Dell laptops I've bought in the last year were returned because of graphics driver problems.

One more thing to try. In LFS setting near the 'sleep every frame' button there's the FPS graph that shows 'sleep/physics/wait'. You can keep this open while driving. If the lag/choppiness corresponds with spikes in the graph then it may be a CPU issue. If not, its probably graphics related.

Have you tried an external display?
No, the laptop doesn't use anywhere near 100% CPU or memory when doing nothing.

Also I think I forgot to mention that the laptop runs all my other games perfectly, games that are supposed to be a lot more demanding than LFS.

I tried the sleep/physics/wait, not really sure what to make of the graphs though. Sleep seems to miss a bar every now and then, physics is 100% constant and wait is really choppy.

Haven't tried an external display and don't have one at hand just now
Actually, with further inspection of the graph, whenever the frames start to drop/skip the Physics graph starts messing up.
Quote from ABCode :Actually, with further inspection of the graph, whenever the frames start to drop/skip the Physics graph starts messing up.

It's logical, LFS has to update the physics multiple times per frame when framerate drops, to keep the refresh rate of the physics at 100 Hz Wink
Did you tried reinstalling LFS and or Direct X9 libraries, do you have virus scanner active, are you infected with malware..
Quote from cargame.nl :Did you tried reinstalling LFS and or Direct X9 libraries, do you have virus scanner active, are you infected with malware..

Yeah, I've tried reinstalling LFS a couple times.

I now downloaded DirectX9 (I was using X12 before) but the situation is unchanged.. Frown
LFS doesn't use X10, 11 or 12 libraries, it's a common misunderstanding that X10, 11 or 12 also include 9 support. It doesn't. But anyway, you downloaded DX9 libraries which you probably already had and it didn't help hhmm..
1

Skipping frames
(26 posts, started )
FGED GREDG RDFGDR GSFDG