The online racing simulator
Help! couldnot initilise graphics
(9 posts, started , go to first unread)
Help! couldnot initilise graphics
So i have literally tried everything to fix this. Reinstalling graphics drivers. different versions of the game. downgrading system graphic drivers. This has only just started happening. What have i done????

I have an
Intel Core 15 3470
Radeon R7 260x
8 GB ram
Windows 10


Thanks for any help. will be greatly appreciated
Hey there,
could you please post your deb.log (found in the LFS folder) and if there's a windows error message coming up, the error codes/addresses, too. I personally couldn't help much with those informations either, but I'm sure it would be a huge help for the devs to fix the problem, if there's any.
Hey,

Thanks for getting back to me. this is the deb.log

Jan 12 14:05:02 LFS : 0.6Q
Jan 12 14:05:02 timer resolution 1 ms
Jan 12 14:05:02 read config
Jan 12 14:05:02 get command line
Jan 12 14:05:02 preinit d3d
Jan 12 14:05:02 started Direct3D 9Ex
Jan 12 14:05:02 number of adapters : 2
Jan 12 14:05:02 adapter 0 - valid modes : 31
Jan 12 14:05:02 adapter 1 - valid modes : 33
Jan 12 14:05:02 using adapter : 0
Jan 12 14:05:02 load font
Jan 12 14:05:02 -----
Jan 12 14:05:02 Can't Create Device
Jan 12 14:05:02 Could not initialise LFSE
Jan 12 14:05:02 Could not initialise graphics

Also i attached the error message that was popping up
Attached images
Capture.PNG
It tries to use the Intel HD Graphics 2500 GPU and failing with it. In your AMD Radeon R7 260x driver controlpanel you should indicate it is the dominant GPU. No idea how it works @AMD as I am Nvidia fanboy.
#5 - BeNoM
"Jan 12 14:05:02 number of adapters : 2"

Exactly as cargame.nl said, make sure your PC is using your dedicated GPU and not your iGPU.
Was writing a longer answer but you guys were faster Smile
Anyway, as they say, you should check the Power - Switchable Graphics menu in your Catalyst Control Center to make sure LFS is using the high performance AMD GPU as they say here: http://www.tomsguide.com/answers/id-2610379/switch-intel-graphics4000-amd-radeon-8570m.html
If that doesn't solve the problem, you could also try editing the cfg.txt in your LFS folder and change the value of Adapter Select from 0 to 1 (Line 7). It could work Smile
Thanks guys. Im not sure what exactly fixed it but i figured that alot of my other games were having issues aswell. so i decided to restore my pc back a couple days and it seems to be great and working now so not sure what happened there haha. Thanks again guys!
Sooooo, it started again. It affects all my games that try to use DirectX9 it seems. However i cannot find one fix.... nothing works now (like in GTA, it says failed to create Direct3D Device, same with most other games (Gmod, Cs))
did you install any updates, new drivers, etc....?

Help! couldnot initilise graphics
(9 posts, started )
FGED GREDG RDFGDR GSFDG