The online racing simulator
ClaViCo Autocross Plugin
(288 posts, started )
ClaViCo Autocross Plugin
A few months ago LFS 0.6B was released featuring new InSim packets. One of those (IS_AXM) quickly caught my eye. Thanks to the free view mode it became clear to me something interesting could be developed. As a result I wrote a small plugin: ClaViCo AP. The main goal of this tool is to expand the layout "building" possibilities. ClaViCo AP features a particular way you add Autocross Objects. With this tool "painstaking" patterns are easely made within a minute. You no longer have to add each object individually because you can quickly build patterns. Furthermore 2 limitations are lifted thanks to the IS_AXM packet. Firstly the objects can now intersect with each others. Secondly it is now possible to add objects out of bounds. Something which is not possible with the standard LFS autocross editor. I could go on and on describing each feature but to prevent the adrenaline seeking youth of our days to fall into boredom I let you take a look at the screenshots attached below.

Please note that ClaViCo AP is currently in the Alpha stage. I count on you guys to report any anomalies. A comprehensive tutorial might be written if there is any interest in this plugin.

Any pertinent feedback is duly appreciated. Have fun

NOTE:
------
• You will have to install .NET framework 4.0 (http://www.microsoft.com/en-us ... oad/details.aspx?id=17851)
• ClaViCo AP only works with LFS dedi, single player is not supported
• ClaViCo AP V1 is no longer supported


[RELEASES]
12.01.2012: ClaViCo AP V1 release (New Version)
13.06.2014: ClaViCo AP V2 release (New Version)
Attached images
lfs_00000033.jpg
lfs_00000030.jpg
lfs_00000034 - Copy.jpg
Attached files
ClaViCo AP V1.zip - 138.5 KB - 492 views
ClaViCo AP V2.zip - 105.5 KB - 815 views
Could not get to work this unfortunately... First had to install .NET Framework 4,as I didn't had it,then tried in single player and got this:

It instantly closes after I run it (console stays open,but closes when pressed any key).

Tried in dedi in local server mode,then I got this:

It just flashed this in console and closed.

So,where could be the problem?

Edit: But works when server connected to master server,is this the only way?
It should work locally too.
I have the same problem as Eclipsed.
I forgot to mention that you will have to use it in conjunction with LFS dedi.
Can you adjust the Y values of objects?

Any way to install this or just run the exe?
Great application, thanks for releasing it

for some reason I can't get floating objects, they always stay on ground
Quote :Can you adjust the Y values of objects?

Could you be more specific please? What are you trying to achieve? If you mean the X and Y coordinates sent by the IS_MCI packet, those are adjusted automatically.

Quote :Great application, thanks for releasing it

for some reason I can't get floating objects, they always stay on ground

I'm glad you like it "Floating objects" or adjusting the objects height can only be done effectively out of bounds. With out of bounds I mean areas where you can't add an object with the standard LFS Autocross Editor.
Y as in vertical. In air . Make object float.'


Also: app freezes on Win 7 64 bit
Z is height, not Y :P
Ok. Z then.

is "port" insim port?
If your object is placed out of bounds you can adjust the altitude from -80 (-20 metres) to 127 (31.75 metres). In this tool the value represented in blue is the altitude of your object, the value next to it in black is the current altitude of your car.

Quote :
is "port" insim port?

yes
Ok I have a problem maybe easier to do this over TS3 or MSN

thanks,
ray
Attached images
error.jpg
Quote :Ok I have a problem maybe easier to do this over TS3 or MSN

At the moment ClaViCo AP won't work in single player mode. The explanation is rather lengthy but it should work in the next version I will release. As for now you will have to setup ClaViCo AP in conjunction with LFS dedi (either locally or online).

If you can't make it work you can always try it out on my private server:

WS • Testland

password: "test12345"
this is on a dedicated server hosted at 500servers
A wild guess is that your host's firewall is blocking it.
never had a problem before. Is the "port" insim? And does server port need to be in extension to Ip


edit: claviko helped me fix
Quote from Bmxtwins :never had a problem before. Is the "port" insim? And does server port need to be in extension to Ip


edit: claviko helped me fix

What was it? Im having same problem.
right im completely clueless how to get this prog to work, never used any insim things befor i don't know how to.

could some one write me a list of instructions how to get it working please?

for example:

1: open lfs
2: open program
3: ...
4: ..

and so on.

thanks
Quote :could some one write me a list of instructions how to get it working please?

1. Download LFS dedi & extract its content
2. Find the setup.cfg file, open it and modify the following:
• replace //pass=password by /pass=password
• replace //insim=29999 by /insim=29999
• replace //ip=xxx.xxx.xxx.xxx by /ip=127.0.0.1
• replace /mode=demo by /mode=S2
• replace /usemaster=yes by /usemaster=no
3. Save setup.cfg
4. Launch LFS dedi & ClaViCo AP
5. Launch LFS -> multiplayer -> join specific host -> local network and fill in these parameters:
• Host IP address: 127.0.0.1
• Host port: 63392
• Host password: password
6. Click go and once ingame do shift + i

This should work.
hmm when i load it,

it comes up the black box then 2 seconds later says programs stopped working and quits

im using windows 7 64bit
Are you sure you followed the steps scrupulously?
yes, here look at picture, that just keeps happening
Attached images
error.jpg
Ohh! hang on hang on, fixed it thanks working
I had great fun playing with the Ramp2 object:
Attached images
UFO galaxy.jpg
Attached files
AU1X_ufos1.lyt - 2.1 KB - 633 views

ClaViCo Autocross Plugin
(288 posts, started )
FGED GREDG RDFGDR GSFDG