The online racing simulator
G27 LEDs mod [renamed]
(330 posts, started )
Hi,
When i switch FF on the LED on G27 works.
When i switch FF off the LED dont work.

I use proxy DLL version 1.05C.

Quote :cfg:
OutGauge Mode 1
OutGauge Delay 1
OutGauge IP 127.0.0.1
OutGauge Port 30000
OutGauge ID 0

Quote from stadtpirat :Hi,
When i switch FF on the LED on G27 works.
When i switch FF off the LED dont work.

I use proxy DLL version 1.05C.

This is expected behavior. The mod needs FFB to be enabled in LFS, unfortunately I forgot to mention this in the README. If you want the LEDs to work with no FFB, switch the FFB on but set its strength to 0 in LFS settings, that should work.
Thank you for the information.
I understand it right?

1. I need only the dinput8.dll 1.05C and copy it to the LFS Folder

2. I must Change the cfg.txt in:

Quote :
OutGauge Mode 1
OutGauge Delay 1
OutGauge IP 127.0.0.1
OutGauge Port 30000
OutGauge ID 0

3. Run lfs.exe
4. Enable FF or FF on and strength to 0 (FF is OFF).

Please Update the Readme.txt in the next release :-)
And very great work, i love this mod.
Yes, that's pretty much it.
Hi madcatx,
Im having a very hard time trying to find out how to run this program. I have tried everything i know, from the readme file to videos in youtube other people put in, but im still having the same problem.

When I launch LFS throught runleds.exe, the LEDS dont work. I know its not the wheels fault because when i tried to press G27sLEDShelper, it opens up and says port number not specified. I have the outgage port from the CFG.txt set to 30000, but it still doesnt work. Do you have any idea why it why the LEDS dont work?
I take it you use other version of LFS than 0.6B which is why you use the "runleds"? method? Could you please enable debugging mode in the mod's config file and post the output?
I am using 0.6B, i tried it using just from LFS.exe but still didnt work.
Attached files
g27dbg.txt - 2.1 KB - 330 views
There is a slightly modified version 1.05C available here. Could you please capture the debugging info with this version?
it still dont work. Here is the debug information.
Attached files
g27dbg.txt - 59.8 KB - 275 views
Good, there appears to be some pretty odd problem with 1.05C, but once that gets sorted out, the LEDs will hopefully work fine.

To make matters complicated, my Windows installation flatlined just a few minutes ago, so I can't give you any estimate when I'll release a new version...
1.05D is up. It hopefully fixes the bug I introduced somewhere after v1.05 while providing much better debugging info. Please note that the official support is still for LFS 0.6B only, test patches are supported through "runleds". Unless you're having problems with 1.05, there is no need to update.
Before reporting any issues, make sure you have debugging output enabled in the g27leds.cfg and don't forget to post the output file.
Attached files
G27LEDS_105D.zip - 418.2 KB - 385 views
Quote from MadCatX :1.05D is up. It hopefully fixes the bug I introduced somewhere after v1.05 while providing much better debugging info. Please note that the official support is still for LFS 0.6B only, test patches are supported through "runleds". Unless you're having problems with 1.05, there is no need to update.
Before reporting any issues, make sure you have debugging output enabled in the g27leds.cfg and don't forget to post the output file.

Thank you for your effort.
I'm new to this thread and I had no trouble installing this "plug". After reinitializing the axes the LEDs work pro... and the additional cfg for the LED range is a really nice thing.

Good job! Thanks!
Hi, i want to customize led settings. How could I open the .cfg file?
Quote from Speed Senna :Hi, i want to customize led settings. How could I open the .cfg file?

In any plain text editor you like, Windows Notepad is one obvious choice.
Quote from MadCatX :In any plain text editor you like, Windows Notepad is one obvious choice.

Thanks! And a big respect for you for programming this mod Excellent work!
Sorry but, i read all 9 pages, and i But I have not drawn any conclusions to work G27Leds finally.... I bough yesterday (the G27), so i'm noob with him, but i had a G25 and i had LFS configured for use REVLIMITER and CSR at the same time, but trying to use G27LEDS, now, i cant use anything, leds, csr, revlimiter... anything...

Anyone can show me how i need configure OG_RELAY for use 3 app at the same time? i dont play lfs for a year... So now i dont know how to configure it!!! And sorry my bad english, im spanish.... hahahah....

P.D: That's my last "game" on LFS, near 1 year ago... (i uploaded that video 1 month later i stop playing LFS).
http://www.youtube.com/watch?v=Q2Hk13KwyXQ&feature=plcp
I've made what appears to be a mistake of updating my Windows development environment to Windows 8 and MSVS 2012. There've been some changes to the compiler so I'd like to know if it there are any problems when the mod is bulit with MSVS 2012 toolchain. Apart from being bulit with MSVS2012 this version is identical to 1.05D.

See the first post in this thread for download.
MadCatX: Just to clarify since it's abit blurry. Does this work with the current test patches now?
Quote from NovaK :MadCatX: Just to clarify since it's abit blurry. Does this work with the current test patches now?

I guess I should have mentioned that. "Official" support is still for 0.6B only, but you should be able to get it working with any test patch through G27LEDsHelper. I'll release a bigger update once 0.6C is out.
I bought a G27 this weekend, and tested this mod now, its really great, I liked the possibility to customize the flashing feature is great

but two improvement suggestions... is it possible to make the "flashing feature" start flashing when the shift light goes on? (on cars that have it)


and... is it possible to make this mod compatible with this one: http://www.lfsforum.net/showthread.php?t=56690 ?

the original FFB I can't feel almost any kurb, but with this mod I can feel all of them




edit: I noticed that after installing this mod, my game is crashing sometimes when I play windowed and do alt tab, am I the only one having this problem?

edit2: Ok, it seems that the crashing is not G27 leds fault, I deleted this mod since it don't work on the new patches, and it keeps crashing
I've been asked how to get the mod working with 0.6E. I'm working on a bigger update with some extra features and more user friednly interface which will work with all versions of LFS. Unfortunately some other aspects of my life demand a lot of my time so I'm not progressing as fast as I'd like to.

In the meantime, you can still use v1.05 with 0.6E through G27LEDsHelper (still bit buggy, but it should work in most cases). If you have some programming experience, you can use CheatEngine to find the memory addresses which hold car type and RPM and update the mod yourselves. RPM is of float type and car type is stored as char[4]. Feel free to upload such an updated version.

I'll release an updated version as soon as possible, but I can't give you any sensible estimate ATM.
Thanks!
V 1.99A has been released.

Please note that since I rewrote the whole helper app and substantial parts of the DLL, I consider this a testing version. Please give it a try and let me know if you come across any problems. Once I'm certain that the basic functionality is working correctly, I'll start adding some extra features and make it less of a pain in the ass to use.

- This version has been built with MSVS2012. If you get any complaints about missing DLLs, you'll probably need this.
- Debugging output to file is enabled by default. Unless you hit any trouble I suggest you disable it in the config file.
- Format of the config file has changed a bit, don't use the old config with this version.
- Make sure you've configured the mod properly and read the README before reporting any bugs, thanks.
Quote from MadCatX :V 1.99A has been released.

Please give it a try and let me know if you come across any problems.before reporting any bugs, thanks.

I tried, but when i launch it up i get an error message, as it crashes instantly. Sorry i couldn't provide any more valuble information than this.

Installed the program you linked to, and had to get an additional dll-file called 'msvcp110d' i think. I'm running Win7 64bit, not sure if that has anything to do with it, but atleast you know my OS.
Thanks. I reuploaded the mod and now it links only to files available in the MSVS 2012 redistributable package.

G27 LEDs mod [renamed]
(330 posts, started )
FGED GREDG RDFGDR GSFDG