The online racing simulator
Shift+F4 lfs app crash (win7)
(11 posts, started , go to first unread)
Shift+F4 lfs app crash (win7)
Not sure if this if anyone can reproduce this but it happened to me twice tonight, still looking into what might have caused this.

spectating in a 1/4 full server, pressed shift+F4 to return from full screen (1920x1200) to windowed mode, no other programs running.

recieved error message "LFS.exe has stopped working" then window closes

heres the problem data:
Problem Event Name: APPCRASH
Application Name: LFS.exe
Application Version: 0.0.0.0
Application Timestamp: 4b0bf605
Fault Module Name: d3d8.dll
Fault Module Version: 6.1.7100.0
Fault Module Timestamp: 49eea4d2
Exception Code: c0000005
Exception Offset: 0004bf62
OS Version: 6.1.7100.2.0.0.256.1
Locale ID: 2057
Additional Information 1: 4709
Additional Information 2: 4709938665fa84e3ff99c8cbe11223bb
Additional Information 3: f4a1
Additional Information 4: f4a136babfc7f1a68f95d1c3d7e165fe


ATI Radeon 4870 Driver ver: 8.632.1.2000 all 32 and 64bit dxdiag tests pass.

This may or may not be a problem limited to my PC but I thought I would post here anyway as I could not find anything about this when searching.

Still trying to find a way to reproduce this.

SD
d3d8.dll

any mod installed? bloom or other software interfering with LFS's DirectX?

PS: I have Win7 64 and ATI and have no problems
HI Whiskey, No no mods at all, my win7 lfs is in its own folder on the desktop, was fresh from version Z and I told Z28 to install in the same location. I don't use the ATI CCC just the display driver, my next step will be to install the latest update to the drives.

Up until today I had no issues at all either, the only thing I have done differently today is; I resized the LFS window, by dragging the corner, I don't know if this is related or if my system just developed some kind of glitch, thats why I ran the dxdiag tests without restarting.

The lfs crash may well never happen again, but I posted here just in case someone else has similar probs.

Knowing my luck it will probably be another dodgy sata cable or some other non lfs related thing

SD.

EDIT: Hi Shadowww, you posted while I was typing you think I might have a directX prob?
Quote from SparkyDave :EDIT: Hi Shadowww, you posted while I was typing you think I might have a directX prob?

Could be, but I think it's just some random error that occurs once in a milestone.
I had a similar effect when I first installed w7 last year. Everytime I used shift+f4 my pc froze completly and I had to turn it off to get it going again.

My solution won't help you though as I did a clean install then. I suspected some driver being not properly installed.
mmm, maybe the is this (I read it when Z28 came out):

in the cfg there is a line with the size and position of the window. Maybe it got corrupted and it's trying to draw outside the limits of your screen.

I can't remember if the solution is fix that in the note pad or erasing the cfg. The only thing I am sure is Scawen posted about this, so it should make the search easier
having the same problem with me too.
any new suggetsion??
Step 1: Put the computer in clean boot and test
Follow Step 1 in the link below,
How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

If everything works fine after a clean boot, you can infer that some third party services are causing the problem.

Proceed with the remaining steps to pin-point out the third party service.
After you figure out the problem causing program, you may have to update or install a higher version of the program, if you seldom use that software you can consider uninstalling it.
Important: - Remember to put the computer back to normal startup follow step 7 in the link.
For more specialized assistance on Windows Live Messenger issue, please repost your query on Windows Live Forum.

Or otherwise try this APPCRASH – Explained With All Possible Solution
Deleting (or renaming, in case of backup) the d3d8.dll solved my problem (any maximisation of the window, going borderless or fullscreen made it crash).
Here’s the mail I got recently for my problem, No probs, try downloading from this site
Malwaretips.com/blogs/malware-removal-guide-for-windows
Safemode with metworking I find is always best way to download when things go wrong.
Im basically at a loose end what else to try there are guys on forum with way more experience, Im surprised you dont have answer yet.
Though Im going to go out on a limb and ask if you tried a system restore to good point then try running malware programs as if Im lost thats what I fall back on although it doesnt always work so can only recommend caution.
You may want to keep using safemode till you get answer which is not great but at least you can browse or try the restore but honestly I cant say for sure that would solve it.
Hope a download from the site I gave you here works.
Good luck

Shift+F4 lfs app crash (win7)
(11 posts, started )
FGED GREDG RDFGDR GSFDG