The online racing simulator
AIRIO - Advanced LFS Tracker
(2372 posts, started , go to first unread)
11.06.10 18:12:37 #4 AEGIO WARNING : Unknown TCP ISP packet
72 55 0 0 1 1 1 0 47 116 114 97 99 107 61 65 83 50 114 0 0 0 0 0 0 0 0 0 0 0 0 0 ...

How about INSIM v5
..
Yeah, sorry, I guess it is time to update the Aegio library... I'll try to make it today, at least so that all new packet types are known.
Actually, if I have all the InSim updates correctly sorted in my head, that warning of unknown packet (and Airio disconnect) happens only after every admin command, both accepted and refused, from any connection. All the object hits and layout update packets are optional and not sent.

Anyway, I did a quick patch of the library to recognize all the new packet types as valid ones, though without processing. Please, anyone interested in testing the incompatible patch 0.6A1 and newer with Airio, download and update the Aegio library files. (I hope it works...)
..
In my case it happens when track and cars changed automaticaly
Hm, then it would seem LFS is sending those hit packets, even though it should not? Or maybe I misread something somewhere. Automatic track/car change is done using admin commands, so yes, that would lead to disconnect. Please try to use the updated library.
ok thx, 5 mins for update & test
Yes, with updated library it works fine, sorry for the trouble
Does the update work with mixed servers too? some 0.6a and some still on 0.5Z28?
Quote from Crady :Does the update work with mixed servers too? some 0.6a and some still on 0.5Z28?

Yes, it's work fine with mixed servers. I have 0.6A, two 0.5Z28 and 0.5Z34 - all ok.
thx
Thanks for the Aegio update! running now a 0.6A1 server
ehhh why does it automatically spectate all people now if I do e.g. "/cars=uf1" ?? is it airio cause of the updated aegio libs or is this LFS itself??

Edit: same happens with "!cars uf1"

Airio log:
11.06.12 22:05:59 #2 C24P05 shredderboy - [CAD] Shredder : !cars uf1
11.06.12 22:06:00 #2 [CAD] SJB joined the spectators
11.06.12 22:06:00 #2 C04P01 sjb - Leaving race...

LFS log:
Jun 12 23:05:59 [CAD] Shredder : ^L!cars uf1
Jun 12 23:05:59 /cars UF1
Jun 12 23:06:00 [CAD] SJB^L joined the spectators

Edit2: seems to be 0.6A1 related, just did !quit and same happens at /cars=

Regards, SJB
Lfs.
Quote from Scawen :
on changing allowed cars disallowed cars will join the spectators

"_______" Lost Control spam
Every night when the S2 servers are emptied, i go onto the demo servers (mostly drift or AA) and every once and awhile in the drift server, there will be a idiot crashing and lagging or even hacking. I don't pay much mind to it until they collide with a equally laggy person and go flying into oblivion causing the "so and so" lost control to spam endlessly until they spectate or pit.

Sometimes they pit and such, but most of the time they don't and let it loop end on end. Dunno if this can be fixed or not. I'm normally cracking up the first few seconds, but it gets rather annoying after 5 minutes.
-
(Silverracer) DELETED by Victor : post no longer needed after thread merge
are the updated aegio files for 0.6A2 or A3 too?

was running A1 till yesterday, updated LFS to A2 while airio was running and airio reconnected successfully automatically.

But 1hour ago A2 crashed, I restarted A2 but Airio doesnt connect now:
11.06.14 20:53:50 #1 Restarting instance...
11.06.14 20:53:50 #1 Reading server configuration...
11.06.14 20:53:50 #1 Opening connection to 127.0.0.1:30002
11.06.14 20:53:50 #1 Connection failed...
11.06.14 20:53:50 #1 AEGIO ERROR : System.Net.Sockets.SocketException
Connection refused
at System.Net.Sockets.Socket.Connect (System.Net.EndPoint remote_end) [0x00000]
at LiveForSpeed.InSim.Aegio.Connection.ConnectionOpen (System.String hostName, Int32 hostPort, System.String adminPass, System.String insimName, Char prefixChar, Boolean hostLocal, Boolean keepColours, Boolean sendNodeLap, Boolean sendMultiCar, Boolean sendHits, Boolean sendAutoX, UInt16 updateInterval, UInt16 udpPort) [0x00000]

EDIT: Airio works now, restarted LFS server 2 more times and Airio did connect
..
Hi EQ,
I want to suggest one thing, seen feature to spectate people after finish race, so I think that it would be good to add feature to pit/spectate all people who causing yellow flags, after race, for people who want to make one more lap after race ( to keep track clean for them )
Quote from Sueycide_FD :... go flying into oblivion causing the "so and so" lost control to spam endlessly until they spectate or pit. ... Dunno if this can be fixed or not.

Airio has no "Danger, someone lost control message", that's purely Lapper feature which I never wanted to implement because of its very low value bordering on pure spam. I'm afraid you need to ask the drift server admins to remove that default Lapper definition.

Quote from SJB :are the updated aegio files for 0.6A2 or A3 too?[/B]

Yes, it was just the 5Z to 6A transition causing problems with new packets. The quick patch just disables erroneous Airio disconnects. I have much improved library version now, recognizing and completely processing all the new packets, also properly handling split (and merged, if they're possible) TCP packets. In a few days there'll be Airio 2.5.4 with this new library, not with so many new things, but fully compatible with 6A and future (uhm) LFS versions. This will be basically the lowest possible version to run on 0.6A+ LFS patches.

Quote from DANIEL-CRO :I think that it would be good to add feature to pit/spectate all people who causing yellow flags, after race, for people who want to make one more lap after race

Uhm, wow, I don't think that would be practically usable thing. Let me think about it, but...
Is it somehow possible to run Airio in hidden mode? tried add parameter "h" but it didnt worked

Noticed that commands in Airio window dont work if Caps Lock is on, like Q for quit.

When add AI driver on server, I'm not limad anymore, by !pl menu and I can get kick for inactivity
Quote from DANIEL-CRO :Noticed that commands in Airio window dont work if Caps Lock is on, like Q for quit.

Corrected for version 2.5.5.

Quote from DANIEL-CRO :When add AI driver on server, I'm not limad anymore, by !pl menu and I can get kick for inactivity

Yes, I corrected this earlier, it will be available in version 2.5.5.
As the official 0.6B patch is available, I updated the library files that Airio is using and called this a version 2.5.4. But it is just library updates, the program files are still the same as in 2.5.3 and even !ver will show this old version, but new library version. It is just a quick fix that was necessary, because older libraries will NOT work properly on new host versions, 0.6B and newer, Airio will keep disconnecting. To solve the problem, the Aegio InSim library needs to be updated, using the files linked in my signature.
..
You mean to allow/support voting for special "official" custom layouts on open tracks?

AIRIO - Advanced LFS Tracker
(2372 posts, started )
FGED GREDG RDFGDR GSFDG