The online racing simulator
AIRIO - Advanced LFS Tracker
(2374 posts, started )
Not really MC, J@tko is right, this is not about server config... If he uses UFB and also LFSW PB as the comparison base, there is no UFB found in his downloaded data and splits/sectors are always compared to zero, leading to the display he describes.

Now, using base car in this case could lead to large + numbers in case you actually have some have LFSW UFR PB on that track... OK, good point, I'll think about it... For some reason I chose not to use base cars when implementing this, but now I do not know what the reason was...
Quote from yeager :EQ, do you think AIRIO would be able to be configured to do the following?

The overall answer is YES. Configuration very similar to what you suggest is used for Dailycious races on R2R and also for Race nights on AMG, although they are a bit longer events.

The biggest problem is timing the config changes. You need FULL version for this with scheduled commands. Also it is not currently possible to say "change this 2 minutes after race 1 is finished", the change time must be set previously and in absolute numbers. (I can smell an improvement suggestion here.)

There may be other minor things that would probably need some small improvements, such as adding the ability to display to everyone the race serie results.

Another question is what to do then with the points and data. Would this all be just for the moment your name is (maybe) displayed for a short while or would it be better to keep the data for a longer time?

But again, overall I think the FULL Airio can support what you suggested. Making people aware of such races and interested in taking part is the hardest thing though...
There were two small bugs in initial Airio 2.3.5a (!pi output not working and server best lap shown wrong), so please get Airio 2.3.5b correcting (probably) the issues.
Quote from EQ Worry :There were two small bugs in initial Airio 2.3.5a (!pi output not working and server best lap shown wrong), so please get Airio 2.3.5b correcting (probably) the issues.

updated on 500servers CP.
What does the update at 500Servers update exactly? Only the exe, dll and pdb files, or does it overwrite the (standard) config files too?

EDIT:

Hmm... just tried to update... seems not to work !ver still shows 2.3.4b ... and the new LiveForSpeed.InSim.Aegio files have not been copied...
checking on it now Crady, but yes it basicall just overwrites the core files (not the configs)
EQ Worry -

Getting an error here for 2.3.5b full version.

Quote :09.12.30 18:08:42 Reading configs...
09.12.30 18:08:42 Common configs read...
09.12.30 18:08:42 Reading data...
09.12.30 18:08:42 AIRIO ERROR: Arithmetic operation resulted in an overflow.
at LiveForSpeed.InSim.Aegio.Strings.GetRawBytes(String str) in c:\Development Files\LFS_Aegio\InSimStrings.cs:line 101
at LiveForSpeed.InSim.Aegio.Strings.RawToUTF(String raw) in c:\Development Files\LFS_Aegio\InSimStrings.cs:line 162
at LiveForSpeed.InSim.Airio.Datas.Read() in c:\Development Files\LFS_Airio\Datas.cs:line 448
at LiveForSpeed.InSim.Airio.Airio.Main() in c:\Development Files\LFS_Airio\Main.cs:line 172

EDIT:

Must be a config issue somewhere as i just updated the Redline servers and that has worked. (fixed now btw crady).

Any ideas?
Thanks for updating manually.

However now nothing works with Airio now

Neither !top nor !pi, !pl and some other commands too.

This is the error the log gives me several times:

09.12.31 02:11:09 Starting Web thread...
09.12.31 02:11:09 Web thread started...
09.12.31 02:11:09 Reading WR table...
09.12.31 02:11:09 WR table read...
09.12.31 02:11:09 Reading configs...
09.12.31 02:11:09 Common configs read...
09.12.31 02:11:10 Reading data...
09.12.31 02:11:10 AIRIO ERROR: Arithmetic operation resulted in an overflow.
at LiveForSpeed.InSim.Aegio.Strings.GetRawBytes(String str) in c:\Development Files\LFS_Aegio\InSimStrings.cs:line 101
at LiveForSpeed.InSim.Aegio.Strings.RawToUTF(String raw) in c:\Development Files\LFS_Aegio\InSimStrings.cs:line 162
at LiveForSpeed.InSim.Airio.Datas.Read() in c:\Development Files\LFS_Airio\Datas.cs:line 448
at LiveForSpeed.InSim.Airio.Airio.Main() in c:\Development Files\LFS_Airio\Main.cs:line 172

ahh so same error. Could have sworn it was working earlier (must have been 2.3.4)

I have installed 2.3.5a on your CP, can you let me know if its now working?
awake that late? lol

sorry, no does not work Airio does not even start up...

Would be nice if you could copy back version 2.3.4b FULL from the Backup folder (I guess Airio.exe and Airio.pdb should do the trick - the libs should be the same)....

Thanks!

Guido
Quote from Crady :awake that late? lol

sorry, no does not work Airio does not even start up...

Would be nice if you could copy back version 2.3.4b FULL from the Backup folder (I guess Airio.exe and Airio.pdb should do the trick - the libs should be the same)....

Thanks!

Guido

done. and im normally up this late. its the best time to get things done.
ayup, mate... works Thanks again.
I'm SO sorry, it was my bad!

It looks I took a bit optimistic approach (probably being in a festive mood) with version 2.3.5b enabling internal arithmetic overflow checks in the Aegio InSim library, leading in some cases to errors when handling LFS strings, leading then to failures at different places - reading stats, doing commands...

Version 2.3.5c without this additional check is now available, which should solve all the issues, also the updated files are sent to 500servers. Be sure to overwrite the Aegio InSim library files (LiveForSpeed.InSim.Aegio.dll and LiveForSpeed.InSim.Aegio.pdb)! Sorry again for the troubles... Have a happy new year!

PS: Actually I believe the above problem is also caused when moving from older versions to the newest. Something may fail, but if stats are saved and later read again (Airio 2.3.5b restarted), very probably the problem will disappear... That's why the very strange behavior some of you experienced.
Does anyone have experience if 2.3.5c works without any issues?

I don´t want to issue an update again which might have major problems too...
the user that had issues that i posted here for before has it installed now and working fine
Cool... then let´s hope the the updater in the control panel works for me now..
Ok the updater does not work for me for some reason... Have to wait for our Admin to update the files manually.
aha! now i see why thats happened.

Fixed and updated for you (can u confirm?)
Yes, confirmed tanks

Guess we should start a own 500Servers Airio support thread.. lol
nah.. just consider this one hijacked
:ufo:
lol... then

There is something more wrong I guess... it seems as Airio is using an other folder now

It is using quite old stats files and the Airio.log does not change anymore... it just stops at 2.35 p.m....
That certainly looks to me like an update at a wrong place, wrong one of the eight RR servers... Airio certainly cannot use other than its own directory, much less on 500servers where all directories have these very strange names... Currently I have no reports of any troubles from other people.

And one more thing concerning the special R consisting of two Japanese characters. With this Airio version you just replace them in config files with the correct unicode characters, because there's now full conversion from Unicode and back supported in the Aegio library.
i spoke to redline Evo and found out what the problem was. and now thats sorted.

AIRIO - Advanced LFS Tracker
(2374 posts, started )
FGED GREDG RDFGDR GSFDG