The online racing simulator
I also had a problem with sound in Windows 11 - perhaps it is caused by the KB5037853 update that was released on May 29, 2024
Quote from matze54564 :Can you tell us which antivirus software you are using?

Avast. I also had the same issue with lfs.exe being detected as a dangerous app. Making the exception solved it.
Quote from Silverracer :Norton.

I use F-Secure, and E12 was not detected as a false positive. I know this information isn't very helpful.
Quote from Lucas McFly :I also had a problem with sound in Windows 11 - perhaps it is caused by the KB5037853 update that was released on May 29, 2024

I recently fired up a old pc with fresh windows 10 and I am having sound going off. I thought I did a pic of the error but I can't find it. I will this weekend!
Quote from Lucas McFly :I also had a problem with sound in Windows 11 - perhaps it is caused by the KB5037853 update that was released on May 29, 2024

Quote from loopingz :I recently fired up a old pc with fresh windows 10 and I am having sound going...

In both cases was it limited to LFS's sound not working or did it affect the operating system sound output (which was resolved after a restart)? Mine was the latter.
When it comes to the overall sound of the system - The system "solution of typical sound problems" in Windows 11 helped me,
and in LFS - adding an exception to Avast - "Sound Error play:b-2147221164"
Ok New test today. I went to spectate on a server with cars running. Controllers unplugged.
Windows 10 up to date. Almost new install. No AV. LFS e12.
After about 3 to 5min (I can do it again and maybe time it but it feels consistent) I have the following in red:
No sound (GetCurrentPosition:'P -2005401450) (without ')
No more sound in LFS. Still sounds for other windows program.
Don't know what else to do.

Edit: installed specific sound driver. Tested for 7min without issue.
Quote from Scawen :
- List of Hosts comes direct from master server (no pinging)

Hello. It's great that the server list loads immediately. It was really annoying waiting for the servers to be listed.

I have a small request or suggestion.

Since you've removed ping ranking, it can be difficult to constantly search for our favorite servers in the list.

So I think it would be very nice to mark our favorite servers. In such a case, we can mark our favorite servers and connect to them without wasting time.

When we click on the server list, all servers are already visible. If we enter even part of the server name we want with the search button in the upper right corner, unsuitable servers can be eliminated and the servers we are looking for can be displayed. Additionally, the list of servers we play on can also appear in this section.

Of course, these will be done by categorizing. Since I'm not a programmer, I don't know if this is really difficult or easy, but these are really nice features.

Note: I have no Photoshop or editing skills, I know that, just deal with it. Big grin

Quote from RealistAdam :Hello. It's great that the server list loads immediately. It was really annoying...

Good idea Adam, perhaps this "favourite server" can be implemented by adapting the favourite mods code, so it shouldn't be as much of a pain to do so, I'm not sure though. Certainly would be great
The "LFS_PATCH_7A_TO_7E13_setup.exe" was blocked by my AV F-Secure. Usually, I rename these file extensions from exe to 7z. But with this file, I couldn't use the 7z archive for the update because it obviously isn't one, so I can't install E13 because the exe is being blocked.
It is an archive, it's just an exe because it's a self-extracting one. If you right-click on it in windows explorer, one of the '7zip' options is 'open archive' which will treat the exe file as if it's just a regular windows folder, and you can copy files out of it from there.

No need to run it or rename it that way.
I installed now Universal Extractor and the extracted folder i used for sync with my lfs folder via beyound compare. maybe i should also use the 7z software.
I would recommend the 7zip software from the official site: https://7-zip.org/

It's very small and efficient and seems to be able to unzip everything including rar, zip, 7z, etc.
Since the published 7E14 and 7E13 test updates are related to servers, I shared them here.

I guess I didn't want any extraneous features.
Thank you.

I've never seen these articles before. I am very careful when writing on test patches. I made a suggestion because the updates are related to servers and server list. Thanks again for the forum links. They are all very valuable.

''Puky'' you may be right about this ."favourite server" can be implemented by adapting the favourite mods code
I can see that the E13 update makes your local servers harder to find.

Maybe I can add a text quick filter to compensate for that, similar to the one on the mods page but probably will not implement favourites at this time as it's more complicated.

Maybe it should be possible to sort by the location column too, to finish off this change for now.
Hello Scawen, I've been meeting this issue that when you tab out while connecting to a server, you will receive errors on the "wating for..." or "checking for..." I'm honestly just a new player but it would be great if I could hear about its causes. Smile
Hello everyone!

I have an issue, well, two of them I think.

First of all, when I try to to go servers menu, the window asks me for the patch 7E13 and gives me three options to choose from as a location: Nederlans, America or something and japan or something. I live in Greece, so I chose NL, for no particular reason rhather than that it's closer to where I am. After that, LFS shuts down and some seconds later a pop-up window asks if I want to restart LFS and informs that update was successful . I choose yes and nothing happens.

The other issue is that if I don;t choose a region for the update and click on cancel, no server is shown.

Any suggestions?

Thanks in advance!
Hi,

1) I don't know why the auto updater doesn't seem to have worked on your computer. That's the first I've heard of that (after a few thousand downloads) so I assume it has been working for most people. Can you see the install file LFS_PATCH_7A_TO_7E13_setup.exe in your LFS folder?

2) If you don't update to E13, no servers are shown in the list due to a change we have made.

You do need E13, so if the auto updater doesn't work then I suggest you get E13 from the first post of this thread and manually run the installer.
Quote from Scawen :Hi...

Hello again and thank you for you reply!

I did the manual installation, I see the .exe in the folder, but when I run LFS on the screen it still says 7E12.

It's been a couple of days now, I still can't find what is wrong.

LFS Test Patch 0.7E15
(163 posts, started )
FGED GREDG RDFGDR GSFDG