The online racing simulator
Test Patch Y14 - AA / AF / East Asian support
(185 posts, closed, started )
Test Patch Y14 - AA / AF / East Asian support
WARNING : THIS IS A TEST


Hello Racers.

Here is a new fully compatible test patch Y14.

It contains Chinese, Japanese and Korean Translations.
Various fixes including a South City hot lapping issue.
Full-scene antialiasing and anisotropic filtering are now supported.
Please read the list of changes below.


Changes in TEST PATCH Y14 :

Full-scene antialiasing is now supported in Graphics Options
Graphical and audio dynamic lod reductions are now instantaneous
FIX : Fences at Blackwood used the road surface mip bias setting
FIX : NVidia cards lost mip bias settings on changing screen size
FIX : Crash on pressing SHIF+F5 to reload language in help screen

Known issues :

Russian and Slovenian flags appear to be radioactive
Dedicated host does not display double byte characters
Name of active Chinese input method is not shown in Vista


Changes in TEST PATCH Y13 :

Added support for anisotropic filtering in Graphics Options
Improved control of mip bias : 4 sliders in Graphics Options
Improved filter (16 bit / 32 bit / all) in Screen Options
Path edges in track selection screen now appear smooth
Improved lesson description blocks width and spacing
FIX : Multiplayer in-game text often appeared blurred
FIX : Unnecessary message "Could not get input context"
FIX : Double byte AI number plates in overtaking lesson


Changes from Y to Y12 :

Double byte character support :

Included Chinese, Japanese and Korean translations
Selectable fonts for these languages in Game Options
Input method editor support including candidate lists
IME automatically switched on and off in text entry dialog
Input language is shown when editing text (white if IME active)
Name of active Chinese input method is shown (but not in Vista)

Interface :

Faster text drawing system improves frame rate
Separate text entry field for AI number plates
Welcome screen now has three columns of languages
Added flags beside names of translations in Game Options
Czech / Japanese / Simplified Chinese lesson translations
Network debug messages are no longer sent in InSim packets
Text input box is now drawn above user messages so easier to type
Line breaks in help text and lesson text now depend on actual width
New game setup screen info message "X removed Y from the start grid"
FIX : Low ASCII characters can no longer be read from text files
FIX : Corrupted text in top left corner after changing language
FIX : Corrupted "finished" at top right after changing language

Multiplayer :

New command /ndebug=no/yes to switch off/on network debug
Dedicated host and network debug show connecting guest IP
FIX : Rapid /ai NAME command resulted in AI with same name
FIX : Rapid /ai command could exceed number of cars allowed
FIX : Joining a host with same name AI resulted in Join OOS
FIX : Skin name buffer overflow exploit

Fixes :

FIX : Replay could open reversed configuration in DEMO
FIX : Wall riding was possible on soft walls at South City
FIX : Could select invalid configuration and weather in cfg.txt
FIX : Admin could crash dedicated host by mistake with some commands


DOWNLOAD :

PATCH Y14 (Version Y must already be installed) :
www.liveforspeed.net/file_lfs. ... me=LFS_PATCH_Y_TO_Y14.exe (1.6 MB)

DEDICATED HOST (for hosting only) :
www.liveforspeed.net/file_lfs.php?name=LFS_S2_DEDI_Y14.zip


KNOWN ISSUES :

Russian and Slovenian flags appear to be radioactive
Dedicated host does not display double byte characters
Name of active Chinese input method is not shown in Vista


Windows XP : East Asian Language Support / Font Installation

LFS does not support double byte characters with Windows 98 / ME. Windows XP and Vista should work well but you may need to install fonts.

If you have Windows XP and currently cannot see the East Asian translations, here's how to set up your computer so it works.
See the attachment - in Control Panel click on "Regional and Language Options" then under the "Languages" tab select "Install files for East Asian Languages".
Windows will probably ask you to get your XP CD and the fonts will be installed from it.

This is important even if you do not use Chinese, Japanese or Korean translations so you can see East Asian text and player names correctly when you are online.
Attached images
support.gif
Keep up the good work!
Will test as soon as I come home...
Sweet, now with FSAA in game options, thanks. Ill try this out and report back any probs
oooh, AA now too, lovely

Works great too!
Good work, works ok But FPS is very poor. (on a clean LFS installation)

I get a better FPS on another LFS installation with high-res packs and the best graphics options in ATI Catalyst...(normal patch Y)
thats gold!
Quote from zeromussov :Good work, works ok But FPS is very poor. (on a clean LFS installation)

I get a better FPS on another LFS installation with high-res packs and the best graphics options in ATI Catalyst...(normal patch Y)

Please state exactly what settings you are using that give a poor frame rate.

Maybe even a screen shot of your old and new graphics options screens. And please make sure you are in the same video mode.
Thx for AA and AF options!
btw, help (?) for AA in graphics options?
Scawen,im not Gay,but I love you
#10 - dev
Thank you for the ingame AA control

/me goes testing...

EDIT: AA works perfectly... even when using Shift + F4 or Alt + Tab
Found a reproducable bug

If you change AA settings in game with mirrors or dials set to virtual or off (real ones off basically), then the area where the real mirrors/dials would be goes corrupted/weird.

Noticeable on incar view, mirror corruption also visible on external view (they go all pink for me).
E: ^ I can reproduce this, too.

Okay just tested:

AF setting still doesn't do anything for me. Also tried setting it with nHancer (as I've used it before), but to no avail.

AA setting works fine

Though one suggestion, maybe you should remove the 3x mode and add the 8x one instead. As far as I know, the 3x is in reality the 2x Quincunx mode, which is just a blurry piece of crap. I have no idea why anyone would ever want to use it, as IMO the normal 2x mode is superior to it. Though if the 8x selection is not easy to implement, just leave it like that.

Another thing, now that AA is officially supported, can you see if there's an easy fix to prevent the transparent tree textures having a small pixel line on top of them (caused by AA, see attachment). It has been like that forever, but now that AA is not forced anymore, maybe you can do something about it.
Attached images
AA.jpg
Quote from AndroidXP :
Though one suggestion, maybe you should remove the 3x mode and add the 8x one instead.

Another thing, now that AA is officially supported, can you see if there's an easy fix to prevent the transparent tree textures having a small pixel line on top of them (caused by AA, see attachment). It has been like that forever, but now that AA is not forced anymore, maybe you can do something about it.

I'm able to select the 8x-mode!
Quote from AndroidXP :Though one suggestion, maybe you should remove the 3x mode and add the 8x one instead. As far as I know, the 3x is in reality the 2x Quincunx mode, which is just a blurry piece of crap. I have no idea why anyone would ever want to use it, as IMO the normal 2x mode is superior to it. Though if the 8x selection is not easy to implement, just leave it like that.

I'm just displaying all AA modes that D3D reports are available.

This depends on your card and probably drivers.
I can't really make an good comparison because i use some high-res packs in one of my LFS installations. (also AF/A-A in drivers)

Well, I think it's ok now.. FPS seems some lower, but I think the AF works some better in Y14...
Attached images
new.jpg
old.jpg
Now that's weird. I can definitely select 8x AA in the driver and it also definitely works. Weird. Ok, hm, nevermind then.
Quote from AndroidXP :Now that's weird. I can definitely select 8x AA in the driver and it also definitely works. Weird. Ok, hm, nevermind then.

I can select 16x in driver options but only have 2x, 4x, and 8x in game.

nVidia 8800GTS (old one) and 169.09 drivers.

Edit: Attached DXDiag output in case it's useful.
Attached files
DxDiag.txt - 51 KB - 125 views
#19 - dev
Quote from Scawen :I'm just displaying all AA modes that D3D reports are available.

This depends on your card and probably drivers.

Hmm... that's strange... My card does support 8x but it doesn't show in-game...

2Bean0: Same with me In nVidia CP I can select 2x, 4x or 8x, but in-game there is no 8x available
I still prefer setting my AA/AF settings from an external program. nHancer to be specific. They just offer wider variety of options.
Altough for less experienced players having the settings in game is a good option.
Ah, I think I know what it is. LFS "only" supports pure multisampling AA, whereas the 8x I was talking of is actually the 8xS mode, which is a combination of 1x2 supersampling + 4x multisampling. It has crap performance anyway, so no need to investigate this further, Scawen. If anyone wants to use these modes, they should use profile or programs like nHancer to force it.
Nice, that's what i wanted.
...
:bowdown:
IMHO having at least pure supersampling methods would be nice...
Is it just me or....?

Prior to Y13/Y14 I had all the AA/AF settings done through nHancer or the nVidia Control panel...no probs at all, looked pretty, and ran WELL...
Installed Y14 and set the card options to "Let the Application Control it" wherever I could...set AA and AF 'in game' to almost what they were in the card control panel, and... a DRASTIC drop in frame rates..
Gone form 200+ fps to a measly 40 - 60 fps at BL! (full 20 car grid of AI's)
Anybody else lost lots of FPS???
AA and AF settings don't seem to be working for me. No difference when the AA if OFF and when it's set to x4.

Tried restarting LFS and my PC.
This thread is closed

Test Patch Y14 - AA / AF / East Asian support
(185 posts, closed, started )
FGED GREDG RDFGDR GSFDG