The online racing simulator
G29 wheel detected but not working...
(13 posts, started )
G29 wheel detected but not working...
Afternoon folks,

Having issues with my wheel, only recently back on LFS.

The wheel itself is detected but I can't assign any buttons i.e trottle to peddle axis. it's still recognising the mouse as the main control.

any help is greatly appreciated!

Happy New year

K
At option > controls select wheel / joystick

And make a profile for lfs in profiler
Quote from RC-Maus :At option > controls select wheel / joystick

And make a profile for lfs in profiler

Thank you! Thumbs up
Hello,

going to revisit this again, having the same issue.

Wheel is detected, but I don't have any functions. when I start it's like the throttle is stuck open without any functionality.

When I go to settings the functions appear to work for example peddles are detected.

I'm the biggest noob when it comes to this so please be patient!

Cheers,
K
does it happen when you leave the pits? i think LFS recalibrates the wheel when it's loaded, so the first time you leave the garage the throttle is open. just moving the wheel helps.
if not try to reverse the pedal axis in controller settings
Yes - exactly.

nothing seems to work, paddles, peddles or wheel rotation but in settings the wheel is detected. pedal axis also appears to work in settings.

Thank you for the reply
Please see attached screenshot.

it appears that throttle/brake axis are always on, no function of wheel either.

Help is greatly appreciated.
Attached images
LFS Wheel Untitled.png
I see your handbrake is set to 'axis' when it should be a button... I wonder if your steering thinks it is the handbrake?
Quote from Shirtkicker :I see your handbrake is set to 'axis' when it should be a button... I wonder if your steering thinks it is the handbrake?

I'm the only person capable of doing something so stupid - no really, thanks! will give it a go this evening!
Quote from Shirtkicker :I see your handbrake is set to 'axis' when it should be a button... I wonder if your steering thinks it is the handbrake?

Thanks for your help, unfortunately it didn't change.

looking at the range, it appears to be set at 1000 which I believe means that it's fully applied, tried to change the value to -1000 but no luck.

Is there a way I can reset to default?

Once again, many thanks for all your help.
Attached images
LFS Wheel Untitled.png
** Best answer **
Thumbs up

resolved
Quote from Cote Dazur :how?

press each pedal and see which axis bar moves then select the appropriate axis for each pedal

G29 wheel detected but not working...
(13 posts, started )
FGED GREDG RDFGDR GSFDG