The online racing simulator
AIRIO - Advanced LFS Tracker
(2373 posts, started , go to first unread)
It seems that each time I connect to (FM) Fox Junkies I have to reset the 1st thing from "All Messages" to "Set Messages". It keeps going back to All Messages for some reason.

I don't know if it's just that server or others since I mostly visit Fox Junkies.
Thanks for letting me know. I've just mailed the FM master asking for a value used in a certain server setting, advising him to change the value. Airio allows admins to specify message verbosity (no/set/all) on each connect, but it really would not be a good idea to force All Messages constantly to everyone. Hopefully we'll clear and correct the matter soon...
Is it possible when a person wins the race he receives points, can these be uploaded to a website like a league table.

Mick 10 points
Jack 8 points
Ben 6 Points Etc......

and updated after every race.

Mick
Quote from Mikjen :Is it possible when a person wins the race he receives points, can these be uploaded to a website like a league table.

Mick 10 points
Jack 8 points
Ben 6 Points Etc......

and updated after every race.

Mick

Mick you could use michele's script http://www.lfsforum.net/showthread.php?t=56503

We use it on our site ... works great..
I seem to be having a problem banning traction control.

If a player joins with TC turned on, then he is spectated for bad setup.
However, if a player joins with TC turned off and then turns it on whilst on-track this is not penalised.

Any help would be appreciated
hi there...

not sure what's going on here...

Quote :RotateTracks=BL3_Figuratively|5|XRG > AU1_ParkwayLong|5|MRT > AU2_RingOfFire|5|UF1 > BL3_TheMaze|5|FXO > BL3_PitOfDespair|5|RB4

Quote :09.08.24 17:47:51 #1 Next track in rotation : AU1_PARKWAYLONG/5/MRT

looks good, right? at load time, it keeps setting it to 3 laps instead of 5... and only for this one combo... i don't get it. running 2.3.3, upgraded yesterday.

any ideas? thanks.
Quote from Bean0 :If a player joins with TC turned on, then he is spectated for bad setup. However, if a player joins with TC turned off and then turns it on whilst on-track this is not penalised.

Now this is a real trouble and I'm very much afraid I cannot offer a simple solution. For some reason player/car setup data are reported via InSim by two different constructs.

One is "driver" data - autogears, brakehelp, autoclutch. Whenever some of this changes (e.g. by pressing Shift+G to tun on/off automatic gears while on track), it is reported as driver change and Airio can act based on these data when e.g. AG is prohibited.

The other is "car" data - ABS, TC, symmetric wheels. They are reported _only_ when joining track. While I believe you cannot turn on/off ABS while on track, if you manipulate with TC it is never directly reported, so it cannot be acted upon.

The only solution I see is asking periodically (say each 10 seconds) for all info concerning cars currently on track. Maybe this is possible, but I can say it is not easy, it may collide with other Airio checks and features. Anyway, because TC currently cannot be prohibited or enforced, as you very correctly noticed and reported, I'll try to adjust the code the way I hinted...

EDIT: The periodic TC check does not work either. Server simply reports TC state active at the moment the driver joined track (as set on Brakes tab in Pits), regardless of current real state.

Bottom line: In my opinion the valid TC on/off status is not reported anywhere and so in effect TC can be neither prohibited nor required. Of course I may have overlooked some option, in that case I'll be grateful for any ideas or comments. Meanwhile I'll add correct TC reporting as part of player (not car) data into my suggestions for InSim improvements to be implemented by LFS developers...
Quote from Mikjen :Is it possible when a person wins the race he receives points, can these be uploaded to a website like a league table.

This would require 2 things:

1) Direct support in Airio to send specific Web requests to a configurable address on various events (not just points, but some might require split/lap times, position and lots of other data, e.g. even PB improvements). Possible, sure, but hard to put it into some flexible framework and to select just what is sent and when.

2) Web script (PHP, ASP.NET) accepting the information on some server/site, processing them and showing somewhere or storing it for later display or whatever.

While it could be interesting, I think Remote and scripts processing Airio stats give a much wider view. Still, when some really interesting option appears, something like this may be implemented into Airio.

[Idea: Report race starts and finishers (with points), create tables showing nicely race numbers and results, one after another. That may be nice and usable, actually. ]

Quote from bunder9999 :at load time, it keeps setting it to 3 laps instead of 5... and only for this one combo... i don't get it. running 2.3.3, upgraded yesterday.

Very weird indeed. The rotation code was not changed for some time already and I surely do not see where was 3 laps taken from. Please do some more experiments, see if really this happens only on this layout.

Hm, one (vague) idea. Isn't the 3 laps somehow hard-coded into that one particular layout? Airio first sets lap count and only then calls the track change, so if layouts can contain default lap count (not sure about this), maybe this one does?

Then the option would be either to update the lap count directly in layout or update Airio so that it sends race length (once again) after the layout is loaded... Let me know pls of any developement in this matter.
#759 - Bub
Hi!

I found some intresting lines in Airio.srv.txt, but i have question.

# -------------------------- Car Filters -------------------------- #

# If setup filter is active you may require/enforce a setup - boolean
SetupGearsForce=false
SetupBrakeForce=false
SetupClutchForce=false
SetupShiftForce=false
SetupTcForce=false
SetupAbsForce=false
SetupSymWForce=false

i think becouse of this line "SetupGearsForce=false" I can force drivers, to drive with equal gear ratios.
Is that write?
and if it is possible, where i need to write them, to force drivers use only gear ratios that i only want?
Quote from Bub :i think becouse of this line "SetupGearsForce=false" I can force drivers, to drive with equal gear ratios. Is that write?

No, that is not possible. Airio (and any other InSim application) can know only things reported by the LFS server and this does NOT include detailed car setup information, such as gear ratios, camber settings and such.

Only very general things are reported, in this case if automatic gear shifting is used. So in Airio you can prohibit (or require) auto gears, but that is all.

People were earlier asking if it is possible to enforce using some default car setup to have exactly equal cars in race. That is not possible either, for the same reason as above. The only car setup thing reported is if symmetric wheels are used, that's all.
#761 - Bub
oh okay, now i see
Thanks for answer, now i know what does those lines
Quote from EQ Worry :
Bottom line: In my opinion the valid TC on/off status is not reported anywhere and so in effect TC can be neither prohibited nor required. Of course I may have overlooked some option, in that case I'll be grateful for any ideas or comments. Meanwhile I'll add correct TC reporting as part of player (not car) data into my suggestions for InSim improvements to be implemented by LFS developers...

Thanks for looking into it.
I read through insim.txt and feared this might be the case.
Quote from EQ Worry :Very weird indeed. The rotation code was not changed for some time already and I surely do not see where was 3 laps taken from. Please do some more experiments, see if really this happens only on this layout.

Hm, one (vague) idea. Isn't the 3 laps somehow hard-coded into that one particular layout? Airio first sets lap count and only then calls the track change, so if layouts can contain default lap count (not sure about this), maybe this one does?

Then the option would be either to update the lap count directly in layout or update Airio so that it sends race length (once again) after the layout is loaded... Let me know pls of any developement in this matter.

none of the layouts i'm using have start positions... i just tried it with a second AU1 layout (wobblyoval) but with a different car, and it does the same thing... does that narrow it down a little? i'm pretty stumped, as my config hasn't changed since forever.
Quote from Bean0 :Thanks for looking into it. I read through insim.txt and feared this might be the case.

I think it is an ommision/inconsistency. Either TC should not be configurable on track, only in pits (such as ABS is), or it should be part of player data with updates (such as auto gears are). As the TC is reported now, it really has no value, as it cannot be checked. And, btw, nice skins you do.

Quote from bunder9999 :i'm pretty stumped, as my config hasn't changed since forever.

No idea for now, I'll contact you using PM here in forum, if you could send me the layouts and configs used, I could do detailed testing as hopefully see where's the catch...
Quote from bunder9999 :hi there...

not sure what's going on here...





looks good, right? at load time, it keeps setting it to 3 laps instead of 5... and only for this one combo... i don't get it. running 2.3.3, upgraded yesterday.

any ideas? thanks.

hi.
i had the same code on my server, but the only issue i have is when anytime it rotates to the UF1, the rotation stops.
tried it on a different server, so i don't think it's something i may have accidentally coded in.....
up till 2.3.3., it has been fairly flawless.
can i go back to previous version?
I've been in contact with Bunder, I tested his layouts and rotations. The strange thing was it was using wrong lap count, but on a different track/layout than in his case. I think I know why is this happening:

When you change track just by e.g. /track=au2, the track is loaded, but also one of the available layouts. I do not think I can prevent that. Only when new track (with random or first layout) is loaded, Airio can do /axload=newlayout. And I think that 1st random layout can change lap count.

The option should be to remove from server all layouts that are not used. Or I would need to update Airio code and send lap count only after the correct layout is loaded, but it will require some thinking and testing.

Quote from z-ro 8 :i had the same code on my server, but the only issue i have is when anytime it rotates to the UF1, the rotation stops.

Hm, this seems like some different issue. While you can always downgrade to previous version, it would be much better to discover why this is happening. So if you'd like to go this way, please send me the rotation string and all layouts to eqworry [at] airio.eu. I'll do detailed testing then and hopefully identify the issue.
EQ Worry, what about utf-8 BOM in PB.txt?
Can someone help me?

I'm sorry but english is not my first language and i'm having a hard time finding a "how to" for what i want.

I have set up a Airio Server, gone through the configs and i managed to configure everything that i wanted properly, except one thing:

Is there anyway to put a "welcome" message when a user joins the server? For instance, i want every user that connects to the server to see a message with the server's rules, is that possible? (inside the server, not while connecting)

Sorry for my newbie question

And sorry for my english mistakes also!!! Thanks in advance for you help!
Quote from EQ Worry :


Hm, this seems like some different issue. While you can always downgrade to previous version, it would be much better to discover why this is happening. So if you'd like to go this way, please send me the rotation string and all layouts to eqworry [at] airio.eu. I'll do detailed testing then and hopefully identify the issue.

RotateTracks=BL3_Figuratively|5|XRG>AU1_ParkwayLong|5|MRT>AU2_RingOfFire|20|UF1>BL3_TheMaze|15|FXO>BL3_PitOfDespair|7|RB4

this is what i have in rotation line,hopefully it's something i did
Quote from SirThiago :Can someone help me?

I'm sorry but english is not my first language and i'm having a hard time finding a "how to" for what i want.

I have set up a Airio Server, gone through the configs and i managed to configure everything that i wanted properly, except one thing:

Is there anyway to put a "welcome" message when a user joins the server? For instance, i want every user that connects to the server to see a message with the server's rules, is that possible? (inside the server, not while connecting)

Sorry for my newbie question

And sorry for my english mistakes also!!! Thanks in advance for you help!

Seventh and eight paragraph of this file>>>>> Airio.srv.txt <<<<<< for large text in middle of screen
third paragraph for text in chat line

below is an example on my server....


Quote :# Large button(s) to be shown to everyone after connecting - string
# Create more buttons (max 5) by using starting/concatenating '+'.
# If also ButtnMotd (see next item) is defined, it will be shown after
# clicking OK below these large buttons.
ConnectBtn=^2THIS IS ^1NOT ^2A DRIFT OR BANGER SERVER
ConnectBtn=+^6IF YOU CHOOSE TO DO SO YOU WILL BE ^1BANNED
ConnectBtn=+^3EXCESSIVE VOTE-BANNING WILL GET YOU ^1BANNED

# These lines will appear as buttons to everyone connecting to the
# server, allowing for communicating some must-read info - string(s)
# Use "ButtnMotd=+text" to define text for individual buttons.
ButtnMotd=^3Report server/rotation issues to ^1pitissues@gmail.com

Quote from Dissector :EQ Worry, what about utf-8 BOM in PB.txt?

Well, I still do not know what problem you have with displaying exported PB.txt (Lapper) data. Wrong characters displayed? No data read? See http://cs.wikipedia.org/wiki/UTF-8#BOM to read what is BOM, it is standard identifying part of UTF-8 encoded files. Does anyone else have problems reading exported PB.txt file? If not, maybe try adapting your PHP script to read UTF-8 file and not (probably) binary data.

Quote from SirThiago :Is there anyway to put a "welcome" message when a user joins the server? For instance, i want every user that connects to the server to see a message with the server's rules, is that possible? (inside the server, not while connecting)

As Zero already pointed out, you have 3 options to display something to every new connection, all defined in appropriate SRV file: Chat lines, small buttons (up to 30 with left, center, right aligned text), big buttons (max 5, always center aligned).

Examples:

UsersMotd=^1This is 1st chat line shown to everyone on connect
UsersMotd=+^7This is 2nd line, etc.

ButtnMotd=|^2First small button, text center-aligned
ButtnMotd=+<^4Second small button, text left-aligned
ButtnMotd=+>^6Third small button, text right-aligned

ConnectBtn=^1Welcome, first big button
ConnectBtn=+^3Take care or be banned
ConnectBtn=+^4Third big button...

All updates can be applied by !rld, you can check big buttons display by !conn, small buttons by !conns. I could also mention you may create several language versions of all messages (displayed in language chosen by the driver in preferences) and also use {NickName} parameter to be replaced by connecting player's nickname, but all this only in newer Airio version.
Quote from EQ Worry :Well, I still do not know what problem you have with displaying exported PB.txt (Lapper) data. Wrong characters displayed? No data read? See http://cs.wikipedia.org/wiki/UTF-8#BOM to read what is BOM, it is standard identifying part of UTF-8 encoded files. Does anyone else have problems reading exported PB.txt file? If not, maybe try adapting your PHP script to read UTF-8 file and not (probably) binary data.

I have is empty web stats. I know what is mean BOM, I thought that you can change export method to... without "Byte Order Mark"(Lapper`s method). Anyway, thanks for answer.
Quote from Dissector :I have is empty web stats. I know what is mean BOM, I thought that you can change export method to... without "Byte Order Mark"(Lapper`s method). Anyway, thanks for answer.

Ah, i see. Well, try to understand why the script returns no data, maybe you'll be able to update it a bit and solve the issue. But when I find a free hour or so, I'll check Lapper's code used for PB.txt save/export and try to mimick it to get 100 percent compatible export file.
Hmm... is the lapper PB.txt in UTF8??

I had to change all our team tags before importing our old lapper PB.txt files to Airio...

Also some German charcaters did not show correctly (ä,ö,ü,ß). I had to change them manually too.
Everything saved with control panel on 500servers will be saved in ANSI, I have complained about this a while back and asked to change it, but it is hard coded in CP....Franky has requested it to be fixed in later updates...But CP developpers are as fast as the LFS ones...

AIRIO - Advanced LFS Tracker
(2373 posts, started )
FGED GREDG RDFGDR GSFDG