The online racing simulator
"CreateEffect failed (1 axis) could not setup FF steering device"
(20 posts, started , go to first unread)
"CreateEffect failed (1 axis) could not setup FF steering device"
Got latest version of LFS (Z) and Logitech drivers (Profiler 5.02.116). Every time I load the game I see "CreateEffect failed (1 axis) could not setup FF steering device" and the FF doesn't work in the game. Anybody seen this?,
Not really, never heard of it, I don't even use ffb on my momo, I like to turn the wheel faster
Maybe re-install drivers, and re-install LFS?
Quote from S14 DRIFT :Maybe re-install drivers, and re-install LFS?

No luck.

Anybody else here use a G25?
Quote from Eric Tetz :No luck.

Anybody else here use a G25?

I used FFEX, but had the same problem.


You must reinstall Profiler, then change in LFS ur input to kb/mice, reboot PC and then you can back switch to FF device.

It helped me, not sure about u.
Then I have no idea.
I had this problem once. Try plugging the wheel in another USB port and reinstall the drivers.
any luck with any solution, because i have the same problem...btw :bump:...btw2, you just lost the game....btw3, chuck norris won the game
Quote from Eric Tetz :Got latest version of LFS (Z) and Logitech drivers (Profiler 5.02.116). Every time I load the game I see "CreateEffect failed (1 axis) could not setup FF steering device" and the FF doesn't work in the game. Anybody seen this?,

Hi everyone, after years i'm coming back to LFS, i just upgrade my S2 license to S3 and bought a Logitech G29, but im getting this same error and FF isnt working, did someone found a fix for this?
I found the problem, I was connecting the wheel to an USB 2.0 port of my old desktop PC (i5-2400), I tried the wheel on my laptop USB 3.0 port and FF works perfect
Im going to buy an USB 3.0 PCIe card for the old PC
That is very fishy because the required USB port ver is 2.0, you probably did not have or did not install correct drivers for the wheel on the old PC (maybe you also had some older version of windows).
well, in fact I bought the USB PCIe card and it doesnt worked
Now i even bought a new PC, Ryzen 3 2200G, with fresh windows install, and same problem, i have tryed in the USB2 ports, USB3 ports and even the PCIe USB3 card too.
It's not about usb card or port, you do not have the correct drivers for a wheel on that PC, as simple as that. Which drivers did you try so far?
good
Quote from rane_nbg :good

i mean, in my new desktop pc, isnt working with same drivers that works in my laptop

any other suggestion to try?
Im Having The Same Issue, Anyone Figured This Out? I Have G29 and I Have INstalled latest Versions On Logitech HUB and LGS
Quote from williamsonaj1234 :Im Having The Same Issue, Anyone Figured This Out? I Have G29 and I Have INstalled latest Versions On Logitech HUB and LGS

Until now, i could not make it works, i put my g29 in the box, frustrated to try, if you found the way, let me know please
Olá pessoal, bom também ocorreu o mesmo problema comigo e um amigo meu, tentamos desinstalar os drivers pelo (gerenciador de dispositivos) mas não funcionou. Então vim aqui no Forum e achei essa att aqui mais recente (https://support.logi.com/hc/en-gb/articles/360024850133--Downloads-G29-Driving-Force-Racing-Wheel) Baixou tudo novamente, abri o jogo e ta normal agora, boa noite!
well, after reading RAZAO0 post i give it a new try, and now it works

i uninstalled Logitech G Hub and Logitech Gaming Center, erase everything named logitech in windows registry and in %appdata% folder

restarted the pc

installed only the logitech g hub and then plug the wheel

and it started to work

see you in the track!

"CreateEffect failed (1 axis) could not setup FF steering device"
(20 posts, started )
FGED GREDG RDFGDR GSFDG