The online racing simulator
Config help
(1028 posts, started )
The Membership Admin gui will do this as weel in that it allows you to make a racer a guest, visitor. full member or admin. Then you can just test that when they log on to see what permissions they have. No reason why it cannot be modified to be a license grading system as well.

In fact thats a good idea for an addon...
Quote from Yisc[NL] :What you really want is to set this:


Event OnNewPlayerJoin()
UserGroupFromFile( "authorised_ab_users", "./Authorisation.txt" );
$userName = GetCurrentPlayerVar ( "UserName" );
IF( UserInGroup( "authorised_ab_users",$userName ) != 1 )
THEN
cmdLFS("/spec " . GetCurrentPlayerVar("Nickname") );
cmdLFS("/msg " . GetCurrentPlayerVar("Nickname") . "^3 not allowed on this server");
ENDIF
EndEvent

This way only the people mentioned (you will need their LFS world names, instead of the nicknames they use) in your Authorisation.txt will have access to your server. If you are not on that list, you will get spectated (/spec) and get a message (/msg) that your not allowed on this server.

thnx Yisc[NL] for replay

i did what u say capy&paste on lfslapper.lpr

but about the Authorisation.txt !! i made 1 txt Next to the lfslapper.lpr

and i make Edit for default_1 To type $ApprovedFile = "./Authorisation.txt";

when i restart lfslapper >> nothing happen !!
Attached images
default_1.jpg
Authorisation.jpg
There is no need to place this in default_1.ini : $ApprovedFile = "./Authorisation.txt";

I have just tested the code myself (with the new uploaded Lapper version 6.0.1.3) and I spotted a small error in the code I gave you earlier, this is the right code:


##########################################
#New PLayer joining race or leaving pits)#
##########################################

Event OnNewPlayerJoin( $userName ) # Player event
UserGroupFromFile( "authorised_users", "./Authorisation.txt" );
$userName = GetCurrentPlayerVar ( "UserName" );
IF( UserInGroup( "authorised_users",$userName ) != 1 )
THEN
cmdLFS("/spec " . GetCurrentPlayerVar("Nickname") );
cmdLFS("/msg " . GetCurrentPlayerVar("Nickname") . "^3 not allowed on this server");
ENDIF
EndEvent

Further you have to make sure the Authorisation.txt is in the same place as your LFSLapper.lpr file , and to put one username per line in the Authorisation.txt , like this:

yisc[nl]
ViKTOOR-LFS
Kravy
Quote from Yisc[NL] :There is no need to place this in default_1.ini : $ApprovedFile = "./Authorisation.txt";

I have just tested the code myself (with the new uploaded Lapper version 6.0.1.3) and I spotted a small error in the code I gave you earlier, this is the right code:


##########################################
#New PLayer joining race or leaving pits)#
##########################################

Event OnNewPlayerJoin( $userName ) # Player event
UserGroupFromFile( "authorised_users", "./Authorisation.txt" );
$userName = GetCurrentPlayerVar ( "UserName" );
IF( UserInGroup( "authorised_users",$userName ) != 1 )
THEN
cmdLFS("/spec " . GetCurrentPlayerVar("Nickname") );
cmdLFS("/msg " . GetCurrentPlayerVar("Nickname") . "^3 not allowed on this server");
ENDIF
EndEvent

Further you have to make sure the Authorisation.txt is in the same place as your LFSLapper.lpr file , and to put one username per line in the Authorisation.txt , like this:

yisc[nl]
ViKTOOR-LFS
Kravy

already did what u told me
but this Code not working with me !
Could you upload your LFSLapper.lpr file here?
You have to rename it to *.txt and then will be able to upload it, so I can have a look.
Which version of Lapper are you using?
Quote from Yisc[NL] :Could you upload your LFSLapper.lpr file here?
You have to rename it to *.txt and then will be able to upload it, so I can have a look.
Which version of Lapper are you using?

LFSLapper, Version=6.0.1.2 by Robert BRACCAGNI ( Gai-Luron )
Attached files
LFSLapper.txt - 69.9 KB - 75 views
Quote from ViKTOOR-LFS :LFSLapper, Version=6.0.1.2 by Robert BRACCAGNI ( Gai-Luron )

I've tested your file in Lapper 6.0.1.2 and it's working instantly.
As soon as I try to join, I get the message that I am not allowed.
When I then put my name in the Authorisation.txt , I can immediatly join the server, without having to restart Lapper.

Does Lapper make any connection to your LFS server at all?
Have you opened an insim port on your LFS server?
To do that, type this into the LFS chat: /insim 29999
That portnumber must be the same as set in your default_1.ini

This is my LFSServers.cfg:


# Configuration of LFSServer to be Managed with LFSLapper
# One line per server
# Remote port is the port used to manage LFSLapper remotely, future extension
# One remote port per LFSLapper on one machine, autoStart is optionnal
#Unique ID|GroupId|Ip|Port|WorkDir|IniFile|autowork
timeOutScript=10000;
remotePort=3001;
DEF1|gr1|127.0.0.1|29999|./default|default_1.ini|autowork

And this in my default_1.ini:


$password = "changeme";
$configFile = "LFSLapper.lpr";
$superUsersFile = "superusers.txt";

Quote from Yisc[NL] :I've tested your file in Lapper 6.0.1.2 and it's working instantly.
As soon as I try to join, I get the message that I am not allowed.
When I then put my name in the Authorisation.txt , I can immediatly join the server, without having to restart Lapper.

Does Lapper make any connection to your LFS server at all?
Have you opened an insim port on your LFS server?
To do that, type this into the LFS chat: /insim 29999
That portnumber must be the same as set in your default_1.ini

This is my LFSServers.cfg:


# Configuration of LFSServer to be Managed with LFSLapper
# One line per server
# Remote port is the port used to manage LFSLapper remotely, future extension
# One remote port per LFSLapper on one machine, autoStart is optionnal
#Unique ID|GroupId|Ip|Port|WorkDir|IniFile|autowork
timeOutScript=10000;
remotePort=3001;
DEF1|gr1|127.0.0.1|29999|./default|default_1.ini|autowork

And this in my default_1.ini:


$password = "changeme";
$configFile = "LFSLapper.lpr";
$superUsersFile = "superusers.txt";


bro my server working with 500servers from Control Panel Login
http://www.500control.co.uk

lfslapper is already start no proplem with that

they have Different numbers inside LFSServers.cfg to make lfslapper working.

remotePort=3918;
^7Saudi_Arabia_Cruise|gr1|84.45.52.141|17684|./default|default_1.ini|autowork

and default_1.ini i have same yours

but this code !! I do not know why this still not working

I am surprised that it worked well with you

if you want take a look to server :saudi_arabia_criuse

maby there is something should we do inside (addonsused.lpr) or Something Missing.

include ("./gui.lpr");
include( "./utils.lpr");
include( "./myInc.lpr");
# Help GUI


#### Include for splitting infos ####
#include( "./pitboard.lpr");
include( "./pitwindow_gui.lpr");
# OR
#include( "./defPitInfo.lpr");
#####################################

#### Include for drifting infos ####
#include( "./driftdef.lpr");
# OR
#include( "./driftmeter.lpr");
#####################################

include ("./debug.lpr");
# GUI Framework main include - this MUST be first
include ("./gui.lpr");

# Help GUI
include ("./gui_help.lpr"); # Multi-tabbed help (all in one)

# Admin GUI
include ("./gui_admin.lpr"); # Admin GUI root include
include ("./gui_admin_membership.lpr"); # Admin GUI Membership administration
include ("./gui_admin_handicaps.lpr"); # Admin GUI Handicap allocations

include ("./gui_help_cruise.lpr"); # Cruise help file (remove if not reqd)
include( "./safetycar.lpr");
include( "./ctrack.lpr");
#include( "./Cruise.lpr");
#include( "./Cruise_Settings.lpr");
include( "./guiconfig.lpr");
include( "./racecontrol.lpr");
include( "./who.lpr");
include( "./tops.lpr");
include ("./cif/info_newbie.lpr");
include( "./listevent.lpr");
#include( "./winnerflags.lpr");
include( "./scripts.lpr");
include ("./cif/help_custom.lpr");
include ("./cif/help_stats.lpr");
include ("./cif/help_admin.lpr");
include ("./cif/help_general.lpr");
include ("./cif/info_mystats.lpr"); # MyStats Information
include ("./cif/info_rules.lpr"); # Server Rules

Could you upload the logfile please?
You can find them in the folder "logs" and then you will need: 84.45.52.141-17684-ERR.log
Quote from Yisc[NL] :Could you upload the logfile please?
You can find them in the folder "logs" and then you will need: 84.45.52.141-17684-ERR.log

yea sure

LFSLapper-MSS.txt

LFSLapper-ERR.txt<< i cant upload it .txt in lfsforum coz its 1.47 MB so i but it inside .rar
Attached files
LFSLapper-MSS.txt - 23.9 KB - 25 views
LFSLapper-ERR.rar - 44.8 KB - 22 views
Those are the log files of Lapper it self.
Inside the "default" directory, you will find another "logs" directory and I need the ERR file from there please.
:
Quote from yisc[nl] :those are the log files of lapper it self.
Inside the "default" directory, you will find another "logs" directory and i need the err file from there please.

84.45.52.141-17684-err

i open it and i found 2 txt file inside /default/Text_Files

but when i was searching for admin1,admin2 on google i found
http://www.lfsforum.net/showthread.php?p=1694998
i think this what you want from me to go >> listevent.lpr !!

CatchEvent OnLapperStart()

GlobalVar $arToClose;
GlobalVar $currUserGroup;
GlobalVar $pathAdminFile;
$pathAdminFile = "./Text_Files";

EndCatchEvent

CatchEvent OnMSO( $UserName, $text ) # Player event

$idxOfFirtsSpace = indexOf( $text, " ");
IF( $idxOfFirtsSpace == -1 ) THEN
$command = $text;
$argv = "";
ELSE
$command = subStr( $text,0,$idxOfFirtsSpace );
$argv = trim( subStr( $text,$idxOfFirtsSpace ) );
ENDIF
userGroupFromFile( "admin1",$pathAdminFile . "/admin1.txt");
UserGroupFromFile( "admin2",$pathAdminFile . "/admin2.txt");
SWITCH( Tolower( $command ) )
CASE "!ug":
IF( UserInGroup( "admin1",$UserName ) == 1 || UserInGroup( "admin2",$UserName ) == 1 )
THEN
IF ( $argv != "" ) THEN
privMsg("^6ADMIN - ^3CURRENT REGISTERED DRIVERS....");
$currUserGroup = $argv;
PrintUserGroup($currUserGroup);
ELSE
privMsg("^6ADMIN - YOU MUST SPECIFY A GROUP TO LIST");
ENDIF
ELSE
privMsg("^6ADMIN - ^2YOU DO NOT HAVE ADMIN STATUS!");
ENDIF
BREAK;
ENDSWITCH
EndCatchEvent

Attached images
Untitled.jpg
Attached files
84.45.52.141-17684-ERR.rar - 35.7 KB - 14 views
Hmm, the log file doesn't show any problems regarding the event we are talking about.
So I only have one last solution, make a RAR file of the whole Lapper directory and upload it here.
I will download that and start your Lapper on a test server of mine.
Quote from Yisc[NL] :Hmm, the log file doesn't show any problems regarding the event we are talking about.
So I only have one last solution, make a RAR file of the whole Lapper directory and upload it here.
I will download that and start your Lapper on a test server of mine.

okey ..
Attached files
Lfslapper.rar - 1.8 MB - 19 views
I have tried to find the problem in your installation of Lapper, but it is so messed up, I gave up in the end.
I have created a new installation using Lapper 6.0.1.3 with the desired functionality we have been talking about all the time.
Download and unzip it, then customize the scripts to your likings and remember, files have a specific place for a reason, you can't just move them around, merge sub-directories etc.
Attached files
LFSLapper6.013.zip - 2 MB - 43 views
Quote from Yisc[NL] :I have tried to find the problem in your installation of Lapper, but it is so messed up, I gave up in the end.
I have created a new installation using Lapper 6.0.1.3 with the desired functionality we have been talking about all the time.
Download and unzip it, then customize the scripts to your likings and remember, files have a specific place for a reason, you can't just move them around, merge sub-directories etc.

im sorry to till u lfslapper u give me. not working at all !

1-Delete all files of old version
2-upload Lapper 6.0.1.3
3-unzip
4-i Edit only 2 file
LFSServers.cfg Edit
# Configuration of LFSServer to be Managed with LFSLapper
# One line per server
# Remote port is the port used to manage LFSLapper remotely, future extension
# One remote port per LFSLapper on one machine, autoStart is optionnal
#Unique ID|GroupId|Ip|Port|WorkDir|IniFile|autowork
timeOutScript=2000;
remotePort=3001;
#DEF1|gr1|127.0.0.1|31993|./default|default_1.ini|autowork
[B]^7Saudi_Arabia_Cruise[/B]|gr1|84.45.52.141|17684|./default|default_1.ini|autowork
#SAC|gr1|127.0.0.1|17684|./default|default_1.ini|autowork

default_1.ini Edit
for exp
$password = "viktoor_lfs";

No problem bro its not very important if we did not find the solution : D

I hope I did not bother you
The Lapper I gave you is a clear download from this forum, in which I only added your server name (there is no need to put the name with colour tags there, nobody will see it) and insim port number. Then I added the code needed for authorisation and tested everything on a test server. So there is no way of it not working.

*edit*
I have currently 7 LFS server with Lapper running and I've written a lof of add-ons over the years, so I think I know my way around Lapper.
I'm sorry but I have invested enough time into this now and won't help you any further.
Quote from Yisc[NL] :The Lapper I gave you is a clear download from this forum, in which I only added your server name (there is no need to put the name with colour tags there, nobody will see it) and insim port number. Then I added the code needed for authorisation and tested everything on a test server. So there is no way of it not working.

*edit*
I have currently 7 LFS server with Lapper running and I've written a lof of add-ons over the years, so I think I know my way around Lapper.
I'm sorry but I have invested enough time into this now and won't help you any further.

its okey bro
Thanks for your time
hi again

sorry guys if i'm disturbed

but yastrday my lfslapper shotdown on 500servers for no resoin !!

can anyone know what happen !!

this is my ERR.TXT

thnx & Regard .
Attached files
84.45.52.141-17684-ERR.rar - 18 KB - 14 views
There appear to be a couple of issues, but the biggest seems to be a timing issue when lapper trying to save data - the error appears as
Time Out in Event or Sub 2000 ms

Yisc[NL] had this issue and found a workaround - see his post http://www.lfsforum.net/showthread.php?p=1685079#post1685079.

Basically, he amended his LFSServers.cfg file, and changed timeOutScript=2000; to timeOutScript=10000;

2000 maybe 2000 milliseconds (2 seconds)?

Rather than changing timeOutScript to 10000, change it to say 5000 and see if that gets rid of your error. If it doesn't, keep making it bigger.

PS Edit your error log, and delete everything in it, so that if you post it again, we can see only the current errors.
Quote from sinanju :There appear to be a couple of issues, but the biggest seems to be a timing issue when lapper trying to save data - the error appears as
Time Out in Event or Sub 2000 ms

Yisc[NL] had this issue and found a workaround - see his post http://www.lfsforum.net/showthread.php?p=1685079#post1685079.

Basically, he amended his LFSServers.cfg file, and changed timeOutScript=2000; to timeOutScript=10000;

2000 maybe 2000 milliseconds (2 seconds)?

Rather than changing timeOutScript to 10000, change it to say 5000 and see if that gets rid of your error. If it doesn't, keep making it bigger.

PS Edit your error log, and delete everything in it, so that if you post it again, we can see only the current errors.

To be honest with you This code new steps for me

what u mean about timeOutScript is this on lfslapper.lpr or just i add inside the LFSServers.cfg !!
It's part of the LFSServers.cfg script


<?php 
#    Configuration of LFSServer to be Managed with LFSLapper
# One line per server
# Remote port is the port used to manage LFSLapper remotely, future extension
# One remote port per LFSLapper on one machine, autoStart is optionnal
#Unique ID|GroupId|Ip|Port|WorkDir|IniFile|autowork
timeOutScript=2000;
remotePort=3001;
DEF1|gr1|127.0.0.1|29999|./default|default_1.ini|autowork
?>


(Shown here as 1st line in blue)
-
(Gai-Luron) DELETED by Gai-Luron
Hello,

A timeout of 2000ms (2s) is very inportant!!!

Maybe the server on 500servers is very slow and freeze.
Maybe you have a loop without exit condition.

Very strange, i repeat 2000ms is big. Try to change it to 5000ms, but more than 5000 is not normal

Gai-Luron
Quote from sinanju :It's part of the LFSServers.cfg script


<?php 
#    Configuration of LFSServer to be Managed with LFSLapper
# One line per server
# Remote port is the port used to manage LFSLapper remotely, future extension
# One remote port per LFSLapper on one machine, autoStart is optionnal
#Unique ID|GroupId|Ip|Port|WorkDir|IniFile|autowork
timeOutScript=2000;
remotePort=3001;
DEF1|gr1|127.0.0.1|29999|./default|default_1.ini|autowork
?>


(Shown here as 1st line in blue)

sinanju .. i try it All of these numbers 2000 & 5000 & 10000 & 20000 . Still the same problem !!

Quote from Gai-Luron :Hello,

A timeout of 2000ms (2s) is very inportant!!!

Maybe the server on 500servers is very slow and freeze.
Maybe you have a loop without exit condition.

Very strange, i repeat 2000ms is big. Try to change it to 5000ms, but more than 5000 is not normal

Gai-Luron

welcom Gai-Luron

i think its all about 500servers coz when i want to press start lfslapper its takes long time to show me Running . also when i stop it . maby takes 30 sec !! for Minimum
Attached images
exp.JPG
EXP2.JPG
EXP3.JPG
You can't have 2 versions of lapper running at same time, which is what you're trying to do with one LFS server.

Stop one, and restart the other.

Unless there's something specific that you want in Krayy's V6.013, then I'd advise stopping that one, and leaving your original lapper running, as that's likely to be setup the way you want it and have developed it over last few months or so.

I would also advise that for any lapper changes you want to make, you try them on your local pc (127.0.0.1), then if you're happy everything appears to be working, then copy the amended files onto 500Servers.

Config help
(1028 posts, started )