The online racing simulator
Guide: Running an LFS Server
(707 posts, started )
A big help is to understand how to set up your router! Once you enter portforward all you do is select your make and model of router from a very extended list and it will ask you for what application, LFS Server is listed so it tells you exactly what to do!
finally i managed to start the dedicated linux server with xing. now i have a new problem. when i use nogfx the server will start and runs perfect. but i cant close the xwindow (server would shut down). so i tried to use invisible. but the server wont start (screen is always terminating). what can i do? please help
Either start the dedi within a screen session (man screen), or run it under nohup. In either of these situations once you disconnect the server should continue to run.
i tried to start the server with screen and nohup. both do not working after i logout. the server always shut down. what can i do that the server wont shut down after i logout and close the xwindow?
In a terminal:
[press enter]
wineconsole lfs.exe /cfg=/path/to/config
[press control + a, press d]

If that doesn't work then you're probably actually running LFS with a visible window and therefore a server with running (therefore not "invisible")?
thx for your help but your hint did not work. but it was my fault i did not setup the display correct. for all linux users out there who have the same problem just export your display

localhost:10.0 (if you get this localhost message you have to change it with the following command)
export DISPLAY=ip.of.your.server:1.0
wine LFS.exe /cfg=setup.cfg

I have been trying for a few hours now to get a dedicated server running for my clan. I have followed the guide and opened the ports on my router. The server will not work, it will not appear on the server list either. Anyone want to try and join it?

The server is on now!

EDIT: I have opened the ports etc correctly now and whenever I start the server I get this...

What does the "SetupServerSocket ; bind failed" error mean? This is really confusing me now!
HI, it won't show up on the server list within LFS for you. It will for others. If you want to check if its showing, login to the LFS Desktop, and open Hosts online, and look for your server there. Mine never shows up in the lists in lfs. But it works great

Just hit Join rather than display lists.

As to your error. Not sure. Did you reset your modem after you setup the ports? I'd say go back to what you were doign first time; it was working then, as it said it was Online. Just make sure u reset your router after you get all ur port info in. Remember u need TCP and UDP forwarded.

I just started all over again and made a new .cfg and I reset the settings on the router. I then opened the ports again and probed them to check if they were open.

I still get the "SetupServerSocket : bind failed" error when I run the server. LOL
Quote from T1_3VOM :I still get the "SetupServerSocket : bind failed" error when I run the server. LOL

Have you set the /ip directive?

Do I need to stab you in the face for ignoring the advice of not setting it?

If you've not set it then you have a firewall or another program consuming the ports LFS uses.

If you're unsure, paste your config.
Well as far as I know I have the right IP address entered. For some reason when I restarted my computer is loaded the track and it says it is online. Only problem is when I try to join the server specifically it looks as if it is loading then goes straight back to the screen it was at before. I am still not sure.


That is the CFG file there. If anyone wants to try and go to the server now then please go ahead and try. It will be on for as long as it can tonight.
running a server

I have a similar problem that Kinght had wayy back on the first page:

My server will not appear on the master server list as well. The only thing I can think of is the port... In Lfs, they say to make sure you are using the right UDP/TDP ports. How do I know if mine is right or not. If it isn't, can you somehow give me a good port to use?

Maybe this will help too: When I try to connect under "join specific game", it says client connect: connected failed

Whilst it's probably right, unless you have a multi-homed machine, I'd still recommend not supplying the /ip directive.

I can't see the game in the masterserver list at the moment, so perhaps it's shutdown, or simply not registering. In which case, take a look at the stuff below. If it's not up, then I apologise as I was out.

Have you checked LFSWorld, and gotten someone else to check? Some home routers can't deal with the loopback required when connecting from the same location as the server is running and basically don't report it as active in the in-game list. In this instance you have no choice but to connect via local address, as there's no fix for it except changing routers.

If it's not registered on LFSWorld, then the fact it's not registered on the masterserver suggests you have an outgoing firewall that's preventing LFS from contacting the masterserver. This maybe due to your own setup, or due to your ISP. Failing that, you've told LFS not to use the master server. Assuming you've not set /usemaster=no;

Do you have Norton Internet Security or anything like that? Windows firewall perhaps. Have you taken a look at the Windows Firewall section?

You might want to try editing the Master Server configuration in cfg.txt and change the port number to 8080 (an alternative port the Master Server is available on). If that works then it's the fault of your ISP.

If it doesn't work then you've likely got a local firewall on your network. Temporarily disable them to test and then check LFSWorld.
Not sure who that was directed to but the server is listed on LFSWorld but I have been asking around for people to try and join but with no luck. They are either busy or jsut plainly can't be bothered. I will find someone though to try it!
T1_3VOM, there were 2 responses in my last post. One for you and one for MBenz. This is for you.

I'm being a cock tonight apparently. You're quite right it is registered on the master server.

It appears that it's not answering, which goes back to the bind error, which I assume you're still getting? In which case, either something else is using the ports, or you're binding to the wrong address. In which case, remove the /ip directive and restart the server. IF you still get it then you've got something else using the ports. Another LFS server, a firewall, anything. A p2p client perhaps.
I have removed the /ip directive and restarted the server. Still is unresponsive though. Is there any way to check if another program is using those ports? I know I don't have another LFS Server.
thank you so much you have been so helpful

but unfortuantely i am retarted and can't figure out how to register on LFS World. where do u go?
Go to google and search for "lfs desktop", then the first link will take you to LFSW!
thanks for your help,

Yup it is registered on the website. When I connect the server to the master server, there seems to be no problem whatsoever. It says satus Online, and then lower it says Track loaded. Under "host 8080" here is the information there:

host=LM racing server

If anything seems wrong or out of the ordinary with that, please let me know. Also if you wouldn't mind, please try logging on the the server "LM racing server." Whenever i try to connect to it via "join specific game" it says CLIENT CONNECTL:CONNECT FAILED. what in the world does that mean?

Thank you for your support

P.S I have tried making both dedicative, and non-dedicative servers and both do not work
Yea whenever I try to join my game specifically I get the "CLIENT CONNECT: CONNECT FAILED" error but when I enter the admin password and try again it looks as if it is about to connect but it then just returns to the 'Join Specific Game' screen without giving any error what-so-ever. Exactly what MBenz said, what does that mean?

Ports not forwarded.
If my ports are not forwarded then why does Shield's Up say that they are open? I think they are in stealth mode but open. That is what I presume 'stealth' means. *see attached*
Attached images
29339 port probe.PNG
63392 port probe.PNG
do you have to forward your ports even if you do not have a firewall up?
I would say so. Think of ports as a door. It needs to be open for people to enter through but if it is closed no access can be gained.

I have been reading up on stealth and it turns out that I do not want them to be in stealth mode. So does anyone know how to change my ports from 'stealth' to 'open'? I have been searching like mad but still have no luck!

Thanks again.
Ports can be typically marked as stealth because whilst the port is open, and a TCP/IP handshake occurs, nothing is actually responding, or transmitting packets from the destination.

You usually get this if the ports are forwarded on a home router, to the incorrect location, or if there's another firewall in the way.

Guide: Running an LFS Server
(707 posts, started )